2
0
Fork 0

Remove borken patch

This commit is contained in:
Arti Zirk 2021-11-05 21:07:00 +02:00
parent 62034828ee
commit e55198615c
3 changed files with 4 additions and 53 deletions

1
.gitignore vendored
View File

@ -3,3 +3,4 @@ astroid
src
*.tar.gz
pkg
*.pkg.*

View File

@ -2,7 +2,7 @@
# Maintainer: Alad Wenter <alad@archlinux.org>
pkgname=astroid-git
_pkgname=astroid
pkgver=v0.15.r13.gb675b42
pkgver=v0.16.r1.g4d6b06a
pkgrel=1
pkgdesc="a graphical threads-with-tags style, lightweight and fast, email client for notmuch, inspired by sup and others"
arch=('x86_64' 'i686')
@ -18,16 +18,8 @@ optdepends=('gvim: default editor'
'cmark: for markdown to html composition')
provides=('astroid')
conflicts=('astroid')
source=("git+https://github.com/astroidmail/astroid.git"
"test_compose.patch")
md5sums=('SKIP'
'75188a53e85c7d80f7553d2cc38d5bb3')
prepare() {
cd "$_pkgname"
patch -p2 < "$srcdir"/test_compose.patch
}
source=("git+https://github.com/astroidmail/astroid.git")
md5sums=('SKIP')
pkgver() {
cd "$_pkgname"

View File

@ -1,42 +0,0 @@
diff --unified --recursive --text src.old/astroid-0.15/tests/test_composed_message.cc src.new/astroid-0.15/tests/test_composed_message.cc
--- src.old/astroid-0.15/tests/test_composed_message.cc 2019-07-17 13:25:08.000000000 +0200
+++ src.new/astroid-0.15/tests/test_composed_message.cc 2019-07-19 11:58:45.275305696 +0200
@@ -12,6 +12,8 @@
BOOST_AUTO_TEST_SUITE(Composing)
+ ustring newline = "\n";
+
BOOST_AUTO_TEST_CASE(compose_read_test)
{
using Astroid::ComposeMessage;
@@ -47,6 +49,9 @@
ustring rbdy = m.plain_text (false);
+ // Fixme: hotfix
+ bdy += newline;
+
BOOST_CHECK_MESSAGE (bdy == rbdy, "message reading produces the same output as compose message input");
unlink (fn.c_str ());
@@ -81,6 +86,9 @@
ustring rbdy = m.plain_text (false);
+ // Fixme: hotfix
+ bdy += newline;
+
BOOST_CHECK_MESSAGE (bdy == rbdy, "message reading produces the same output as compose message input");
teardown ();
@@ -208,6 +216,9 @@
ustring rbdy = m.plain_text (false);
+ // Fixme: hotfix
+ bdy += newline;
+
BOOST_CHECK_MESSAGE (bdy == rbdy, "message reading produces the same output as compose message input");
unlink (fn.c_str ());