Cleanup and add shell completions
This commit is contained in:
parent
4f9993dc9b
commit
2713c6b804
9
.SRCINFO
9
.SRCINFO
@ -1,16 +1,15 @@
|
|||||||
pkgbase = git-subrepo-git
|
pkgbase = git-subrepo-git
|
||||||
pkgdesc = Git command is an improvement from git-submodule and git-subtree.
|
pkgdesc = Git Submodule Alternative
|
||||||
pkgver = 0.3.0.r72.g1e79595
|
pkgver = 0.4.3.r1.g2f68596
|
||||||
pkgrel = 1
|
pkgrel = 1
|
||||||
url = https://github.com/ingydotnet/git-subrepo
|
url = https://github.com/ingydotnet/git-subrepo
|
||||||
arch = any
|
arch = any
|
||||||
license = GPL
|
license = GPL
|
||||||
provides = git-subrepo=0.3.0.r72.g1e79595
|
depends = git
|
||||||
|
provides = git-subrepo=0.4.3.r1.g2f68596
|
||||||
conflicts = git-subrepo
|
conflicts = git-subrepo
|
||||||
source = git-subrepo::git+https://github.com/ingydotnet/git-subrepo.git
|
source = git-subrepo::git+https://github.com/ingydotnet/git-subrepo.git
|
||||||
source = make-destdir.patch
|
|
||||||
md5sums = SKIP
|
md5sums = SKIP
|
||||||
md5sums = ee9d7137bb4fe4b0cc7da8f669e26ddf
|
|
||||||
|
|
||||||
pkgname = git-subrepo-git
|
pkgname = git-subrepo-git
|
||||||
|
|
||||||
|
21
PKGBUILD
21
PKGBUILD
@ -2,18 +2,17 @@
|
|||||||
|
|
||||||
pkgname=git-subrepo-git
|
pkgname=git-subrepo-git
|
||||||
_pkgname=${pkgname%-git}
|
_pkgname=${pkgname%-git}
|
||||||
pkgver=0.3.0.r72.g1e79595
|
pkgver=0.4.3.r1.g2f68596
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc="Git command is an improvement from git-submodule and git-subtree."
|
pkgdesc='Git Submodule Alternative'
|
||||||
arch=('any')
|
arch=('any')
|
||||||
url="https://github.com/ingydotnet/$_pkgname"
|
url="https://github.com/ingydotnet/$_pkgname"
|
||||||
license=('GPL')
|
license=('GPL')
|
||||||
provides=("$_pkgname=$pkgver")
|
provides=("$_pkgname=$pkgver")
|
||||||
conflicts=("$_pkgname")
|
conflicts=("$_pkgname")
|
||||||
source=("$_pkgname"::"git+$url.git"
|
source=("$_pkgname"::"git+$url.git")
|
||||||
make-destdir.patch)
|
md5sums=('SKIP')
|
||||||
md5sums=('SKIP'
|
depends=(git)
|
||||||
'ee9d7137bb4fe4b0cc7da8f669e26ddf')
|
|
||||||
|
|
||||||
pkgver() {
|
pkgver() {
|
||||||
cd "$_pkgname"
|
cd "$_pkgname"
|
||||||
@ -24,10 +23,10 @@ pkgver() {
|
|||||||
)
|
)
|
||||||
}
|
}
|
||||||
|
|
||||||
prepare() {
|
build() {
|
||||||
cd "$_pkgname"
|
cd "$_pkgname"
|
||||||
|
|
||||||
patch -p1 < ../make-destdir.patch
|
make compgen
|
||||||
}
|
}
|
||||||
|
|
||||||
check() {
|
check() {
|
||||||
@ -40,4 +39,10 @@ package() {
|
|||||||
cd "$_pkgname"
|
cd "$_pkgname"
|
||||||
|
|
||||||
make DESTDIR="$pkgdir" PREFIX=/usr install
|
make DESTDIR="$pkgdir" PREFIX=/usr install
|
||||||
|
|
||||||
|
install -d -m 0755 "$pkgdir"/usr/share/bash-completion/completions
|
||||||
|
install -C -m 0644 share/completion.bash "$pkgdir"/usr/share/bash-completion/completions/git-subrepo
|
||||||
|
|
||||||
|
install -d -m 0755 "$pkgdir"/usr/share/zsh/site-functions
|
||||||
|
install -C -m 0644 share/zsh-completion/_git-subrepo "$pkgdir"/usr/share/zsh/site-functions/_git-subrepo
|
||||||
}
|
}
|
||||||
|
@ -1,24 +0,0 @@
|
|||||||
diff --git a/Makefile b/Makefile
|
|
||||||
index 1239b9f..764bd65 100644
|
|
||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -15,9 +15,9 @@ SHARE = share
|
|
||||||
|
|
||||||
# Install variables:
|
|
||||||
PREFIX ?= /usr/local
|
|
||||||
-INSTALL_LIB ?= $(shell git --exec-path)
|
|
||||||
+INSTALL_LIB ?= $(DESTDIR)$(shell git --exec-path)
|
|
||||||
INSTALL_EXT ?= $(INSTALL_LIB)/$(NAME).d
|
|
||||||
-INSTALL_MAN1 ?= $(PREFIX)/share/man/man1
|
|
||||||
+INSTALL_MAN1 ?= $(DESTDIR)$(PREFIX)/share/man/man1
|
|
||||||
|
|
||||||
# Basic targets:
|
|
||||||
default: help
|
|
||||||
@@ -36,6 +36,7 @@ test:
|
|
||||||
|
|
||||||
# Install support:
|
|
||||||
install:
|
|
||||||
+ install -C -d -m 0755 $(INSTALL_LIB)/
|
|
||||||
install -C -m 0755 $(LIB) $(INSTALL_LIB)/
|
|
||||||
install -C -d -m 0755 $(INSTALL_EXT)/
|
|
||||||
install -C -m 0755 $(EXTS) $(INSTALL_EXT)/
|
|
Loading…
Reference in New Issue
Block a user