2
0
Fork 0

Cleanup and add shell completions

This commit is contained in:
Arti Zirk 2021-02-18 12:42:56 +02:00
parent 4f9993dc9b
commit 2713c6b804
3 changed files with 17 additions and 37 deletions

View File

@ -1,16 +1,15 @@
pkgbase = git-subrepo-git
pkgdesc = Git command is an improvement from git-submodule and git-subtree.
pkgver = 0.3.0.r72.g1e79595
pkgdesc = Git Submodule Alternative
pkgver = 0.4.3.r1.g2f68596
pkgrel = 1
url = https://github.com/ingydotnet/git-subrepo
arch = any
license = GPL
provides = git-subrepo=0.3.0.r72.g1e79595
depends = git
provides = git-subrepo=0.4.3.r1.g2f68596
conflicts = git-subrepo
source = git-subrepo::git+https://github.com/ingydotnet/git-subrepo.git
source = make-destdir.patch
md5sums = SKIP
md5sums = ee9d7137bb4fe4b0cc7da8f669e26ddf
pkgname = git-subrepo-git

View File

@ -2,18 +2,17 @@
pkgname=git-subrepo-git
_pkgname=${pkgname%-git}
pkgver=0.3.0.r72.g1e79595
pkgver=0.4.3.r1.g2f68596
pkgrel=1
pkgdesc="Git command is an improvement from git-submodule and git-subtree."
pkgdesc='Git Submodule Alternative'
arch=('any')
url="https://github.com/ingydotnet/$_pkgname"
license=('GPL')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
source=("$_pkgname"::"git+$url.git"
make-destdir.patch)
md5sums=('SKIP'
'ee9d7137bb4fe4b0cc7da8f669e26ddf')
source=("$_pkgname"::"git+$url.git")
md5sums=('SKIP')
depends=(git)
pkgver() {
cd "$_pkgname"
@ -24,10 +23,10 @@ pkgver() {
)
}
prepare() {
build() {
cd "$_pkgname"
patch -p1 < ../make-destdir.patch
make compgen
}
check() {
@ -40,4 +39,10 @@ package() {
cd "$_pkgname"
make DESTDIR="$pkgdir" PREFIX=/usr install
install -d -m 0755 "$pkgdir"/usr/share/bash-completion/completions
install -C -m 0644 share/completion.bash "$pkgdir"/usr/share/bash-completion/completions/git-subrepo
install -d -m 0755 "$pkgdir"/usr/share/zsh/site-functions
install -C -m 0644 share/zsh-completion/_git-subrepo "$pkgdir"/usr/share/zsh/site-functions/_git-subrepo
}

View File

@ -1,24 +0,0 @@
diff --git a/Makefile b/Makefile
index 1239b9f..764bd65 100644
--- a/Makefile
+++ b/Makefile
@@ -15,9 +15,9 @@ SHARE = share
# Install variables:
PREFIX ?= /usr/local
-INSTALL_LIB ?= $(shell git --exec-path)
+INSTALL_LIB ?= $(DESTDIR)$(shell git --exec-path)
INSTALL_EXT ?= $(INSTALL_LIB)/$(NAME).d
-INSTALL_MAN1 ?= $(PREFIX)/share/man/man1
+INSTALL_MAN1 ?= $(DESTDIR)$(PREFIX)/share/man/man1
# Basic targets:
default: help
@@ -36,6 +36,7 @@ test:
# Install support:
install:
+ install -C -d -m 0755 $(INSTALL_LIB)/
install -C -m 0755 $(LIB) $(INSTALL_LIB)/
install -C -d -m 0755 $(INSTALL_EXT)/
install -C -m 0755 $(EXTS) $(INSTALL_EXT)/