You cannot select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
33 lines
1.0 KiB
Bash
33 lines
1.0 KiB
Bash
# Maintainer: Arti Zirk <arti.zirk@gmail.com>
|
|
|
|
pkgname=rauc
|
|
pkgver=1.8
|
|
pkgrel=1
|
|
pkgdesc="RAUC controls the update process on embedded linux systems. It is both a target application that runs as an update client and a host/target tool that allows you to create, inspect and modify installation artifacts."
|
|
arch=('i686' 'x86_64')
|
|
url="https://github.com/rauc/rauc"
|
|
license=('GPL')
|
|
depends=('curl' 'json-glib')
|
|
makedepends=('python')
|
|
optdepends=(
|
|
'casync: Casync integration support'
|
|
'squashfs-tools: Extract or print the info of a bundle'
|
|
)
|
|
source=(https://github.com/$pkgname/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz
|
|
https://github.com/$pkgname/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.xz.asc)
|
|
sha256sums=('d233247c1763b1c56c851d0adef2094b7aa2fcd72decf524a8ac0419188e0978'
|
|
'SKIP')
|
|
validpgpkeys=('977843FD5C3EBF76BAD4008EA58CC53DBF05E090')
|
|
|
|
build() {
|
|
cd $srcdir/$pkgname-$pkgver
|
|
./configure --prefix=/usr
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd $srcdir/$pkgname-$pkgver
|
|
make DESTDIR=$pkgdir install
|
|
}
|
|
# vim:syntax=sh
|