57 lines
1.5 KiB
Bash
57 lines
1.5 KiB
Bash
# Maintainer: Antonin Décimo <antonin dot decimo at gmail dot com>
|
|
# Contributor: Adrian Perez de Castro <aperez@igalia.com>
|
|
pkgname=wlroots-hidpi
|
|
pkgver=0.13.0
|
|
pkgrel=1
|
|
license=(custom:MIT)
|
|
pkgdesc='Modular Wayland compositor library, with XWayland HiDPI (git version)'
|
|
url=https://github.com/swaywm/wlroots
|
|
arch=(x86_64)
|
|
provides=("wlroots-hidpi=${pkgver%%.r*}"
|
|
"wlroots=${pkgver%%.r*}"
|
|
"wlroots-git")
|
|
conflicts=(wlroots wlroots-git wlroots-hidpi-git)
|
|
options=(debug)
|
|
depends=(
|
|
libinput
|
|
libxcb
|
|
libxkbcommon
|
|
opengl-driver
|
|
pixman
|
|
wayland
|
|
xcb-util-errors
|
|
xcb-util-renderutil
|
|
xcb-util-wm
|
|
systemd)
|
|
makedepends=(
|
|
git
|
|
meson
|
|
wayland-protocols
|
|
xorgproto)
|
|
source=("${pkgname}::git+${url}#tag=${pkgver}"
|
|
# "xwayland_hidpi.diff::https://github.com/swaywm/wlroots/pull/2064.diff"
|
|
"xwayland_hidpi.diff::https://github.com/swaywm/wlroots/compare/${pkgver}...MisterDA:xwayland_hidpi.diff"
|
|
)
|
|
sha512sums=('SKIP'
|
|
'516a6ba1a840803784b9b4786e570f5564cb82e1feee6d14fd7c9e9bf852840a497d94fc3ba70c713994fa5278f0ff40b8cef81fe56fc75f880d89d138a9ef72')
|
|
|
|
prepare () {
|
|
cd "${pkgname}"
|
|
patch --forward --strip=1 --input="${srcdir}/xwayland_hidpi.diff"
|
|
}
|
|
|
|
build () {
|
|
arch-meson \
|
|
-Dlogind-provider=systemd \
|
|
-Dlibseat=disabled \
|
|
-Dwerror=false \
|
|
-Dexamples=false \
|
|
"${pkgname}" build
|
|
meson compile -C build
|
|
}
|
|
|
|
package () {
|
|
DESTDIR="${pkgdir}" meson install -C build
|
|
install -Dm644 "${pkgname}/"LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
|
|
}
|