mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-05 04:50:18 +02:00
gmu: update to 0.8.0
This commit is contained in:
parent
1d202776fc
commit
0009b7c773
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=gmu
|
PKG_NAME:=gmu
|
||||||
PKG_VERSION:=0.7.2
|
PKG_VERSION:=0.8.0BETA1
|
||||||
PKG_RELEASE:=3
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://wejp.k.vu/files/
|
PKG_SOURCE_URL:=http://wejp.k.vu/files/
|
||||||
PKG_MD5SUM:=dea481ab0f8f9f10b38aa21605dbb18d
|
PKG_MD5SUM:=a1a3d346802f3877b4c739b3c65225d6
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
@ -1,10 +1,8 @@
|
|||||||
diff --git a/nanonote.mk b/nanonote.mk
|
|
||||||
index 52ba352..52bc34c 100644
|
|
||||||
--- a/nanonote.mk
|
--- a/nanonote.mk
|
||||||
+++ b/nanonote.mk
|
+++ b/nanonote.mk
|
||||||
@@ -19,11 +19,7 @@ DECODERS_TO_BUILD=decoders/vorbis.so decoders/musepack.so decoders/wavpack.so de
|
@@ -19,11 +19,7 @@ DECODERS_TO_BUILD=decoders/vorbis.so dec
|
||||||
FRONTENDS_TO_BUILD=frontends/sdl.so frontends/log.so
|
FRONTENDS_TO_BUILD=frontends/sdl.so frontends/log.so
|
||||||
SDL_LIB=-lSDL -lpthread -ldirectfb -ldirect -lfusion -lz -lSDL_image -lSDL_gfx
|
SDL_LIB=-lSDL -lpthread -ldirectfb -ldirect -lfusion -lz
|
||||||
SDL_CFLAGS=-D_GNU_SOURCE=1 -D_REENTRANT
|
SDL_CFLAGS=-D_GNU_SOURCE=1 -D_REENTRANT
|
||||||
-CXX=mipsel-openwrt-linux-g++
|
-CXX=mipsel-openwrt-linux-g++
|
||||||
-CC=mipsel-openwrt-linux-gcc
|
-CC=mipsel-openwrt-linux-gcc
|
||||||
@ -12,7 +10,7 @@ index 52ba352..52bc34c 100644
|
|||||||
-TOOLCHAIN_ROOT_PATH=$(shell which $(CC)|sed 's/toolchain-mipsel_gcc-4.3.3+cs_uClibc-0.9.30.1\/usr\/bin\/$(CC)//')
|
-TOOLCHAIN_ROOT_PATH=$(shell which $(CC)|sed 's/toolchain-mipsel_gcc-4.3.3+cs_uClibc-0.9.30.1\/usr\/bin\/$(CC)//')
|
||||||
COPTS?=-O2 -s
|
COPTS?=-O2 -s
|
||||||
-CFLAGS=-msoft-float -I$(TOOLCHAIN_ROOT_PATH)/target-mipsel_uClibc-0.9.30.1/usr/include/SDL -I$(TOOLCHAIN_ROOT_PATH)/target-mipsel_uClibc-0.9.30.1/usr/include -ffast-math -fomit-frame-pointer $(SDL_CFLAGS) -DFILE_HW_H="\"hw_$(TARGET).h\""
|
-CFLAGS=-msoft-float -I$(TOOLCHAIN_ROOT_PATH)/target-mipsel_uClibc-0.9.30.1/usr/include/SDL -I$(TOOLCHAIN_ROOT_PATH)/target-mipsel_uClibc-0.9.30.1/usr/include -ffast-math -fomit-frame-pointer $(SDL_CFLAGS) -DFILE_HW_H="\"hw_$(TARGET).h\""
|
||||||
-LFLAGS=-s $(SDL_LIB) -L$(TOOLCHAIN_ROOT_PATH)/target-mipsel_uClibc-0.9.30.1/usr/lib -L$(TOOLCHAIN_ROOT_PATH)/target-mipsel_uClibc-0.9.30.1/root-xburst/usr/lib -lpthread -lm -ldl -lgcc -Wl,-export-dynamic
|
-LFLAGS=-s -L$(TOOLCHAIN_ROOT_PATH)/target-mipsel_uClibc-0.9.30.1/usr/lib -L$(TOOLCHAIN_ROOT_PATH)/target-mipsel_uClibc-0.9.30.1/root-xburst/usr/lib -lpthread -lm -ldl -lgcc -Wl,-export-dynamic
|
||||||
+CFLAGS+=-msoft-float -ffast-math -fomit-frame-pointer $(SDL_CFLAGS) -DFILE_HW_H="\"hw_$(TARGET).h\""
|
+CFLAGS+=-msoft-float -ffast-math -fomit-frame-pointer $(SDL_CFLAGS) -DFILE_HW_H="\"hw_$(TARGET).h\""
|
||||||
+LFLAGS=$(LDFLAGS) -s $(SDL_LIB) -lpthread -lm -ldl -lgcc -Wl,-export-dynamic
|
+LFLAGS=$(LDFLAGS) -s $(SDL_LIB) -lpthread -lm -ldl -lgcc -Wl,-export-dynamic
|
||||||
DISTFILES=$(BINARY) frontends decoders themes gmu.png README.txt libs.nanonote gmu.nn COPYING gmuinput.nanonote.conf
|
DISTFILES=$(BINARY) frontends decoders themes gmu.png README.txt libs.nanonote gmu.nn COPYING gmuinput.nanonote.conf gmu.bmp
|
||||||
|
@ -1,6 +1,5 @@
|
|||||||
diff -ur gmu-0.7.2.orig/nanonote.mk gmu-0.7.2/nanonote.mk
|
--- a/nanonote.mk
|
||||||
--- gmu-0.7.2.orig/nanonote.mk 2011-02-25 09:44:13.789059308 +0300
|
+++ b/nanonote.mk
|
||||||
+++ gmu-0.7.2/nanonote.mk 2011-02-25 16:12:39.573386748 +0300
|
|
||||||
@@ -16,6 +16,9 @@
|
@@ -16,6 +16,9 @@
|
||||||
|
|
||||||
#DECODERS_TO_BUILD=decoders/vorbis.so decoders/musepack.so decoders/flac.so decoders/wavpack.so decoders/mpg123.so decoders/mikmod.so
|
#DECODERS_TO_BUILD=decoders/vorbis.so decoders/musepack.so decoders/flac.so decoders/wavpack.so decoders/mpg123.so decoders/mikmod.so
|
||||||
@ -9,5 +8,5 @@ diff -ur gmu-0.7.2.orig/nanonote.mk gmu-0.7.2/nanonote.mk
|
|||||||
+ DECODERS_TO_BUILD+=$(MORE_DECODERS)
|
+ DECODERS_TO_BUILD+=$(MORE_DECODERS)
|
||||||
+endif
|
+endif
|
||||||
FRONTENDS_TO_BUILD=frontends/sdl.so frontends/log.so
|
FRONTENDS_TO_BUILD=frontends/sdl.so frontends/log.so
|
||||||
SDL_LIB=-lSDL -lpthread -ldirectfb -ldirect -lfusion -lz -lSDL_image -lSDL_gfx
|
SDL_LIB=-lSDL -lpthread -ldirectfb -ldirect -lfusion -lz
|
||||||
SDL_CFLAGS=-D_GNU_SOURCE=1 -D_REENTRANT
|
SDL_CFLAGS=-D_GNU_SOURCE=1 -D_REENTRANT
|
||||||
|
Loading…
Reference in New Issue
Block a user