1
0
mirror of git://projects.qi-hardware.com/openwrt-packages.git synced 2024-11-22 22:25:21 +02:00

Merge branch 'master' of git@projects.qi-hardware.com:openwrt-packages

This commit is contained in:
Mirko Vogt 2010-03-27 20:41:25 +01:00
commit 0ac004f370
12 changed files with 203 additions and 77 deletions

View File

@ -1,5 +1,9 @@
#
# Copyright (C) 2010 emdete.de
#
# This is free software, licensed under the GNU General Public License # This is free software, licensed under the GNU General Public License
# v3. See /LICENSE for more information. # v3. See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=bwbasic PKG_NAME:=bwbasic

View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=fn-handle PKG_NAME:=fn-handle
PKG_VERSION:=20100316 PKG_VERSION:=20100316
PKG_REV:=748269bdcfd0cea82ff9e3a79f60a0c3bb3bd35b PKG_REV:=acacde7b404a544d214f4ee01231bf0193a7155d
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz

View File

@ -2,10 +2,12 @@
# Copyright (C) 2008 OpenWrt.org # Copyright (C) 2008 OpenWrt.org
START=40 START=40
DEVICE="/dev/input/event0" DEVICE_PW="/dev/input/event0"
DEVICE_KB="/dev/input/event1"
start() { start() {
fnkeys $DEVICE & fnkeys $DEVICE_PW &
fnkeys $DEVICE_KB &
} }
stop() { stop() {

View File

@ -34,7 +34,7 @@ endef
TARGET_LDFLAGS+="-Wl,-rpath-link=$(STAGING_DIR)/usr/lib" TARGET_LDFLAGS+="-Wl,-rpath-link=$(STAGING_DIR)/usr/lib"
CONFIGURE_ARGS += CONFIGURE_ARGS += --without-threads
define Package/guile/install define Package/guile/install
$(INSTALL_DIR) $(1)/usr/bin $(INSTALL_DIR) $(1)/usr/bin

View File

@ -0,0 +1,13 @@
diff --git a/configure.in b/configure.in
index 217ac83..c4c16fc 100644
--- a/configure.in
+++ b/configure.in
@@ -854,7 +854,7 @@ main (void)
}]])],
[guile_cv_use_csqrt=yes],
[guile_cv_use_csqrt="no, glibc 2.3 bug"],
- [guile_cv_use_csqrt="yes, hopefully (cross-compiling)"])])
+ [guile_cv_use_csqrt="no, Ben NanoNote (cross-compiling)"])])
case $guile_cv_use_csqrt in
yes*)
AC_DEFINE(HAVE_USABLE_CSQRT, 1, [Define to 1 if csqrt is bug-free])

View File

@ -1,50 +0,0 @@
diff --git a/configure b/configure
index a57297d..98857ae 100755
--- a/configure
+++ b/configure
@@ -35053,6 +35053,8 @@ fi
if test "$with_threads" = pthreads; then
+cat >> /dev/null << end_pthread_attr_getstack_check_part1
+
{ $as_echo "$as_me:$LINENO: checking whether pthread_attr_getstack works for the main thread" >&5
$as_echo_n "checking whether pthread_attr_getstack works for the main thread... " >&6; }
old_CFLAGS="$CFLAGS"
@@ -35121,12 +35123,15 @@ $as_echo "$ac_try_echo") >&5
ac_status=$?
$as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
(exit $ac_status); }; }; then
+
+end_pthread_attr_getstack_check_part1
works=yes
cat >>confdefs.h <<\_ACEOF
#define PTHREAD_ATTR_GETSTACK_WORKS 1
_ACEOF
+cat >> /dev/null << end_pthread_attr_getstack_check_part2
else
$as_echo "$as_me: program exited with status $ac_status" >&5
$as_echo "$as_me: failed program was:" >&5
@@ -35138,6 +35143,7 @@ fi
rm -rf conftest.dSYM
rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
fi
+end_pthread_attr_getstack_check_part2
CFLAGS="$old_CFLAGS"
diff --git a/configure.in b/configure.in
index 217ac83..c4c16fc 100644
--- a/configure.in
+++ b/configure.in
@@ -854,7 +854,7 @@ main (void)
}]])],
[guile_cv_use_csqrt=yes],
[guile_cv_use_csqrt="no, glibc 2.3 bug"],
- [guile_cv_use_csqrt="yes, hopefully (cross-compiling)"])])
+ [guile_cv_use_csqrt="no, Ben NanoNote (cross-compiling)"])])
case $guile_cv_use_csqrt in
yes*)
AC_DEFINE(HAVE_USABLE_CSQRT, 1, [Define to 1 if csqrt is bug-free])

49
pyneod/Makefile Normal file
View File

@ -0,0 +1,49 @@
#
# Copyright (C) 2010 pyneo.org
#
# This is free software, licensed under the GNU General Public License
# v3. See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=pyneod
PKG_VERSION:=1.26
PKG_RELEASE:=1
PKG_SOURCE:=pyneo-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://git.pyneo.org/browse/cgit/pyneo/snapshot/
PKG_MD5SUM:=48cc3fe7c29ac385107cee08786a4477
PKG_BUILD_DEPENDS:=python
include $(INCLUDE_DIR)/package.mk
$(call include_mk, python-package.mk)
define Package/pyneod
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
DEPENDS:=+python +python-pyneo
TITLE:=Base lib for pyneo suite
URL:=http://pyneo.org/
endef
define Package/pyneod/description
Pyneo is a software stack for mobile devices.
endef
define PyPackage/pyneod/filespec
+|$(PYTHON_PKG_DIR)/pyneod
-|$(PYTHON_PKG_DIR)/pyneod/data/alsastates
endef
define Build/Compile
$(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
$(call Build/Compile/PyMod,., \
install --prefix="$(PKG_INSTALL_DIR)/usr", \
)
endef
$(eval $(call PyPackage,pyneod))
$(eval $(call BuildPackage,pyneod))

48
python-pyneo/Makefile Normal file
View File

@ -0,0 +1,48 @@
#
# Copyright (C) 2010 pyneo.org
#
# This is free software, licensed under the GNU General Public License
# v3. See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=python-pyneo
PKG_VERSION:=1.26
PKG_RELEASE:=1
PKG_SOURCE:=pyneo-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://git.pyneo.org/browse/cgit/pyneo/snapshot/
PKG_MD5SUM:=48cc3fe7c29ac385107cee08786a4477
PKG_BUILD_DEPENDS:=python
include $(INCLUDE_DIR)/package.mk
$(call include_mk, python-package.mk)
define Package/python-pyneo
SUBMENU:=Python
SECTION:=lang
CATEGORY:=Languages
DEPENDS:=+python
TITLE:=Base lib for pyneo suite
URL:=http://pyneo.org/
endef
define Package/python-pyneo/description
Pyneo is a software stack for mobile devices.
endef
define PyPackage/python-pyneo/filespec
+|$(PYTHON_PKG_DIR)/python-pyneo
-|$(PYTHON_PKG_DIR)/python-pyneo/data
endef
define Build/Compile
$(if $(Build/Compile/PyMod),,@echo Python packaging code not found.; false)
$(call Build/Compile/PyMod,., \
install --prefix="$(PKG_INSTALL_DIR)/usr", \
)
endef
$(eval $(call PyPackage,python-pyneo))
$(eval $(call BuildPackage,python-pyneo))

View File

@ -1,5 +1,9 @@
#
# Copyright (C) 2010 emdete.de
#
# This is free software, licensed under the GNU General Public License # This is free software, licensed under the GNU General Public License
# v3. See /LICENSE for more information. # v3. See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=robots PKG_NAME:=robots

View File

@ -8,17 +8,71 @@ when press "enter" will goto the translate result text
Signed-off-by: Xiangfu Liu <xiangfu@sharism.cc> Signed-off-by: Xiangfu Liu <xiangfu@sharism.cc>
--- ---
src/mainwin.cpp | 4 +++- src/mainwin.cpp | 27 ++++++++++++++++++++-------
src/mainwin.h | 1 + src/mainwin.h | 1 +
src/stardict.cpp | 4 ++++ src/stardict.cpp | 4 ++++
3 files changed, 8 insertions(+), 1 deletions(-) 3 files changed, 25 insertions(+), 7 deletions(-)
diff --git a/src/mainwin.cpp b/src/mainwin.cpp diff --git a/src/mainwin.cpp b/src/mainwin.cpp
index ccd5adc..eaa0650 100644 index ccd5adc..a1d6373 100644
--- a/src/mainwin.cpp --- a/src/mainwin.cpp
+++ b/src/mainwin.cpp +++ b/src/mainwin.cpp
@@ -2689,8 +2689,10 @@ void MidWin::Create(GtkWidget *vbox) @@ -165,8 +165,13 @@ void TopWin::on_entry_changed(GtkEntry *entry, TopWin *oTopWin)
return;
const gchar *sWord = gtk_entry_get_text(entry);
if(sWord[0]!='\0') {
+ gtk_widget_show(gpAppFrame->oMidWin.oIndexWin.notebook);
+ gtk_widget_hide(gpAppFrame->oMidWin.vbox1);
gpAppFrame->TopWinWordChange(sWord);
} else {
+ gtk_widget_hide(gpAppFrame->oMidWin.oIndexWin.notebook);
+ gtk_widget_show(gpAppFrame->oMidWin.vbox1);
+
gpAppFrame->oMidWin.oTextWin.queryWord.clear();
gpAppFrame->oMidWin.oIndexWin.oResultWin.Clear();
gpAppFrame->oMidWin.oTextWin.ShowTips();
@@ -581,8 +586,13 @@ void TopWin::SetText(const gchar *word, bool notify)
if (!notify)
return;
if(word[0]!='\0') {
+ gtk_widget_show(gpAppFrame->oMidWin.oIndexWin.notebook);
+ gtk_widget_hide(gpAppFrame->oMidWin.vbox1);
gpAppFrame->TopWinWordChange(word);
} else {
+ gtk_widget_hide(gpAppFrame->oMidWin.oIndexWin.notebook);
+ gtk_widget_show(gpAppFrame->oMidWin.vbox1);
+
gpAppFrame->oMidWin.oTextWin.queryWord.clear();
gpAppFrame->oMidWin.oIndexWin.oResultWin.Clear();
gpAppFrame->oMidWin.oTextWin.ShowTips();
@@ -1815,18 +1825,19 @@ void TextWin::ShowTips()
{
query_result = TEXT_WIN_TIPS;
view->set_text(
- _(" Welcome to StarDict!\n\n"
+ _(" Please type a word to start searching. \n\n"
+ " Welcome to StarDict.\n"
" Press Ctrl+Q to quit. \n"
+ " Press Alt+C or ESC to clear the input entry's text.\n"
#ifndef CONFIG_NANONOTE
" Press Alt+Z to iconify the window or Alt+X to hide the window.\n"
-#endif
- " Press Alt+C or ESC to clear the input entry's text.\n"
" Press Space key to move focus to the input entry.\n"
- " If the query word was not found, you can press Tab key to select the first word in the word list.\n"
" After selected some text, clicking the middle mouse button on the main window's Definition area or on the notification area icon will look up that word.\n"
+ " When the floating window reports that a word was not found, double clicking will perform a fuzzy query.\n"
+#endif
+ " If the query word was not found, you can press Tab key to select the first word in the word list.\n"
" StarDict can match strings against patterns containing '*' (wildcard) and '?' (joker).\n"
- " Input a word beginning with \'/\' to do a Fuzzy query.\n"
- " When the floating window reports that a word was not found, double clicking will perform a fuzzy query.\n")
+ " Input a word beginning with \'/\' to do a Fuzzy query.\n")
);
view->scroll_to(0);
}
@@ -2689,8 +2700,10 @@ void MidWin::Create(GtkWidget *vbox)
oLeftWin.Create(hbox, has_treedict); oLeftWin.Create(hbox, has_treedict);
gtk_box_pack_start(GTK_BOX(hbox),notebook, true, true, 0); gtk_box_pack_start(GTK_BOX(hbox),notebook, true, true, 0);
@ -43,10 +97,19 @@ index c3589c6..569c978 100644
LeftWin oLeftWin; LeftWin oLeftWin;
IndexWin oIndexWin; IndexWin oIndexWin;
diff --git a/src/stardict.cpp b/src/stardict.cpp diff --git a/src/stardict.cpp b/src/stardict.cpp
index b84f5c5..8dd64ac 100644 index b84f5c5..07cb57a 100644
--- a/src/stardict.cpp --- a/src/stardict.cpp
+++ b/src/stardict.cpp +++ b/src/stardict.cpp
@@ -588,6 +588,8 @@ gboolean AppCore::vKeyPressReleaseCallback(GtkWidget * window, GdkEventKey *even @@ -425,6 +425,8 @@ void AppCore::Create(gchar *queryword)
} else {
oMidWin.oTextWin.ShowInitFailed();
}
+ gtk_widget_hide(oMidWin.oIndexWin.notebook);
+ gtk_widget_show(oMidWin.vbox1);
}
gboolean AppCore::on_delete_event(GtkWidget * window, GdkEvent *event , AppCore *app)
@@ -588,6 +590,8 @@ gboolean AppCore::vKeyPressReleaseCallback(GtkWidget * window, GdkEventKey *even
gtk_tree_model_get(model, &iter, 0, &word, -1); gtk_tree_model_get(model, &iter, 0, &word, -1);
oAppCore->ListClick(word); oAppCore->ListClick(word);
g_free(word); g_free(word);
@ -55,12 +118,3 @@ index b84f5c5..8dd64ac 100644
/* here to dispaly the result windows */ /* here to dispaly the result windows */
} }
} }
@@ -613,6 +615,8 @@ gboolean AppCore::vKeyPressReleaseCallback(GtkWidget * window, GdkEventKey *even
oAppCore->oTopWin.InsertBackList();
oAppCore->oTopWin.SetText("");
oAppCore->oTopWin.grab_focus();
+ gtk_widget_show(oAppCore->oMidWin.oIndexWin.notebook);
+ gtk_widget_hide(oAppCore->oMidWin.vbox1);
} else {
if (!oAppCore->oTopWin.has_focus())
oAppCore->oTopWin.grab_focus();

View File

@ -6,8 +6,8 @@ Signed-off-by: Xiangfu Liu <xiangfu@sharism.cc>
--- ---
src/pangoview.cpp | 16 ++++++++-------- src/pangoview.cpp | 16 ++++++++--------
src/stardict.cpp | 7 +++++-- src/stardict.cpp | 9 +++++++--
2 files changed, 13 insertions(+), 10 deletions(-) 2 files changed, 15 insertions(+), 10 deletions(-)
diff --git a/src/pangoview.cpp b/src/pangoview.cpp diff --git a/src/pangoview.cpp b/src/pangoview.cpp
@ -62,10 +62,10 @@ index e400ac3..b386b6e 100644
void TextPangoWidget::do_set_pango_text(const char *str) void TextPangoWidget::do_set_pango_text(const char *str)
diff --git a/src/stardict.cpp b/src/stardict.cpp diff --git a/src/stardict.cpp b/src/stardict.cpp
index 8dd64ac..ae5fb05 100644 index 07cb57a..b4ade70 100644
--- a/src/stardict.cpp --- a/src/stardict.cpp
+++ b/src/stardict.cpp +++ b/src/stardict.cpp
@@ -487,11 +487,10 @@ gboolean AppCore::vKeyPressReleaseCallback(GtkWidget * window, GdkEventKey *even @@ -489,11 +489,10 @@ gboolean AppCore::vKeyPressReleaseCallback(GtkWidget * window, GdkEventKey *even
if (event->type==GDK_KEY_PRESS) if (event->type==GDK_KEY_PRESS)
oAppCore->Quit(); oAppCore->Quit();
} }
@ -78,7 +78,7 @@ index 8dd64ac..ae5fb05 100644
} }
} }
else if ((event->keyval==GDK_z || event->keyval==GDK_Z) && only_mod1_pressed) { else if ((event->keyval==GDK_z || event->keyval==GDK_Z) && only_mod1_pressed) {
@@ -508,6 +507,7 @@ gboolean AppCore::vKeyPressReleaseCallback(GtkWidget * window, GdkEventKey *even @@ -510,6 +509,7 @@ gboolean AppCore::vKeyPressReleaseCallback(GtkWidget * window, GdkEventKey *even
if (event->type==GDK_KEY_PRESS) if (event->type==GDK_KEY_PRESS)
show_help(NULL); show_help(NULL);
} }
@ -86,11 +86,13 @@ index 8dd64ac..ae5fb05 100644
else if ((event->keyval==GDK_f || event->keyval==GDK_F) && only_ctrl_pressed) { else if ((event->keyval==GDK_f || event->keyval==GDK_F) && only_ctrl_pressed) {
if (event->type==GDK_KEY_PRESS) if (event->type==GDK_KEY_PRESS)
oAppCore->oMidWin.oToolWin.do_search(); oAppCore->oMidWin.oToolWin.do_search();
@@ -623,6 +623,9 @@ gboolean AppCore::vKeyPressReleaseCallback(GtkWidget * window, GdkEventKey *even @@ -623,6 +623,11 @@ gboolean AppCore::vKeyPressReleaseCallback(GtkWidget * window, GdkEventKey *even
} }
} }
break; break;
+ case GDK_Return: + case GDK_Return:
+ gtk_widget_hide(oAppCore->oMidWin.oIndexWin.notebook);
+ gtk_widget_show(oAppCore->oMidWin.vbox1);
+ return_val=true; + return_val=true;
+ break; + break;
default: default:

View File

@ -8,8 +8,8 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=vido PKG_NAME:=vido
PKG_VERSION:=20100222 PKG_VERSION:=20100326
PKG_REV:=7a95279f5e36778faf6d2ef9b01136e054bb8660 PKG_REV:=c544a52e18c5aae130002d05aca62940ba744597
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz