mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 15:12:28 +02:00
libgii: initial commit
This commit is contained in:
parent
fa537a3c64
commit
0c9d588c6f
77
libgii/Makefile
Normal file
77
libgii/Makefile
Normal file
@ -0,0 +1,77 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2011 David Kuehling <dvdkhlng TA gmx TOD de>
|
||||||
|
#
|
||||||
|
# License GPLv2 or later. NO WARRANTY.
|
||||||
|
#
|
||||||
|
# OpenWRT package for the libGII
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=libgii
|
||||||
|
PKG_VERSION:=1.0.2
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).src.tar.gz
|
||||||
|
PKG_SOURCE_URL:=@SF/ggi
|
||||||
|
PKG_MD5SUM:=205ca1d87042c8e4aafecd6da7c9de39
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/libgii-$(PKG_VERSION)
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
PKG_FIXUP:=libtool
|
||||||
|
|
||||||
|
PKG_BUILD_DEPENDS:= libtool/host
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/libgii
|
||||||
|
SECTION:=libs
|
||||||
|
CATEGORY:=Libraries
|
||||||
|
TITLE:=GGI Project Input Interface Library
|
||||||
|
URL:=http://www.ggi-project.org/packages/libgii.html
|
||||||
|
DEPENDS:=
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/libgii/description
|
||||||
|
LibGII is intended to be to input what our LibGGI library is to graphics.
|
||||||
|
|
||||||
|
The goal of LibGII is to provide a single easy to use, but yet powerful, API
|
||||||
|
for all possible input sources. However we are not there yet. The API is far
|
||||||
|
from set in stone yet, and is likely to change.
|
||||||
|
endef
|
||||||
|
|
||||||
|
TARGET_CFLAGS +=
|
||||||
|
CONFIGURE_VARS +=
|
||||||
|
CONFIGURE_ARGS += \
|
||||||
|
--enable-mutexes=builtin \
|
||||||
|
--disable-x
|
||||||
|
|
||||||
|
define Build/Configure
|
||||||
|
$(call Build/Configure/Default)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
$(call Build/Compile/Default,-j2)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/InstallDev
|
||||||
|
$(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib
|
||||||
|
$(CP) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/include/* \
|
||||||
|
$(1)/usr/include/
|
||||||
|
$(CP) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/lib/*.{a,so*} \
|
||||||
|
$(1)/usr/lib/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/libgii/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
|
||||||
|
$(INSTALL_DIR) $(1)/etc/ggi
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/etc/ggi/* $(1)/etc/ggi/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,libgii))
|
||||||
|
|
||||||
|
|
||||||
|
# The following comments configure the Emacs editor. Just ignore them.
|
||||||
|
# Local Variables:
|
||||||
|
# compile-command: "make -C ~/h/src/qi/openwrt-xburst package/libgii/compile -j2 V=99"
|
||||||
|
# End:
|
13
libgii/patches/010-no-demos.patch
Normal file
13
libgii/patches/010-no-demos.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
Index: libgii-1.0.2/Makefile.in
|
||||||
|
===================================================================
|
||||||
|
--- libgii-1.0.2.orig/Makefile.in 2011-01-04 18:41:07.000000000 +0100
|
||||||
|
+++ libgii-1.0.2/Makefile.in 2011-01-04 18:41:27.000000000 +0100
|
||||||
|
@@ -337,7 +337,7 @@
|
||||||
|
|
||||||
|
# multiple AUTOMAKE_OPTIONS lines only confuses automake 1.6
|
||||||
|
AUTOMAKE_OPTIONS = 1.4 foreign
|
||||||
|
-SUBDIRS = include gg input filter gii input-shared filter-shared regress demos doc m4 dist
|
||||||
|
+SUBDIRS = include gg input filter gii input-shared filter-shared regress doc m4 dist
|
||||||
|
giiconfdatadir = ${sysconfdir}/${ggi_subdir}
|
||||||
|
giiconfdata_DATA = libgii.conf
|
||||||
|
DISTCLEANFILES = libgii.conf config.lt
|
Loading…
Reference in New Issue
Block a user