mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-04 23:09:21 +02:00
Initial port of Snownews RSS reader to OpenWRT.
This commit is contained in:
parent
23955b4887
commit
145395cd59
47
snownews/Makefile
Normal file
47
snownews/Makefile
Normal file
@ -0,0 +1,47 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2006 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=snownews
|
||||||
|
PKG_VERSION:=1.5.12
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=http://kiza.kcore.de/media/software/snownews/
|
||||||
|
PKG_MD5SUM:=80da8943fc5aa96571924aec0087d4c0
|
||||||
|
|
||||||
|
#
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/snownews
|
||||||
|
SECTION:=utils
|
||||||
|
CATEGORY:=Utilities
|
||||||
|
DEPENDS:=+libncurses +libxml2 +libopenssl +zlib
|
||||||
|
TITLE:=SnowNews
|
||||||
|
URL:=http://kiza.kcore.de/software/snownews/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/snownews/description
|
||||||
|
RSS feed reader
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Configure
|
||||||
|
$(call Build/Compile/Default,\
|
||||||
|
EXTRA_CFLAGS="-I$(STAGING_DIR)/usr/lib/libintl/include -I$(STAGING_DIR)/usr/lib/libiconv/include -I$(STAGING_DIR)/usr/include"\
|
||||||
|
EXTRA_LDFLAGS="-L$(STAGING_DIR)/usr/lib/ -L$(STAGING_DIR)/usr/lib/libintl/lib -L$(STAGING_DIR)/usr/lib/libiconv/lib -liconv -lcharset -lintl -lm -lz "\
|
||||||
|
)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/snownews/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/snownews $(1)/usr/bin
|
||||||
|
$(STRIP) $(1)/usr/bin/snownews
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,snownews))
|
13
snownews/patches/Makefile.patch
Normal file
13
snownews/patches/Makefile.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
--- snownews-1.5.12/Makefile 2009-09-17 08:44:27.000000000 +0200
|
||||||
|
+++ snownews-1.5.12m/Makefile 2010-07-28 12:14:11.000000000 +0200
|
||||||
|
@@ -6,7 +6,9 @@
|
||||||
|
|
||||||
|
### Compiler/linker flags ###
|
||||||
|
### Generated via configure ###
|
||||||
|
-include platform_settings
|
||||||
|
+PREFIX= /usr
|
||||||
|
+CFLAGS= -Wall -Wno-format-y2k -O2 -DLOCALEPATH="\"$(LOCALEPATH)\"" -DOS=\"Linux\" -I/usr/include/libxml2 $(EXTRA_CFLAGS)
|
||||||
|
+LDFLAGS= -lncurses -lcrypto -lxml2 $(EXTRA_LDFLAGS)
|
||||||
|
|
||||||
|
### Object files ###
|
||||||
|
OBJFILES= main.o netio.o interface.o xmlparse.o updatecheck.o conversions.o dialog.o ui-support.o categories.o about.o cookies.o setup.o net-support.o digcalc.o filters.o io-internal.o os-support.o zlib_interface.o support.o
|
Loading…
Reference in New Issue
Block a user