mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 00:29:41 +02:00
bwbasic, fix compile error, remove BROKEN
This commit is contained in:
parent
57b658a157
commit
1a1d25d260
@ -7,33 +7,35 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=bwbasic
|
||||
PKG_VERSION:=master
|
||||
PKG_VERSION:=2.50
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
||||
PKG_SOURCE_URL:=http://pyneo.org/t
|
||||
PKG_MD5SUM:=8d42bb36260bfa276a1ca065bf464355
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
|
||||
PKG_SOURCE_URL:=@SF/bwbasic
|
||||
PKG_INSTALL:=1
|
||||
UNPACK_CMD=unzip -d $(1) $(DL_DIR)/$(PKG_SOURCE)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/bwbasic
|
||||
MAINTAINER:="Xiangfu Liu" <xiangfu@sharism.cc>
|
||||
SECTION:=utilites
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=An bwbasic application
|
||||
URL:=http://pyneo.org/t/bwbasic
|
||||
DEPENDS:=@BROKEN +libncurses
|
||||
URL:=http://www.bwbasic.at/info.htm
|
||||
DEPENDS:=+libncurses
|
||||
endef
|
||||
#DEPENDS:=+libreadline +libtermcap
|
||||
|
||||
MAKE_FLAGS += -f Makefile.ncu
|
||||
|
||||
define Package/bwbasic/description
|
||||
A bwbasic application
|
||||
A bwbasic application
|
||||
endef
|
||||
|
||||
define Package/bwbasic/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) \
|
||||
$(PKG_INSTALL_DIR)/usr/bin/bwbasic \
|
||||
$(PKG_INSTALL_DIR)/usr/local/bin/bwbasic \
|
||||
$(1)/usr/bin/
|
||||
endef
|
||||
|
||||
|
28
bwbasic/patches/001-pass-openwrt-CFLAGS.patch
Normal file
28
bwbasic/patches/001-pass-openwrt-CFLAGS.patch
Normal file
@ -0,0 +1,28 @@
|
||||
diff --git a/Makefile.ncu b/Makefile.ncu
|
||||
index e852faf..d5b5b2d 100644
|
||||
--- a/Makefile.ncu
|
||||
+++ b/Makefile.ncu
|
||||
@@ -19,13 +19,13 @@ DEFS = -DHAVE_STRING=1 -DHAVE_STDLIB=1 -DHAVE_RAISE=1 -DHAVE_UNISTD=1
|
||||
|
||||
# Revised by JBV
|
||||
#CFLAGS = -O
|
||||
-CFLAGS = -g -ansi
|
||||
+CFLAGS += -g -ansi
|
||||
|
||||
# Revised by JBV
|
||||
#LDFLAGS = -s
|
||||
|
||||
prefix = /usr/local
|
||||
-exec_prefix = $(prefix)
|
||||
+exec_prefix = $(DESTDIR)$(prefix)
|
||||
bindir = $(exec_prefix)/bin
|
||||
|
||||
SHELL = /bin/sh
|
||||
@@ -87,6 +87,7 @@ $(OFILES): $(HFILES)
|
||||
$(CC) -c $(CPPFLAGS) -I$(srcdir) $(DEFS) $(CFLAGS) $<
|
||||
|
||||
install: all
|
||||
+ mkdir -p $(bindir)
|
||||
$(INSTALL_PROGRAM) bwbasic $(bindir)/bwbasic
|
||||
|
||||
uninstall:
|
Loading…
Reference in New Issue
Block a user