mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-26 02:54:59 +02:00
add missing dependency libjpeg, disable use of assembler, adjust configure-string
This commit is contained in:
parent
ede97070be
commit
21577551ed
@ -25,7 +25,7 @@ define Package/DirectFB
|
|||||||
SECTION:=libs
|
SECTION:=libs
|
||||||
CATEGORY:=Libraries
|
CATEGORY:=Libraries
|
||||||
URL:=http://directfb.org
|
URL:=http://directfb.org
|
||||||
DEPENDS:=+libpng
|
DEPENDS:=+libpng +libjpeg
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/DirectFB/description
|
define Package/DirectFB/description
|
||||||
@ -33,9 +33,10 @@ define Package/DirectFB/description
|
|||||||
endef
|
endef
|
||||||
|
|
||||||
TARGET_LDFLAGS+="-Wl,-rpath-link=$(STAGING_DIR)/usr/lib"
|
TARGET_LDFLAGS+="-Wl,-rpath-link=$(STAGING_DIR)/usr/lib"
|
||||||
|
CONFIGURE_CMD=./autogen.sh
|
||||||
|
|
||||||
|
comma:=,
|
||||||
define Build/Configure
|
define Build/Configure
|
||||||
( cd $(PKG_BUILD_DIR); ./autogen.sh );
|
|
||||||
$(call Build/Configure/Default, \
|
$(call Build/Configure/Default, \
|
||||||
--disable-osx \
|
--disable-osx \
|
||||||
--disable-x11 \
|
--disable-x11 \
|
||||||
@ -47,6 +48,8 @@ define Build/Configure
|
|||||||
--disable-sdl \
|
--disable-sdl \
|
||||||
--disable-vnc \
|
--disable-vnc \
|
||||||
--enable-sysfs \
|
--enable-sysfs \
|
||||||
|
--with-inputdrivers=keyboard$(comma)linuxinput \
|
||||||
|
--with-gfxdrivers=none \
|
||||||
)
|
)
|
||||||
endef
|
endef
|
||||||
|
|
||||||
@ -56,10 +59,10 @@ define Build/InstallDev
|
|||||||
$(1)/usr/lib \
|
$(1)/usr/lib \
|
||||||
$(1)/usr/lib/pkgconfig
|
$(1)/usr/lib/pkgconfig
|
||||||
$(CP) \
|
$(CP) \
|
||||||
$(PKG_INSTALL_DIR)/usr/lib/lib{direct,fusion}*.{so*,a,la} \
|
$(PKG_INSTALL_DIR)/usr/lib/* \
|
||||||
$(1)/usr/lib/
|
$(1)/usr/lib/
|
||||||
$(CP) \
|
$(CP) \
|
||||||
$(PKG_INSTALL_DIR)/usr/include/directfb* \
|
$(PKG_INSTALL_DIR)/usr/include/* \
|
||||||
$(1)/usr/include/
|
$(1)/usr/include/
|
||||||
$(CP) \
|
$(CP) \
|
||||||
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig \
|
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig \
|
||||||
@ -75,8 +78,7 @@ define Package/DirectFB/install
|
|||||||
$(1)/usr/lib/directfb-1.4-0-pure/interfaces/IDirectFBVideoProvider \
|
$(1)/usr/lib/directfb-1.4-0-pure/interfaces/IDirectFBVideoProvider \
|
||||||
$(1)/usr/lib/directfb-1.4-0-pure/wm \
|
$(1)/usr/lib/directfb-1.4-0-pure/wm \
|
||||||
$(1)/usr/lib/directfb-1.4-0-pure/systems \
|
$(1)/usr/lib/directfb-1.4-0-pure/systems \
|
||||||
$(1)/usr/lib/directfb-1.4-0-pure/inputdrivers \
|
$(1)/usr/lib/directfb-1.4-0-pure/inputdrivers
|
||||||
$(1)/usr/lib/directfb-1.4-0-pure/gfxdrivers
|
|
||||||
$(CP) \
|
$(CP) \
|
||||||
$(PKG_INSTALL_DIR)/usr/bin/* \
|
$(PKG_INSTALL_DIR)/usr/bin/* \
|
||||||
$(1)/usr/bin/
|
$(1)/usr/bin/
|
||||||
@ -101,9 +103,6 @@ define Package/DirectFB/install
|
|||||||
$(CP) \
|
$(CP) \
|
||||||
$(PKG_INSTALL_DIR)/usr/lib/directfb-1.4-0-pure/inputdrivers/*.so* \
|
$(PKG_INSTALL_DIR)/usr/lib/directfb-1.4-0-pure/inputdrivers/*.so* \
|
||||||
$(1)/usr/lib/directfb-1.4-0-pure/inputdrivers/
|
$(1)/usr/lib/directfb-1.4-0-pure/inputdrivers/
|
||||||
$(CP) \
|
|
||||||
$(PKG_INSTALL_DIR)/usr/lib/directfb-1.4-0-pure/gfxdrivers/*.so* \
|
|
||||||
$(1)/usr/lib/directfb-1.4-0-pure/gfxdrivers/
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,DirectFB))
|
$(eval $(call BuildPackage,DirectFB))
|
||||||
|
13
libdirectfb/patches/disable-asm.patch
Normal file
13
libdirectfb/patches/disable-asm.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
--- DirectFB-1.4.2/configure.in.orig 2009-10-14 17:19:38.000000000 +0200
|
||||||
|
+++ DirectFB-1.4.2/configure.in 2009-10-14 17:19:55.000000000 +0200
|
||||||
|
@@ -221,8 +221,8 @@
|
||||||
|
have_kos=no
|
||||||
|
need_libc_r=no
|
||||||
|
need_libdl=yes
|
||||||
|
+want_ppcasm=no
|
||||||
|
+want_armasm=no
|
||||||
|
-want_ppcasm=yes
|
||||||
|
-want_armasm=yes
|
||||||
|
|
||||||
|
case "$target_or_host" in
|
||||||
|
*-linux*)
|
Loading…
Reference in New Issue
Block a user