1
0
mirror of git://projects.qi-hardware.com/openwrt-packages.git synced 2024-07-01 03:16:43 +03:00

netsurf - at least shows up.

This commit is contained in:
kyak 2010-11-20 14:44:08 +03:00
parent 25cc3ef145
commit 22c747edd9
8 changed files with 106 additions and 10 deletions

View File

@ -24,7 +24,9 @@ endef
define Build/Compile define Build/Compile
rm -rf $(PKG_INSTALL_DIR) rm -rf $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \ $(MAKE_VARS) $(MAKE) -C $(PKG_BUILD_DIR) \
$(MAKE_FLAGS) \
WARNFLAGS="" \
COMPONENT_TYPE=lib-shared \ COMPONENT_TYPE=lib-shared \
DESTDIR="$(PKG_INSTALL_DIR)" \ DESTDIR="$(PKG_INSTALL_DIR)" \
all install all install

View File

@ -15,7 +15,7 @@ define Package/libhubbub
CATEGORY:=Libraries CATEGORY:=Libraries
TITLE:=Hubbub is an HTML5 compliant parsing library TITLE:=Hubbub is an HTML5 compliant parsing library
URL:=http://www.netsurf-browser.org/projects/hubbub/ URL:=http://www.netsurf-browser.org/projects/hubbub/
DEPENDS:=+libparserutils @BROKEN DEPENDS:=+libparserutils
endef endef
define Package/libhubbub/description define Package/libhubbub/description
@ -24,7 +24,8 @@ endef
define Build/Compile define Build/Compile
rm -rf $(PKG_INSTALL_DIR) rm -rf $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \ $(MAKE_VARS) $(MAKE) -C $(PKG_BUILD_DIR) \
$(MAKE_FLAGS) \
COMPONENT_TYPE=lib-shared \ COMPONENT_TYPE=lib-shared \
DESTDIR="$(PKG_INSTALL_DIR)" \ DESTDIR="$(PKG_INSTALL_DIR)" \
all install all install

56
libnsfb/Makefile Normal file
View File

@ -0,0 +1,56 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libnsfb
PKG_REV:=10618
PKG_VERSION:=r$(PKG_REV)
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=svn://svn.netsurf-browser.org/trunk/libnsfb
PKG_SOURCE_PROTO:=svn
PKG_SOURCE_VERSION:=$(PKG_REV)
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
define Package/libnsfb
SECTION:=libs
CATEGORY:=Libraries
TITLE:=LibNSFB is a framebuffer abstraction library, written in C
URL:=http://www.netsurf-browser.org/projects/libcss/
endef
define Package/libnsfb/description
The overall idea of the library is to provide a generic abstraction to a linear section of memory which corresponds to a visible array of pixel elements on a display device. Different colour depths are supported and the library provides routines for tasks such as drawing onto the framebuffer and rectangle copy operations.
endef
define Build/Compile
rm -rf $(PKG_INSTALL_DIR)
$(MAKE_VARS) $(MAKE) -C $(PKG_BUILD_DIR) \
$(MAKE_FLAGS) \
WARNFLAGS="" \
COMPONENT_TYPE=lib-shared \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install
endef
define Build/InstallDev
mkdir -p $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/local/include/* $(1)/usr/include/
mkdir -p $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/local/lib/* $(1)/usr/lib/
$(SED) \
's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
$(1)/usr/lib/pkgconfig/libnsfb.pc
$(SED) \
's/xcb\|xcb-icccm\|xcb-image\|xcb-keysyms//g' \
$(1)/usr/lib/pkgconfig/libnsfb.pc
endef
define Package/libnsfb/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/local/lib/libnsfb.so* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,libnsfb))

View File

@ -0,0 +1,10 @@
diff -ur libnsfb.orig/src/surface/Makefile libnsfb/src/surface/Makefile
--- libnsfb.orig/src/surface/Makefile 2010-11-20 13:13:46.000000000 +0300
+++ libnsfb/src/surface/Makefile 2010-11-20 13:42:01.000000000 +0300
@@ -1,4 +1,4 @@
# Sources
-DIR_SOURCES := surface.c sdl.c vnc.c able.c ram.c linux.c x.c
+DIR_SOURCES := surface.c sdl.c ram.c linux.c
include build/makefiles/Makefile.subdir
Только в libnsfb/src/surface: Makefile~

View File

@ -15,7 +15,7 @@ define Package/libparserutils
CATEGORY:=Libraries CATEGORY:=Libraries
TITLE:=LibParserUtils has some built-in charset converters TITLE:=LibParserUtils has some built-in charset converters
URL:=http://www.netsurf-browser.org/projects/libparserutils/ URL:=http://www.netsurf-browser.org/projects/libparserutils/
DEPENDS:=@BROKEN DEPENDS:=
endef endef
define Package/libparserutils/description define Package/libparserutils/description
@ -24,7 +24,8 @@ endef
define Build/Compile define Build/Compile
rm -rf $(PKG_INSTALL_DIR) rm -rf $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \ $(MAKE_VARS) $(MAKE) -C $(PKG_BUILD_DIR) \
$(MAKE_FLAGS) \
COMPONENT_TYPE=lib-shared \ COMPONENT_TYPE=lib-shared \
DESTDIR="$(PKG_INSTALL_DIR)" \ DESTDIR="$(PKG_INSTALL_DIR)" \
all install all install

View File

@ -23,7 +23,8 @@ endef
define Build/Compile define Build/Compile
rm -rf $(PKG_INSTALL_DIR) rm -rf $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \ $(MAKE_VARS) $(MAKE) -C $(PKG_BUILD_DIR) \
$(MAKE_FLAGS) \
COMPONENT_TYPE=lib-shared \ COMPONENT_TYPE=lib-shared \
DESTDIR="$(PKG_INSTALL_DIR)" \ DESTDIR="$(PKG_INSTALL_DIR)" \
all install all install

View File

@ -11,6 +11,8 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.netsurf-browser.org/downloads/development/ PKG_SOURCE_URL:=http://www.netsurf-browser.org/downloads/development/
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME) PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk include $(INCLUDE_DIR)/package.mk
define Package/netsurf define Package/netsurf
@ -19,15 +21,18 @@ define Package/netsurf
CATEGORY:=Network CATEGORY:=Network
TITLE:=netsurf TITLE:=netsurf
URL:=http://www.netsurf-browser.org/ URL:=http://www.netsurf-browser.org/
DEPENDS:=+libsdl +libcss +libhubbub +libparserutils @BROKEN DEPENDS:=+libsdl +libcss +libhubbub +libparserutils +libnsfb +libxml2 +libcurl
endef endef
define Package/netsurf/description define Package/netsurf/description
NetSurf is a free, open source web browser. It is written in C and released under the GNU Public Licence version 2. NetSurf has its own layout and rendering engine entirely written from scratch. It is small and capable of handling many of the web standards in use today. NetSurf is a free, open source web browser. It is written in C and released under the GNU Public Licence version 2. NetSurf has its own layout and rendering engine entirely written from scratch. It is small and capable of handling many of the web standards in use today.
endef endef
MAKE_VARS += MAKE_FLAGS += "TARGET=framebuffer" \
"PREFIX=/usr"
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/SDL TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/SDL
TARGET_LDFLAGS += -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
define Build/Prepare define Build/Prepare
$(call Build/Prepare/Default) $(call Build/Prepare/Default)
@ -36,11 +41,15 @@ endef
define Package/netsurf/install define Package/netsurf/install
$(INSTALL_DIR) \ $(INSTALL_DIR) \
$(1)/usr/bin \ $(1)/usr/bin $(1)/usr/share/netsurf
$(INSTALL_BIN) \ $(INSTALL_BIN) \
./files/netsurf \ $(PKG_INSTALL_DIR)/usr/bin/netsurf \
$(1)/usr/bin/ $(1)/usr/bin/
$(INSTALL_DATA) \
$(PKG_INSTALL_DIR)/usr/share/netsurf/* \
$(1)/usr/share/netsurf/
endef endef
$(eval $(call BuildPackage,netsurf)) $(eval $(call BuildPackage,netsurf))

View File

@ -0,0 +1,16 @@
#
# NetSurf build configuration example
#
#
# To configure NetSurf's build options create a Makefile.config file. This is
# an example Makefile.config.
#
# To see the available config options, look at Makefile.defaults
# For example, by default, NetSurf builds with BMP support. If you
# wish to disable this, then uncomment the following line.
override NETSURF_USE_BMP := NO
override NETSURF_USE_GIF := NO
override NETSURF_USE_MNG := NO