mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 00:19:20 +02:00
ben-wpan: now ben-wpan tools also build for other targets
This commit is contained in:
parent
341c9cf220
commit
23f18f74a8
@ -26,9 +26,18 @@ define Package/ben-wpan/Default
|
||||
URL:=http://en.qi-hardware.com/wiki/Ben_WPAN
|
||||
endef
|
||||
|
||||
ifneq ($(CONFIG_TARGET_xburst_qi_lb60),)
|
||||
BEN_WPAN_MAKE_ARGS=V=1 TARGET=ben_openwrt
|
||||
else
|
||||
# If you compile under other target please manually disable those package under 'menuconfig'
|
||||
# atrf-rssi atrf-path atrf-xtal
|
||||
# this need more work on DEPENDS work, like the dirtpan DEPENDS below.
|
||||
BEN_WPAN_MAKE_ARGS=NOGUI=1 V=1 CC_host=$(TARGET_CC)
|
||||
endif
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/tools TARGET=ben_openwrt; \
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/tools/dirtpan TARGET=ben_openwrt CFLAGS+="-I$(STAGING_DIR)/usr/include -I../include"
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/tools $(BEN_WPAN_MAKE_ARGS) && \
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/tools/dirtpan $(BEN_WPAN_MAKE_ARGS) CFLAGS+="-I$(STAGING_DIR)/usr/include -I../include"
|
||||
endef
|
||||
|
||||
define Package/ben-wpan-doc
|
||||
@ -145,6 +154,7 @@ endef
|
||||
define Package/dirtpan
|
||||
$(call Package/ben-wpan/Default)
|
||||
TITLE:=Quick and dirty IPv4 over 802.15.4 tunnel
|
||||
DEPENDS:=$(if $(CONFIG_TARGET_xburst_qi_lb60),,+libusb)
|
||||
endef
|
||||
|
||||
define Package/dirtpan/install
|
||||
|
19
ben-wpan/patches/001-disable-some-gui-apps.patch
Normal file
19
ben-wpan/patches/001-disable-some-gui-apps.patch
Normal file
@ -0,0 +1,19 @@
|
||||
diff --git a/tools/Makefile b/tools/Makefile
|
||||
index 0ebc31b..95adf51 100644
|
||||
--- a/tools/Makefile
|
||||
+++ b/tools/Makefile
|
||||
@@ -11,8 +11,12 @@
|
||||
#
|
||||
|
||||
|
||||
-BEN_DIRS=atrf-gpio atrf-id atrf-path atrf-proxy atrf-reset \
|
||||
- atrf-rssi atrf-trim atrf-txrx atrf-xmit atrf-xtal
|
||||
+BEN_DIRS=atrf-gpio atrf-id atrf-proxy atrf-reset atrf-trim \
|
||||
+ atrf-txrx atrf-xmit
|
||||
+
|
||||
+ifeq ($(NOGUI),)
|
||||
+BEN_DIRS += atrf-rssi atrf-path atrf-xtal
|
||||
+endif
|
||||
|
||||
ifneq ($(wildcard ../install/lowpan-tools-0.2.2/include/ieee802154.h),)
|
||||
DIRTPAN := dirtpan
|
Loading…
Reference in New Issue
Block a user