1
0
mirror of git://projects.qi-hardware.com/openwrt-packages.git synced 2024-06-26 05:15:07 +03:00

qball: patches went upstream, updated to 1.3

This commit is contained in:
kyak 2011-07-10 12:28:37 +04:00
parent ea2dcff5ff
commit 3b735b02bc
2 changed files with 2 additions and 26 deletions

View File

@ -6,11 +6,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=qball
PKG_VERSION:=1.2
PKG_VERSION:=1.3
PKG_RELEASE:=1
PKG_SOURCE_URL:=http://homepage.ntlworld.com/mark.harman/
PKG_SOURCE:=qball_src.zip
PKG_MD5SUM:=106736362979921cd02fa7675f38c483
PKG_MD5SUM:=78231c3ae743d6b4e92726125efec448
UNZIP_CMD=unzip -d $(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION) $(DL_DIR)/$(PKG_SOURCE)
include $(INCLUDE_DIR)/package.mk

View File

@ -1,24 +0,0 @@
--- QBall-1.2.orig/QBall/mainwindow.cpp 2011-01-05 01:58:24.000000000 +0300
+++ QBall/mainwindow.cpp 2011-02-02 17:18:47.000000000 +0300
@@ -274,7 +274,7 @@
itemScore->setZValue(1.0);
QFont font = itemScore->font();
qDebug("font size: %d", font.pointSize());
- font.setPointSize(8);
+ font.setPointSize(20);
itemScore->setFont(font);
itemScore->setPos(16, 16);
itemScore->setDefaultTextColor(Qt::yellow);
@@ -1172,6 +1172,12 @@
else if( event->key() == Qt::Key_P ) {
gamestate->userPause();
}
+ else if( event->key() == Qt::Key_Return ) {
+ QPushButton *button = qobject_cast< QPushButton* >(qApp->focusWidget());
+ if (button) {
+ button->click();
+ }
+ }
else {
QMainWindow::keyPressEvent(event);
}