1
0
mirror of git://projects.qi-hardware.com/openwrt-packages.git synced 2024-11-22 06:03:08 +02:00

libggi: patch by jow to adapt to build-system changes

This commit is contained in:
David Kühling 2011-02-28 22:15:06 +01:00
parent 5e9064e7f8
commit 3c62d2b08c
2 changed files with 21 additions and 12 deletions

View File

@ -15,9 +15,9 @@ PKG_SOURCE_URL:=@SF/ggi
PKG_MD5SUM:=4fa672b1403c9f06e8cb35e699a693f1 PKG_MD5SUM:=4fa672b1403c9f06e8cb35e699a693f1
PKG_BUILD_DIR:=$(BUILD_DIR)/libggi-$(PKG_VERSION) PKG_BUILD_DIR:=$(BUILD_DIR)/libggi-$(PKG_VERSION)
PKG_INSTALL:=1 PKG_INSTALL:=1
PKG_FIXUP:=libtool
PKG_BUILD_DEPENDS:= libtool/host PKG_FIXUP:=libtool
PKG_REMOVE_FILES:=aclocal.m4 acinclude.m4
include $(INCLUDE_DIR)/package.mk include $(INCLUDE_DIR)/package.mk

View File

@ -1,8 +1,6 @@
Index: libggi-2.2.2/configure --- a/configure
=================================================================== +++ b/configure
--- libggi-2.2.2.orig/configure 2011-01-04 19:40:37.000000000 +0100 @@ -18746,8 +18746,8 @@ fi
+++ libggi-2.2.2/configure 2011-01-04 19:40:43.000000000 +0100
@@ -18746,8 +18746,8 @@
if test "${ac_cv_header_directfb_internal_directfb_version_h+set}" = set; then if test "${ac_cv_header_directfb_internal_directfb_version_h+set}" = set; then
@ -13,7 +11,7 @@ Index: libggi-2.2.2/configure
if test "${ac_cv_header_directfb_internal_directfb_version_h+set}" = set; then if test "${ac_cv_header_directfb_internal_directfb_version_h+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6 echo $ECHO_N "(cached) $ECHO_C" >&6
fi fi
@@ -18755,8 +18755,8 @@ @@ -18755,8 +18755,8 @@ echo "$as_me:$LINENO: result: $ac_cv_hea
echo "${ECHO_T}$ac_cv_header_directfb_internal_directfb_version_h" >&6 echo "${ECHO_T}$ac_cv_header_directfb_internal_directfb_version_h" >&6
else else
# Is the header compilable? # Is the header compilable?
@ -24,7 +22,7 @@ Index: libggi-2.2.2/configure
cat >conftest.$ac_ext <<_ACEOF cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */ /* confdefs.h. */
_ACEOF _ACEOF
@@ -18764,7 +18764,7 @@ @@ -18764,7 +18764,7 @@ cat confdefs.h >>conftest.$ac_ext
cat >>conftest.$ac_ext <<_ACEOF cat >>conftest.$ac_ext <<_ACEOF
/* end confdefs.h. */ /* end confdefs.h. */
$ac_includes_default $ac_includes_default
@ -33,7 +31,7 @@ Index: libggi-2.2.2/configure
_ACEOF _ACEOF
rm -f conftest.$ac_objext rm -f conftest.$ac_objext
if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5 if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
@@ -18800,15 +18800,15 @@ @@ -18800,15 +18800,15 @@ echo "$as_me:$LINENO: result: $ac_header
echo "${ECHO_T}$ac_header_compiler" >&6 echo "${ECHO_T}$ac_header_compiler" >&6
# Is the header present? # Is the header present?
@ -52,7 +50,7 @@ Index: libggi-2.2.2/configure
_ACEOF _ACEOF
if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5 if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
(eval $ac_cpp conftest.$ac_ext) 2>conftest.er1 (eval $ac_cpp conftest.$ac_ext) 2>conftest.er1
@@ -18842,25 +18842,25 @@ @@ -18842,25 +18842,25 @@ echo "${ECHO_T}$ac_header_preproc" >&6
# So? What about this header? # So? What about this header?
case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
yes:no: ) yes:no: )
@ -94,7 +92,7 @@ Index: libggi-2.2.2/configure
( (
cat <<\_ASBOX cat <<\_ASBOX
## ------------------------------------------------------ ## ## ------------------------------------------------------ ##
@@ -18871,8 +18871,8 @@ @@ -18871,8 +18871,8 @@ _ASBOX
sed "s/^/$as_me: WARNING: /" >&2 sed "s/^/$as_me: WARNING: /" >&2
;; ;;
esac esac
@ -105,3 +103,14 @@ Index: libggi-2.2.2/configure
if test "${ac_cv_header_directfb_internal_directfb_version_h+set}" = set; then if test "${ac_cv_header_directfb_internal_directfb_version_h+set}" = set; then
echo $ECHO_N "(cached) $ECHO_C" >&6 echo $ECHO_N "(cached) $ECHO_C" >&6
else else
--- a/configure.in
+++ b/configure.in
@@ -766,7 +766,7 @@ if test "x$build_directfb_renderer" != "
[Define if you have <directfb.h> header file]),
build_directfb_renderer="no")
- AC_CHECK_HEADER(directfb-internal/directfb_version.h,
+ AC_CHECK_HEADER(directfb/directfb_version.h,
foo=bar, build_directfb_renderer="no")
fi