mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-26 00:00:36 +02:00
Merge branch 'master' of git@projects.qi-hardware.com:openwrt-packages
This commit is contained in:
commit
40841c96cd
62
dgclock/Makefile
Normal file
62
dgclock/Makefile
Normal file
@ -0,0 +1,62 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2010 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=dgclock
|
||||||
|
PKG_VERSION:=091222
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=dgclock$(PKG_VERSION).zip
|
||||||
|
PKG_SOURCE_URL:=http://clogging.web.fc2.com/dingoo/
|
||||||
|
PKG_MD5SUM:=2a5143b7a3db464488c917387445e092
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/dgclock-$(PKG_VERSION)
|
||||||
|
|
||||||
|
UNPACK_CMD=unzip -d $(1) $(DL_DIR)/$(PKG_SOURCE)
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
TARGET_CFLAGS+=\
|
||||||
|
-I$(STAGING_DIR)/usr/lib/libintl/include/ \
|
||||||
|
-I$(STAGING_DIR)/usr/lib/libiconv/include/
|
||||||
|
|
||||||
|
TARGET_LDFLAGS+=\
|
||||||
|
-Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
|
||||||
|
-L$(STAGING_DIR)/usr/lib/libintl/lib/ \
|
||||||
|
-L$(STAGING_DIR)/usr/lib/libiconv/lib/
|
||||||
|
|
||||||
|
define Package/dgclock
|
||||||
|
SECTION:=xorg-apps
|
||||||
|
CATEGORY:=Xorg
|
||||||
|
TITLE:=dgclock - sdl based date and time
|
||||||
|
URL:=http://clogging.web.fc2.com/dingoo/
|
||||||
|
DEPENDS:=+libsdl +libsdl-image +libsdl-ttf +libgl-mesa +dejavu-fonts-ttf
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/dgclock/description
|
||||||
|
Clock and date in sdl
|
||||||
|
endef
|
||||||
|
|
||||||
|
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/SDL
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
$(call Build/Compile/Default, \
|
||||||
|
A320=1\
|
||||||
|
)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/dgclock/install
|
||||||
|
$(INSTALL_DIR) \
|
||||||
|
$(1)/usr/bin
|
||||||
|
|
||||||
|
$(INSTALL_BIN) \
|
||||||
|
$(PKG_BUILD_DIR)/bin/a320/dgclock \
|
||||||
|
$(1)/usr/bin/
|
||||||
|
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,dgclock))
|
17
dgclock/patches/001-use-dejavu-font.patch
Normal file
17
dgclock/patches/001-use-dejavu-font.patch
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
diff -ruN dgclock/src/main.c dgclock.mod/src/main.c
|
||||||
|
--- dgclock/src/main.c 2009-12-21 16:00:00.000000000 +0100
|
||||||
|
+++ dgclock.mod/src/main.c 2010-02-10 11:30:11.000000000 +0100
|
||||||
|
@@ -60,11 +60,11 @@
|
||||||
|
|
||||||
|
SDL_ShowCursor(SDL_DISABLE);
|
||||||
|
|
||||||
|
- gTTFFont = TTF_OpenFont ( "mplus-2p-medium.ttf" , 15 );
|
||||||
|
+ gTTFFont = TTF_OpenFont ( "/usr/share/fonts/ttf-dejavu/DejaVuSans.ttf" , 15 );
|
||||||
|
if (!gTTFFont)
|
||||||
|
return -1;
|
||||||
|
|
||||||
|
- gTTFSmall = TTF_OpenFont ( "mplus-2p-medium.ttf" , 10 );
|
||||||
|
+ gTTFSmall = TTF_OpenFont ( "/usr/share/fonts/ttf-dejavu/DejaVuSans.ttf" , 10 );
|
||||||
|
if (!gTTFSmall)
|
||||||
|
return -1;
|
||||||
|
|
47
dgclock/patches/002-fix-bpp-on-nn.patch
Normal file
47
dgclock/patches/002-fix-bpp-on-nn.patch
Normal file
@ -0,0 +1,47 @@
|
|||||||
|
diff -ruN dgclock-091222/src/main.c dgclock-091222.mod/src/main.c
|
||||||
|
--- dgclock-091222/src/main.c 2010-02-10 11:51:51.000000000 +0100
|
||||||
|
+++ dgclock-091222.mod/src/main.c 2010-02-10 15:27:40.000000000 +0100
|
||||||
|
@@ -7,7 +7,7 @@
|
||||||
|
#include "text.h"
|
||||||
|
#include "settime.h"
|
||||||
|
|
||||||
|
-SDL_Surface *gSurfaceMain = NULL;
|
||||||
|
+SDL_Surface *gSurfaceMain, *gRealScreen = NULL;
|
||||||
|
TTF_Font *gTTFFont = NULL;
|
||||||
|
TTF_Font *gTTFSmall = NULL;
|
||||||
|
|
||||||
|
@@ -46,8 +46,9 @@
|
||||||
|
return -1;
|
||||||
|
}
|
||||||
|
|
||||||
|
- gSurfaceMain = SDL_SetVideoMode(320,240,16,0);
|
||||||
|
-
|
||||||
|
+ gSurfaceMain = SDL_CreateRGBSurface(SDL_SWSURFACE, 320, 240, 16, 0, 0, 0, 0);
|
||||||
|
+ gRealScreen = SDL_SetVideoMode(320,240,32,0);
|
||||||
|
+
|
||||||
|
if (!gSurfaceMain)
|
||||||
|
return -1;
|
||||||
|
|
||||||
|
@@ -560,7 +561,8 @@
|
||||||
|
SDL_Surface *pSurfaceText = NULL;
|
||||||
|
|
||||||
|
|
||||||
|
- SDL_Flip(gSurfaceMain);
|
||||||
|
+ SDL_BlitSurface(gSurfaceMain,NULL,gRealScreen,NULL);
|
||||||
|
+ SDL_Flip(gRealScreen);
|
||||||
|
|
||||||
|
i = 0;
|
||||||
|
quit_flag = 0;
|
||||||
|
@@ -612,8 +614,10 @@
|
||||||
|
app_make_time(&lctm);
|
||||||
|
}
|
||||||
|
|
||||||
|
- SDL_Flip(gSurfaceMain);
|
||||||
|
- SDL_Flip(gSurfaceMain); // seems double buffer
|
||||||
|
+ SDL_BlitSurface(gSurfaceMain,NULL,gRealScreen,NULL);
|
||||||
|
+ SDL_Flip(gRealScreen);
|
||||||
|
+ SDL_Flip(gRealScreen);
|
||||||
|
+
|
||||||
|
update_flag = 0;
|
||||||
|
}
|
||||||
|
|
35
robots/Makefile
Normal file
35
robots/Makefile
Normal file
@ -0,0 +1,35 @@
|
|||||||
|
# This is free software, licensed under the GNU General Public License
|
||||||
|
# v2. See /LICENSE for more information.
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=robots
|
||||||
|
PKG_VERSION:=6.6.6
|
||||||
|
PKG_RELEASE:=6
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=http://pyneo.org/t
|
||||||
|
PKG_MD5SUM:=c673aaab232243c660484d2969e3cf30
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/robots
|
||||||
|
SECTION:=utilites
|
||||||
|
CATEGORY:=Utilities
|
||||||
|
TITLE:=An robots application
|
||||||
|
URL:=http://pyneo.org/t/robots
|
||||||
|
DEPENDS:=+libncurses
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/robots/description
|
||||||
|
A robots application
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/robots/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/games
|
||||||
|
$(INSTALL_BIN) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/games/robots \
|
||||||
|
$(1)/usr/games/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,robots))
|
65
sparsehash/Makefile
Normal file
65
sparsehash/Makefile
Normal file
@ -0,0 +1,65 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2010 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=sparsehash
|
||||||
|
PKG_VERSION:=1.6
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=sparsehash-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=http://google-sparsehash.googlecode.com/files/
|
||||||
|
PKG_MD5SUM:=054fc9626730cd866ea15fe26b9462c6
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/sparsehash-$(PKG_VERSION)
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/sparsehash
|
||||||
|
SECTION:=libs
|
||||||
|
CATEGORY:=Libraries
|
||||||
|
TITLE:=Sparsehash
|
||||||
|
URL:=http://code.google.com/p/google-sparsehash/
|
||||||
|
DEPENDS:=
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/sparsehash/description
|
||||||
|
An extremely memory-efficient hash_map implementation. 2 bits/entry overhead! The SparseHash library contains several hash-map implementations, including implementations that optimize for space or speed.
|
||||||
|
These hashtable implementations are similar in API to SGI's hash_map class and the tr1 unordered_map class, but with different performance characteristics. It's easy to replace hash_map or unordered_map by sparse_hash_map or dense_hash_map in C++ code.
|
||||||
|
endef
|
||||||
|
#
|
||||||
|
# TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/SDL
|
||||||
|
#
|
||||||
|
# CONFIGURE_ARGS += \
|
||||||
|
# --with-sdl-exec-prefix=$(STAGING_DIR)
|
||||||
|
#
|
||||||
|
# CONFIGURE_VARS += \
|
||||||
|
# LIBS="-lSDL -ldirect -ldirectfb -lfusion"
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
rm -rf $(PKG_INSTALL_DIR)
|
||||||
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
|
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||||
|
all install
|
||||||
|
endef
|
||||||
|
|
||||||
|
# define Build/InstallDev
|
||||||
|
# $(INSTALL_DIR) $(1)/usr/include/SDL $(1)/usr/lib
|
||||||
|
# $(CP) \
|
||||||
|
# $(PKG_INSTALL_DIR)/usr/include/SDL/SDL_image.h \
|
||||||
|
# $(1)/usr/include/SDL/
|
||||||
|
# $(CP) \
|
||||||
|
# $(PKG_INSTALL_DIR)/usr/lib/libSDL_image*.{a,so*} \
|
||||||
|
# $(1)/usr/lib/
|
||||||
|
# endef
|
||||||
|
|
||||||
|
define Package/sparsehash/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/include/google/ $(1)/usr/lib/
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/share/doc/sparsehash-$(PKG_VERSION)/ $(1)/usr/doc/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,sparsehash))
|
1582
sparsehash/patches/0001-add-autogen.patch
Normal file
1582
sparsehash/patches/0001-add-autogen.patch
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user