mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-04 23:21:53 +02:00
new package: timidity, MIDI files player
This commit is contained in:
parent
1c605fea94
commit
49ec91899c
49
timidity++/Makefile
Normal file
49
timidity++/Makefile
Normal file
@ -0,0 +1,49 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=TiMidity++
|
||||
PKG_VERSION:=2.13.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://downloads.sourceforge.net/project/TiMidity/TiMidity++/TiMidity++-2.13.2/TiMidity++/TiMidity++-2.13.2.tar.bz2
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/TiMidity++
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=TiMidity++
|
||||
URL:=http://TiMidity.sourceforge.net/
|
||||
DEPENDS:=@BROKEN
|
||||
endef
|
||||
|
||||
define Package/TiMidity++/description
|
||||
TiMidity++ is a software synthesizer. It can play MIDI files by converting them into PCM waveform data
|
||||
endef
|
||||
|
||||
TARGET_LDFLAGS += -Wl,-rpath-link -Wl,$(STAGING_DIR)/usr/lib
|
||||
|
||||
define Build/Prepare
|
||||
$(call Build/Prepare/Default)
|
||||
cp ./files/nanonote_newton_table.c $(PKG_BUILD_DIR)/timidity/newton_table.c
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); \
|
||||
export AUTOMAKE="automake --foreign --add-missing --copy"; \
|
||||
autoreconf)
|
||||
$(call Build/Configure/Default, --enable-audio=alsa)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/Default)
|
||||
endef
|
||||
define Package/TiMidity++/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) \
|
||||
$(PKG_BUILD_DIR)/timidity/timidity \
|
||||
$(1)/usr/bin
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,TiMidity++))
|
3364
timidity++/files/nanonote_newton_table.c
Normal file
3364
timidity++/files/nanonote_newton_table.c
Normal file
File diff suppressed because it is too large
Load Diff
15
timidity++/patches/001-remove-generate-newton_table.c.patch
Normal file
15
timidity++/patches/001-remove-generate-newton_table.c.patch
Normal file
@ -0,0 +1,15 @@
|
||||
diff --git a/timidity/Makefile.am b/timidity/Makefile.am
|
||||
index a411d87..5d031ca 100644
|
||||
--- a/timidity/Makefile.am
|
||||
+++ b/timidity/Makefile.am
|
||||
@@ -319,10 +319,6 @@ if WATCOM_C
|
||||
newton_table.c: calcnewt$(EXEEXT)
|
||||
./calcnewt > $@
|
||||
|
||||
-else
|
||||
-newton_table.c: calcnewt$(EXEEXT)
|
||||
- ./calcnewt > $@
|
||||
-
|
||||
endif
|
||||
endif
|
||||
|
Loading…
Reference in New Issue
Block a user