1
0
mirror of git://projects.qi-hardware.com/openwrt-packages.git synced 2024-07-01 02:11:05 +03:00

gnuplot-gfx: reworked truecolor fixes to upstream-submittable

This commit is contained in:
David Kühling 2011-01-09 11:36:37 +01:00
parent cf3da20f8e
commit 52ae1d77d9
3 changed files with 24 additions and 17 deletions

View File

@ -29,7 +29,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=gnuplot-gfx
PKG_ORIG_NAME=gnuplot
PKG_VERSION:=4.4.0
PKG_RELEASE:=3
PKG_RELEASE:=5
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_ORIG_NAME)-$(PKG_VERSION)
HOST_BUILD_DIR = $(BUILD_DIR_HOST)/$(PKG_ORIG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_ORIG_NAME)-$(PKG_VERSION).tar.gz

View File

@ -1,19 +1,13 @@
Index: gnuplot-4.4.0/term/linux.trm
===================================================================
--- gnuplot-4.4.0.orig/term/linux.trm 2011-01-06 16:42:27.000000000 +0100
+++ gnuplot-4.4.0/term/linux.trm 2011-01-08 12:28:08.000000000 +0100
@@ -94,8 +94,12 @@
#define _STRING_H_
#include <vga.h>
--- gnuplot-4.4.0.orig/term/linux.trm 2011-01-09 10:20:04.000000000 +0100
+++ gnuplot-4.4.0/term/linux.trm 2011-01-09 10:45:51.000000000 +0100
@@ -241,7 +241,7 @@
linetype = LT_BLACK;
if (linetype >= 13)
linetype %= 13;
- vga_setcolor(vgacolor[linetype + 2]);
+ vga_setegacolor(vgacolor[linetype + 2]);
}
-static int linux_vmode = G1024x768x256; /* default mode */
-static int vgacolor[] = { 7, 8, 2, 3, 4, 5, 9, 14, 12, 15, 13, 10, 11, 1, 6 };
+static int linux_vmode = G320x240x16M32; /* default mode */
+/* static int vgacolor[] = { 7, 8, 2, 3, 4, 5, 9, 14, 12, 15, 13, 10, 11, 1, 6 }; */
+static int vgacolor[] = {
+ 0xc0c0c0, 0x808080, 0x008000, 0x008080, 0x800000, 0x800080,
+ 0x0000ff, 0xffff00, 0xff0000, 0xffffff, 0xff00ff, 0x00ff00,
+ 0x00ffff, 0x000080, 0x808000 };
static int graphics_on = FALSE;
static vga_modeinfo *modeinfo;
static int linux_startx, linux_starty, linux_lasty;
TERM_PUBLIC void

View File

@ -0,0 +1,13 @@
Index: gnuplot-4.4.0/term/linux.trm
===================================================================
--- gnuplot-4.4.0.orig/term/linux.trm 2011-01-09 10:29:36.000000000 +0100
+++ gnuplot-4.4.0/term/linux.trm 2011-01-09 10:29:52.000000000 +0100
@@ -94,7 +94,7 @@
#define _STRING_H_
#include <vga.h>
-static int linux_vmode = G1024x768x256; /* default mode */
+static int linux_vmode = G320x240x16M32; /* default mode */
static int vgacolor[] = { 7, 8, 2, 3, 4, 5, 9, 14, 12, 15, 13, 10, 11, 1, 6 };
static int graphics_on = FALSE;
static vga_modeinfo *modeinfo;