mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-16 18:54:04 +02:00
Initial Port of plucker (plkr.org) handheld reader. It's market as
@BROKEN. It compiles and works but further improvemnt of GUI is necessary.
This commit is contained in:
parent
712b269303
commit
54f53a6ca7
53
plucker/Makefile
Normal file
53
plucker/Makefile
Normal file
@ -0,0 +1,53 @@
|
|||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=plucker
|
||||||
|
PKG_VERSION:=1.8
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)_src-$(PKG_VERSION).tar.bz2
|
||||||
|
PKG_SOURCE_URL:=http://downloads.plkr.org/1.8/
|
||||||
|
PKG_CAT:=bzip2 -cd
|
||||||
|
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/plucker
|
||||||
|
SECTION:=utils
|
||||||
|
CATEGORY:=Utilities
|
||||||
|
TITLE:=Plucker files reader (PDB)
|
||||||
|
DEPENDS:=@BROKEN +zlib +libintl +libiconv +libgconf2 +libjpeg +pixman +fontconfig +libfreetype +pango +atk +libpng +DirectFB
|
||||||
|
URL=http://www.plkr.org
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/plucker/description
|
||||||
|
Plucker can view files made by the Plucker Distiller (Project Gutenberg books, for example).
|
||||||
|
endef
|
||||||
|
|
||||||
|
|
||||||
|
TARGET_CFLAGS+= -I$(STAGING_DIR)/usr/lib/libintl/include
|
||||||
|
TARGET_LDFLAGS+= -L$(STAGING_DIR)/usr/lib/libintl/lib
|
||||||
|
TARGET_LDFLAGS+= -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
|
||||||
|
|
||||||
|
define Build/Configure
|
||||||
|
$(call Build/Configure/Default, \
|
||||||
|
--prefix=/usr \
|
||||||
|
--disable-palmosbuild \
|
||||||
|
--disable-docbuild \
|
||||||
|
--disable-java-distiller\
|
||||||
|
--enable-gtkviewer\
|
||||||
|
--enable-unplug \
|
||||||
|
--disable-explode \
|
||||||
|
--disable-desktopbuild, \
|
||||||
|
LIBS="-L$(STAGING_DIR)/usr/lib/libiconv/lib -L$(STAGING_DIR)/usr/lib/libintl/lib -L$(STAGING_DIR)/usr/lib -lgtk-directfb-2.0 -lgdk-directfb-2.0 -latk-1.0 -lgio-2.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lpangoft2-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -lintl -liconv -lfreetype -lfontconfig -ljpeg -lpng -lpixman-1 -ldirectfb -ldirect -lfusion -lexpat -lz -lm"\
|
||||||
|
)
|
||||||
|
endef
|
||||||
|
|
||||||
|
|
||||||
|
define Package/plucker/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/viewer-GTK+2-POSIX/plucker $(1)/usr/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,plucker))
|
51
plucker/Makefile.bad
Normal file
51
plucker/Makefile.bad
Normal file
@ -0,0 +1,51 @@
|
|||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=plucker
|
||||||
|
PKG_VERSION:=1.8
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)_src-$(PKG_VERSION).tar.bz2
|
||||||
|
PKG_SOURCE_URL:=http://downloads.plkr.org/1.8/
|
||||||
|
PKG_CAT:=bzip2 -cd
|
||||||
|
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/plucker
|
||||||
|
SECTION:=utils
|
||||||
|
CATEGORY:=Utilities
|
||||||
|
TITLE:=Plucker files reader (PDB)
|
||||||
|
DEPENDS:=+zlib +libintl +libiconv +libgconf2 +gtk +jpeg +pixman +fontconfig +libfreetype +pango +atk +libpng +DirectFB
|
||||||
|
URL=http://www.plkr.org
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/plucker/description
|
||||||
|
Plucker can view files made by the Plucker Distiller (Project Gutenberg books, for example).
|
||||||
|
endef
|
||||||
|
|
||||||
|
#TARGET_CFLAGS+=-"I$(STAGING_DIR)/usr/include/gtk-2.0 -I$(STAGING_DIR)/usr/include"
|
||||||
|
|
||||||
|
define Build/Configure
|
||||||
|
$(call Build/Configure/Default, \
|
||||||
|
--prefix=/usr \
|
||||||
|
--disable-palmosbuild \
|
||||||
|
--disable-docbuild \
|
||||||
|
--disable-java-distiller\
|
||||||
|
--enable-gtkviewer\
|
||||||
|
--enable-unplug \
|
||||||
|
--disable-explode \
|
||||||
|
--disable-desktopbuild, \
|
||||||
|
LIBS="-L$(STAGING_DIR)/usr/lib/libintl/lib -L$(STAGING_DIR)/usr/lib/libiconv/lib -L$(STAGING_DIR)/usr/lib" \
|
||||||
|
GTK2LIBS="-latk -lpixman -lfontconfig -lpng"\
|
||||||
|
)
|
||||||
|
endef
|
||||||
|
|
||||||
|
|
||||||
|
define Package/plucker/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/viewer-GTK+2-POSIX/plucker $(1)/usr/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,plucker))
|
19
plucker/patches/configure.patch
Normal file
19
plucker/patches/configure.patch
Normal file
@ -0,0 +1,19 @@
|
|||||||
|
--- plucker-1.8/configure 2004-05-19 17:19:43.000000000 +0200
|
||||||
|
+++ plucker-1.8m/configure 2010-07-31 17:14:40.040292498 +0200
|
||||||
|
@@ -4655,6 +4655,7 @@
|
||||||
|
has_jpeg_library=no
|
||||||
|
fi
|
||||||
|
|
||||||
|
+BUILD_UNPLUCK=yes
|
||||||
|
|
||||||
|
if test "$BUILD_UNPLUCK" != "yes"; then
|
||||||
|
echo "$as_me:$LINENO: result: libunpluck will not be built, by request" >&5
|
||||||
|
@@ -4670,6 +4671,8 @@
|
||||||
|
BUILD_UNPLUCK=no
|
||||||
|
fi
|
||||||
|
|
||||||
|
+BUILD_UNPLUCK=yes
|
||||||
|
+
|
||||||
|
if test "$BUILD_EXPLODE" = "no" ; then
|
||||||
|
echo "$as_me:$LINENO: result: explode will not be built, by request" >&5
|
||||||
|
echo "${ECHO_T}explode will not be built, by request" >&6
|
Loading…
Reference in New Issue
Block a user