mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 00:19:20 +02:00
add dfbsee makefile
marked as broken Signed-off-by: Mirko Lindner <mirko@sharism.cc>
This commit is contained in:
parent
f53c2e8159
commit
56054b32a7
76
dfbsee/Makefile
Normal file
76
dfbsee/Makefile
Normal file
@ -0,0 +1,76 @@
|
||||
#
|
||||
# Copyright (c) 2010 wejp
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=dfbsee
|
||||
PKG_VERSION:=0.7.4
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=DFBSee-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.directfb.org/download/DFBSee/
|
||||
PKG_MD5SUM:=3320a976457d3b3e9eaef530fdf56b37
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/DFBSee-$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/dfbsee
|
||||
SECTION:=multimedia
|
||||
CATEGORY:=Multimedia
|
||||
TITLE:=directfb media player
|
||||
URL:=
|
||||
MENU:=1
|
||||
DEPENDS:=@BROKEN
|
||||
endef
|
||||
|
||||
define Package/dfbsee/description
|
||||
A popular music player for various handheld devices.
|
||||
It supports various file formats and comes with a
|
||||
file browser and a playlist editor/viewer.
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
|
||||
|
||||
define Build/Compile
|
||||
-$(MAKE) -C $(PKG_BUILD_DIR) distclean
|
||||
(cd $(PKG_BUILD_DIR); \
|
||||
./configure \
|
||||
);
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/src \
|
||||
volume-tables-gen
|
||||
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/src \
|
||||
volume-tables.header
|
||||
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) distclean
|
||||
|
||||
$(call Build/Configure/Default, \
|
||||
);
|
||||
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/src/gfx \
|
||||
$(MAKE_OPTS) \
|
||||
gfx.h
|
||||
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/src \
|
||||
dfbsee
|
||||
endef
|
||||
|
||||
define Package/dfbsee/install
|
||||
$(INSTALL_DIR) \
|
||||
$(1)/usr/share/DFBSee \
|
||||
$(1)/usr/bin \
|
||||
|
||||
$(INSTALL_BIN) \
|
||||
$(PKG_BUILD_DIR)/src/dfbsee \
|
||||
$(1)/usr/bin/
|
||||
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_BUILD_DIR)/data/decker.ttf \
|
||||
$(1)/usr/share/DFBSee/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,dfbsee))
|
105
dfbsee/patches/010-fix-compile.patch
Normal file
105
dfbsee/patches/010-fix-compile.patch
Normal file
@ -0,0 +1,105 @@
|
||||
# --- T2-COPYRIGHT-NOTE-BEGIN ---
|
||||
# This copyright note is auto-generated by ./scripts/Create-CopyPatch.
|
||||
#
|
||||
# T2 SDE: package/.../dfbsee/compile-fix.patch
|
||||
# Copyright (C) 2004 - 2005 The T2 SDE Project
|
||||
#
|
||||
# More information can be found in the files COPYING and README.
|
||||
#
|
||||
# This patch file is dual-licensed. It is available under the license the
|
||||
# patched project is licensed under, as long as it is an OpenSource license
|
||||
# as defined at http://www.opensource.org/ (e.g. BSD, X11) or under the terms
|
||||
# of the GNU General Public License as published by the Free Software
|
||||
# Foundation; either version 2 of the License, or (at your option) any later
|
||||
# version.
|
||||
# --- T2-COPYRIGHT-NOTE-END ---
|
||||
diff -Nur DFBSee-0.7.4.orig/src/main.c DFBSee-0.7.4/src/main.c
|
||||
--- DFBSee-0.7.4.orig/src/main.c 2002-11-02 01:08:18.000000000 +0200
|
||||
+++ DFBSee-0.7.4/src/main.c 2005-11-01 17:57:22.000000000 +0200
|
||||
@@ -53,7 +53,7 @@
|
||||
main (int argc,
|
||||
char **argv)
|
||||
{
|
||||
- DFBCardCapabilities caps;
|
||||
+ DFBGraphicsDeviceDescription desc;
|
||||
DFBSurfaceDescription dsc;
|
||||
IDirectFBEventBuffer *buffer;
|
||||
IDirectFBSurface *image_area;
|
||||
@@ -78,8 +78,8 @@
|
||||
/* create the super interface */
|
||||
DFBCHECK (DirectFBCreate (&dfb));
|
||||
|
||||
- dfb->GetCardCapabilities (dfb, &caps);
|
||||
- hw_stretchblit = caps.acceleration_mask & DFXL_STRETCHBLIT;
|
||||
+ dfb->GetDeviceDescription (dfb, &desc);
|
||||
+ hw_stretchblit = desc.acceleration_mask & DFXL_STRETCHBLIT;
|
||||
|
||||
dfb->SetCooperativeLevel (dfb, DFSCL_FULLSCREEN);
|
||||
|
||||
diff -Nur DFBSee-0.7.4.orig/src/rotate.c DFBSee-0.7.4/src/rotate.c
|
||||
--- DFBSee-0.7.4.orig/src/rotate.c 2002-08-26 21:14:14.000000000 +0200
|
||||
+++ DFBSee-0.7.4/src/rotate.c 2005-11-01 18:02:17.000000000 +0200
|
||||
@@ -43,9 +43,9 @@
|
||||
{\
|
||||
*d = *s;\
|
||||
s++;\
|
||||
- (__u8*)d += dest_pitch;\
|
||||
+ d = ((void*) d) + dest_pitch;\
|
||||
}\
|
||||
- (__u8*)src += src_pitch;\
|
||||
+ src = ((void*) src) + src_pitch;\
|
||||
}\
|
||||
}\
|
||||
|
||||
@@ -53,7 +53,7 @@
|
||||
{\
|
||||
type d;\
|
||||
type s;\
|
||||
- (__u8 *) dest += (height - 1) * dest_pitch;\
|
||||
+ dest = ((void*) dest) + (height - 1) * dest_pitch;\
|
||||
for (w = 0; w < width; w++)\
|
||||
{\
|
||||
h = height;\
|
||||
@@ -63,9 +63,9 @@
|
||||
{\
|
||||
*d = *s;\
|
||||
s++;\
|
||||
- (__u8*)d -= dest_pitch;\
|
||||
+ d = ((void*) d) - dest_pitch;\
|
||||
}\
|
||||
- (__u8*)src += src_pitch;\
|
||||
+ src = ((void*) src) + src_pitch;\
|
||||
}\
|
||||
}\
|
||||
|
||||
@@ -73,7 +73,7 @@
|
||||
{\
|
||||
type d;\
|
||||
type s;\
|
||||
- (__u8 *) dest += (height - 1) * dest_pitch;\
|
||||
+ dest = ((void*) dest) + (height - 1) * dest_pitch;\
|
||||
while (--height)\
|
||||
{\
|
||||
d = (type) dest + width - 1;\
|
||||
@@ -85,8 +85,8 @@
|
||||
s++;\
|
||||
d--;\
|
||||
}\
|
||||
- (__u8*)src += src_pitch;\
|
||||
- (__u8*)dest -= dest_pitch;\
|
||||
+ src = ((void*) src) - src_pitch;\
|
||||
+ dest = ((void*) dest) + dest_pitch;\
|
||||
}\
|
||||
}\
|
||||
|
||||
@@ -172,7 +172,7 @@
|
||||
source->Lock (source, DSLF_READ, &src, &src_pitch);
|
||||
destination->Lock (destination, DSLF_READ, &dest, &dest_pitch);
|
||||
|
||||
- (__u8 *) dest += dest_pitch * y + DFB_BYTES_PER_PIXEL (pixelformat) * x;
|
||||
+ dest += dest_pitch * y + DFB_BYTES_PER_PIXEL (pixelformat) * x;
|
||||
|
||||
rotate (dest, dest_pitch,
|
||||
src, src_pitch, width, height, DFB_BYTES_PER_PIXEL (pixelformat),
|
||||
|
||||
|
12
dfbsee/patches/020-asm-types.patch
Normal file
12
dfbsee/patches/020-asm-types.patch
Normal file
@ -0,0 +1,12 @@
|
||||
*** DFBSee-0.7.4/src/rotate.c 2010-04-16 20:01:33.000000000 +0200
|
||||
--- b-DFBSee-0.7.4/src/rotate.c 2010-04-17 10:45:19.000000000 +0200
|
||||
***************
|
||||
*** 26,31 ****
|
||||
--- 26,32 ----
|
||||
|
||||
#include "dfbsee.h"
|
||||
#include "rotate.h"
|
||||
+ #include <asm/types.h>
|
||||
|
||||
|
||||
#define SWAP(a,b,tmp) { (tmp) = *(b); *(b) = *(a); *(a) = (tmp); }
|
35
dfbsee/patches/030-makefile-am.patch
Normal file
35
dfbsee/patches/030-makefile-am.patch
Normal file
@ -0,0 +1,35 @@
|
||||
*** DFBSee-0.7.4/src/Makefile.am 2002-08-12 16:24:43.000000000 +0200
|
||||
--- b-DFBSee-0.7.4/src/Makefile.am 2010-04-17 12:39:26.000000000 +0200
|
||||
***************
|
||||
*** 42,46 ****
|
||||
volume_tables_gen_INCLUDES =
|
||||
volume_tables_gen_LDADD = -lm
|
||||
|
||||
! volume-tables.h: volume-tables-gen
|
||||
./volume-tables-gen > $(srcdir)/volume-tables.h
|
||||
--- 42,46 ----
|
||||
volume_tables_gen_INCLUDES =
|
||||
volume_tables_gen_LDADD = -lm
|
||||
|
||||
! volume-tables.header: volume-tables-gen
|
||||
./volume-tables-gen > $(srcdir)/volume-tables.h
|
||||
|
||||
*** DFBSee-0.7.4/src/Makefile.in 2002-11-13 01:14:10.000000000 +0100
|
||||
--- b-DFBSee-0.7.4/src/Makefile.in 2010-04-17 12:45:26.000000000 +0200
|
||||
***************
|
||||
*** 402,408 ****
|
||||
maintainer-clean-generic clean mostlyclean distclean maintainer-clean
|
||||
|
||||
|
||||
! volume-tables.h: volume-tables-gen
|
||||
./volume-tables-gen > $(srcdir)/volume-tables.h
|
||||
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
--- 402,408 ----
|
||||
maintainer-clean-generic clean mostlyclean distclean maintainer-clean
|
||||
|
||||
|
||||
! volume-tables.header: volume-tables-gen
|
||||
./volume-tables-gen > $(srcdir)/volume-tables.h
|
||||
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
Loading…
Reference in New Issue
Block a user