mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 18:57:31 +02:00
gnuplot: Build and package help files for internal documentation system
This commit is contained in:
parent
21acf8eb42
commit
59ad4eac72
@ -13,15 +13,97 @@ PKG_NAME:=gnuplot-ggi
|
||||
PKG_ORIG_NAME=gnuplot
|
||||
PKG_VERSION:=4.4.0
|
||||
PKG_RELEASE:=2
|
||||
PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_ORIG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL=1
|
||||
|
||||
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_ORIG_NAME)-$(PKG_VERSION)
|
||||
HOST_BUILD_DIR = $(BUILD_DIR_HOST)/$(PKG_ORIG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(PKG_ORIG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/gnuplot
|
||||
PKG_MD5SUM:=e708665bd512153ad5c35252fe499059
|
||||
|
||||
PKG_INSTALL=1
|
||||
PKG_BUILD_DEPENDS:= gnuplot-ggi/host libtool/host
|
||||
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/gnuplot-ggi/Default
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=A portable command-line driven graphing utility
|
||||
URL:=http://sourceforge.net/projects/gnuplot/
|
||||
endef
|
||||
|
||||
define Package/gnuplot-ggi/Default/description
|
||||
Gnuplot is a portable command-line driven graphing utility for linux, OS/2,
|
||||
MS Windows, OSX, VMS, and many other platforms. This version is compiled
|
||||
to use LibGGI as default terminal, allowing gnuplot to draw directly to
|
||||
the Linux framebuffer.
|
||||
endef
|
||||
|
||||
define Package/gnuplot-ggi
|
||||
$(call Package/gnuplot-ggi/Default)
|
||||
DEPENDS:=+libncurses +uclibcxx +zlib +libpng +libfreetype +libgd +libintl +libiconv
|
||||
TITLE+=
|
||||
endef
|
||||
|
||||
define Package/gnuplot-ggi-gih
|
||||
$(call Package/gnuplot-ggi/Default)
|
||||
DEPENDS:=+gnuplot-ggi
|
||||
TITLE+=(integrated help)
|
||||
endef
|
||||
|
||||
define Package/gnuplot-ggi-gih/description
|
||||
$(call Package/gnuplot-ggi/Default/description)
|
||||
This package contains the documentation files needed for GNUplot\'s internal
|
||||
help system.
|
||||
endef
|
||||
|
||||
##
|
||||
## Compile for the host
|
||||
##
|
||||
|
||||
# We need the doc2gih tool compiled on the *host* to get GNUplot's online
|
||||
# documentation when compiling for the target.
|
||||
|
||||
HOST_CONFIGURE_VARS += \
|
||||
--without-x \
|
||||
--without-tutorial \
|
||||
--without-lisp-files \
|
||||
--without-ggi
|
||||
|
||||
define Host/Configure
|
||||
$(call Host/Configure/Default)
|
||||
endef
|
||||
|
||||
define Host/Compile
|
||||
$(MAKE) -C $(HOST_BUILD_DIR)/docs doc2gih alldoc2gih
|
||||
endef
|
||||
|
||||
define Host/Install
|
||||
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
|
||||
$(INSTALL_BIN) $(HOST_BUILD_DIR)/docs/{doc2gih,alldoc2gih} \
|
||||
$(STAGING_DIR_HOST)/bin/
|
||||
endef
|
||||
|
||||
##
|
||||
## Compile for the target
|
||||
##
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--without-x \
|
||||
--without-tutorial \
|
||||
--without-row-help \
|
||||
--without-lisp-files \
|
||||
--with-ggi \
|
||||
--with-gihdir=/usr/share/gnuplot
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \
|
||||
CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++" \
|
||||
LIBS="-nodefaultlibs -luClibc++ -lpthread -lgcc"
|
||||
|
||||
TARGET_CPPFLAGS += -DDEFAULTTERM=\\\"ggi\\\"
|
||||
|
||||
# todo: insto cppflags
|
||||
TARGET_CFLAGS += \
|
||||
-I$(STAGING_DIR)/usr/lib/libintl/include \
|
||||
-I$(STAGING_DIR)/usr/lib/libiconv/include
|
||||
@ -31,31 +113,6 @@ TARGET_LDFLAGS+= \
|
||||
-L$(STAGING_DIR)/usr/lib/libintl/lib \
|
||||
-L$(STAGING_DIR)/usr/lib/libiconv/lib
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \
|
||||
CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++" \
|
||||
LIBS="-nodefaultlibs -luClibc++ -lpthread -lgcc"
|
||||
|
||||
define Package/gnuplot-ggi
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
DEPENDS:=+libncurses +uclibcxx +zlib +libpng +libfreetype +libgd +libintl +libiconv
|
||||
TITLE:=A portable command-line driven graphing utility
|
||||
URL:=http://sourceforge.net/projects/gnuplot/
|
||||
endef
|
||||
|
||||
define Package/gnuplot-ggi/description
|
||||
Gnuplot is a portable command-line driven graphing utility for linux, OS/2,
|
||||
MS Windows, OSX, VMS, and many other platforms.
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--without-x \
|
||||
--without-tutorial \
|
||||
--without-row-help \
|
||||
--without-lisp-files \
|
||||
--with-ggi
|
||||
|
||||
# cannot disable mouse for ggi: compilation fails. (todo: fix)
|
||||
# --disable-mouse
|
||||
|
||||
@ -69,7 +126,15 @@ define Package/gnuplot-ggi/install
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gnuplot $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
define Package/gnuplot-ggi-gih/install
|
||||
$(INSTALL_DIR) $(1)/usr/share/gnuplot/
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/gnuplot/gnuplot.gih \
|
||||
$(1)/usr/share/gnuplot/
|
||||
endef
|
||||
|
||||
$(eval $(call HostBuild))
|
||||
$(eval $(call BuildPackage,gnuplot-ggi))
|
||||
$(eval $(call BuildPackage,gnuplot-ggi-gih))
|
||||
|
||||
|
||||
# The following comments configure the Emacs editor. Just ignore them.
|
||||
|
@ -1,11 +1,13 @@
|
||||
--- a/Makefile.in.orig 2010-03-13 22:20:04.000000000 +0100
|
||||
+++ b/Makefile.in 2010-06-03 15:08:35.000000000 +0200
|
||||
Index: gnuplot-4.4.0/Makefile.in
|
||||
===================================================================
|
||||
--- gnuplot-4.4.0.orig/Makefile.in 2010-03-13 22:20:04.000000000 +0100
|
||||
+++ gnuplot-4.4.0/Makefile.in 2011-01-05 12:48:51.000000000 +0100
|
||||
@@ -240,7 +240,7 @@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
AUTOMAKE_OPTIONS = foreign 1.2h
|
||||
-SUBDIRS = config m4 term src docs $(LISPDIR) man demo tutorial share
|
||||
+SUBDIRS = config m4 term src $(LISPDIR) share
|
||||
+SUBDIRS = config m4 term src docs $(LISPDIR) share
|
||||
EXTRA_DIST = BUGS CodeStyle Copyright FAQ.pdf GNUmakefile INSTALL INSTALL.gnu \
|
||||
Makefile.maint PATCHLEVEL PGPKEYS PORTING README README.1ST \
|
||||
VERSION configure.vms pm3d
|
||||
|
26
gnuplot-ggi/patches/030-host-doc2gih.patch
Normal file
26
gnuplot-ggi/patches/030-host-doc2gih.patch
Normal file
@ -0,0 +1,26 @@
|
||||
Index: gnuplot-4.4.0/docs/Makefile.in
|
||||
===================================================================
|
||||
--- gnuplot-4.4.0.orig/docs/Makefile.in 2011-01-05 13:07:42.000000000 +0100
|
||||
+++ gnuplot-4.4.0/docs/Makefile.in 2011-01-05 13:08:04.000000000 +0100
|
||||
@@ -339,9 +339,11 @@
|
||||
### gnuplot interactive help format
|
||||
gih: gnuplot.gih
|
||||
|
||||
+# Note: here we have to use the host-compiled doc2gih tool, that the build
|
||||
+# process installs in the staging bin directory
|
||||
gnuplot.gih: doc2gih $(srcdir)/gnuplot.doc
|
||||
@rm -f alldoc2gih
|
||||
- ./doc2gih $(srcdir)/gnuplot.doc gnuplot.gih
|
||||
+ doc2gih $(srcdir)/gnuplot.doc gnuplot.gih
|
||||
|
||||
doc2gih: doc2gih.o termdoc.o
|
||||
$(LINK) doc2gih.o termdoc.o $(LIBS)
|
||||
@@ -349,7 +351,7 @@
|
||||
# To include all terminals in the .gih file
|
||||
allgih: alldoc2gih $(srcdir)/gnuplot.doc
|
||||
@rm -f doc2gih
|
||||
- ./alldoc2gih $(srcdir)/gnuplot.doc gnuplot.gih
|
||||
+ alldoc2gih $(srcdir)/gnuplot.doc gnuplot.gih
|
||||
|
||||
alldoc2gih: alldoc2gih.o termdoc.o
|
||||
$(LINK) alldoc2gih.o termdoc.o $(LIBS)
|
Loading…
Reference in New Issue
Block a user