mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 09:41:53 +02:00
cgminer: update to 2.5.0
This commit is contained in:
parent
be0ae261af
commit
5fb69ba453
@ -9,8 +9,8 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=cgminer
|
PKG_NAME:=cgminer
|
||||||
PKG_VERSION:=20120516
|
PKG_VERSION:=20120723
|
||||||
PKG_REV:=b69d735cfe468c489a24677ffef1d6d998818cac
|
PKG_REV:=4abecc26745c8fb473b6df67ac55f85e95a85275
|
||||||
# this is upstream version 2.4.1
|
# this is upstream version 2.4.1
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=4
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
15
cgminer/patches/0001-add-roundl-define.patch
Normal file
15
cgminer/patches/0001-add-roundl-define.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
diff --git a/miner.h b/miner.h
|
||||||
|
index 120d763..7b7d6d5 100644
|
||||||
|
--- a/miner.h
|
||||||
|
+++ b/miner.h
|
||||||
|
@@ -159,6 +159,10 @@ void *alloca (size_t);
|
||||||
|
#define ARRAY_SIZE(arr) (sizeof(arr) / sizeof((arr)[0]))
|
||||||
|
#endif
|
||||||
|
|
||||||
|
+#ifndef roundl
|
||||||
|
+#define roundl(x) (long double)((long long)((x==0)?0.0:((x)+((x)>0)?0.5:-0.5)))
|
||||||
|
+#endif
|
||||||
|
+
|
||||||
|
enum alive {
|
||||||
|
LIFE_WELL,
|
||||||
|
LIFE_SICK,
|
Loading…
Reference in New Issue
Block a user