mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 22:22:49 +02:00
[new package] [frotz] A Portable Z-Machine Interpreter
something wrong when install. we need pass correct folder to frotz's Makefile. Mark as BROKEN.
This commit is contained in:
parent
cf8fece57f
commit
61b8c5c6cf
38
frotz/Makefile
Normal file
38
frotz/Makefile
Normal file
@ -0,0 +1,38 @@
|
|||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=frotz
|
||||||
|
PKG_VERSION:=2.43
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/frotz
|
||||||
|
TITLE:=frotz
|
||||||
|
SECTION:=utils
|
||||||
|
CATEGORY:=Utilities
|
||||||
|
DEPENDS:=@BROKEN +libncurses
|
||||||
|
URL:=http://frotz.sourceforge.net/
|
||||||
|
endef
|
||||||
|
|
||||||
|
MAKE_VARS +=CONFIG_DIR=/etc \
|
||||||
|
INCL=-I$(STAGING_DIR)/usr/include \
|
||||||
|
LIB=-L$(STAGING_DIR)/usr/lib \
|
||||||
|
SOUND_DEV=/dev/dsp \
|
||||||
|
SOUND_DEFS=-DOSS_SOUND \
|
||||||
|
CURSES=-lncurses \
|
||||||
|
CURSES_DEF=-DUSE_NCURSES_H
|
||||||
|
|
||||||
|
define Package/frotz/description
|
||||||
|
A Portable Z-Machine Interpreter
|
||||||
|
endef
|
||||||
|
|
||||||
|
|
||||||
|
define Package/frotz/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/frotz $(1)/usr/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,frotz))
|
49
frotz/patches/001-change-strip-to-variable.patch
Normal file
49
frotz/patches/001-change-strip-to-variable.patch
Normal file
@ -0,0 +1,49 @@
|
|||||||
|
change the strip to $(STRIP).
|
||||||
|
|
||||||
|
From: Xiangfu Liu <xiangfu@sharism.cc>
|
||||||
|
|
||||||
|
when cross compile we need use cross comppile strip.
|
||||||
|
|
||||||
|
Signed-off-by: Xiangfu Liu <xiangfu@sharism.cc>
|
||||||
|
---
|
||||||
|
Makefile | 6 +++---
|
||||||
|
1 files changed, 3 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/Makefile b/Makefile
|
||||||
|
index 3e1253a..aae3eaa 100644
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -3,6 +3,7 @@
|
||||||
|
#
|
||||||
|
CC = gcc
|
||||||
|
#CC = cc
|
||||||
|
+STRIP = strip
|
||||||
|
|
||||||
|
# Define your optimization flags. Most compilers understand -O and -O2,
|
||||||
|
# Standard (note: Solaris on UltraSparc using gcc 2.8.x might not like this.)
|
||||||
|
@@ -213,7 +214,7 @@ soundcard.h:
|
||||||
|
fi
|
||||||
|
|
||||||
|
install: $(NAME)
|
||||||
|
- strip $(BINNAME)$(EXTENSION)
|
||||||
|
+ $(STRIP) $(BINNAME)$(EXTENSION)
|
||||||
|
install -d $(PREFIX)/bin
|
||||||
|
install -d $(MAN_PREFIX)/man/man6
|
||||||
|
install -c -m 755 $(BINNAME)$(EXTENSION) $(PREFIX)/bin
|
||||||
|
@@ -226,7 +227,7 @@ uninstall:
|
||||||
|
deinstall: uninstall
|
||||||
|
|
||||||
|
install_dumb: d$(NAME)
|
||||||
|
- strip d$(BINNAME)$(EXTENSION)
|
||||||
|
+ $(STRIP) d$(BINNAME)$(EXTENSION)
|
||||||
|
install -d $(PREFIX)/bin
|
||||||
|
install -d $(MAN_PREFIX)/man/man6
|
||||||
|
install -c -m 755 d$(BINNAME)$(EXTENSION) $(PREFIX)/bin
|
||||||
|
@@ -264,7 +265,6 @@ distclean: clean
|
||||||
|
rm -f *core $(SRCDIR)/*core
|
||||||
|
-rm -rf $(distdir)
|
||||||
|
-rm -f $(distdir).tar $(distdir).tar.gz
|
||||||
|
-
|
||||||
|
realclean: distclean
|
||||||
|
|
||||||
|
clobber: distclean
|
Loading…
Reference in New Issue
Block a user