mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 19:09:42 +02:00
First port to OpenWRT: patchet terminal limits. Makred as BROKEN until
someone confirmes that it is useable.
This commit is contained in:
parent
ec1da6d705
commit
6c8e93b357
51
abook/Makefile
Normal file
51
abook/Makefile
Normal file
@ -0,0 +1,51 @@
|
|||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=abook
|
||||||
|
PKG_VERSION:=0.5.6
|
||||||
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
|
PKG_SOURCE:=abook-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=@SF/abook
|
||||||
|
PKG_MD5SUM:=87d25df96864a7c507a4965e6d1da49d
|
||||||
|
PKG_CAT:=zcat
|
||||||
|
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/abook-$(PKG_VERSION)
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/abook
|
||||||
|
SECTION:=utils
|
||||||
|
CATEGORY:=Utilities
|
||||||
|
TITLE:=abook
|
||||||
|
URL:=http://abook.sourceforge.net/
|
||||||
|
DEPENDS:= +libreadline +libncurses @BROKEN
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/abook/description
|
||||||
|
Simple address book program.
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Configure
|
||||||
|
$(call Build/Configure/Default, \
|
||||||
|
--prefix=/usr \
|
||||||
|
)
|
||||||
|
endef
|
||||||
|
|
||||||
|
#define Build/Configure
|
||||||
|
# (cd $(PKG_BUILD_DIR); \
|
||||||
|
# $(TARGET_CONFIGURE_OPTS) \
|
||||||
|
# CFLAGS="$(TARGET_CFLAGS) $(FPIC)" \
|
||||||
|
# UNAME_S="Linux" \
|
||||||
|
# ./configure \
|
||||||
|
# --host=mipsel \
|
||||||
|
# --prefix=/usr \
|
||||||
|
# );
|
||||||
|
#endef
|
||||||
|
|
||||||
|
|
||||||
|
define Package/abook/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin/
|
||||||
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/abook $(1)/usr/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,abook))
|
13
abook/patches/abook_h.patch
Normal file
13
abook/patches/abook_h.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
--- abook-0.5.6/abook.h 2005-09-17 12:10:25.000000000 +0200
|
||||||
|
+++ abook-0.5.6m/abook.h 2010-09-08 19:50:56.316495243 +0200
|
||||||
|
@@ -17,8 +17,8 @@
|
||||||
|
|
||||||
|
#define Y_STATUSLINE (LINES - 2)
|
||||||
|
|
||||||
|
-#define MIN_LINES 20
|
||||||
|
-#define MIN_COLS 70
|
||||||
|
+#define MIN_LINES 15
|
||||||
|
+#define MIN_COLS 40
|
||||||
|
|
||||||
|
#define DEFAULT_UMASK 066
|
||||||
|
#define DIR_IN_HOME ".abook"
|
Loading…
Reference in New Issue
Block a user