mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 17:15:01 +02:00
Merge branch 'master' of projects.qi-hardware.com:openwrt-packages
This commit is contained in:
commit
712b269303
@ -16,7 +16,7 @@ define Package/centerim
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
SUBMENU:=Instant Messaging
|
||||
DEPENDS:=+libncurses +libreadline
|
||||
DEPENDS:=+libncurses +libreadline +gpgme
|
||||
TITLE:=Universal IM client
|
||||
URL:=http://www.centerim.org
|
||||
endef
|
||||
@ -26,7 +26,7 @@ define Package/centerim/description
|
||||
Works in a character terminal.
|
||||
endef
|
||||
|
||||
CONFIGURE_VARS+=ac_cv_lib_ncurses_initscr=yes ac_cv_path_GPGME_CONFIG=""
|
||||
CONFIGURE_VARS+=ac_cv_lib_ncurses_initscr=yes
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default, \
|
||||
|
74
gpgme/Makefile
Normal file
74
gpgme/Makefile
Normal file
@ -0,0 +1,74 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gpgme
|
||||
PKG_VERSION:=1.3.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=ftp://ftp.gnupg.org/gcrypt/gpgme/
|
||||
PKG_MD5SUM:=f148c73f6f540f91e02141df72844f62
|
||||
PKG_FIXUP:=libtool
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
PKG_INSTALL=1
|
||||
|
||||
define Package/gpgme
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=GnuPG Made Easy
|
||||
URL:=http://www.gnupg.org
|
||||
DEPENDS:=+libgpg-error +libassuan
|
||||
endef
|
||||
|
||||
define Package/gpgme/description
|
||||
GPGME (GnuPG Made Easy) is a C language library that allows to add
|
||||
support for cryptography to a program. It is designed to make
|
||||
access to public key crypto engines like GnuPG or GpgSM easier
|
||||
for applications. GPGME provides a high-level crypto API for
|
||||
encryption, decryption, signing, signature verification and key management.
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default, \
|
||||
--with-pth=no --with-gpg="" --with-gpgsm="" \
|
||||
--with-gpgconf="" --with-g13="" \
|
||||
--enable-shared --enable-static \
|
||||
)
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(2)/bin $(1)/usr/bin
|
||||
$(INSTALL_BIN) \
|
||||
$(PKG_INSTALL_DIR)/usr/bin/gpgme-config \
|
||||
$(2)/bin/
|
||||
$(SED) \
|
||||
's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
|
||||
$(2)/bin/gpgme-config
|
||||
ln -sf $(STAGING_DIR)/host/bin/gpgme-config $(1)/usr/bin/gpgme-config
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_INSTALL_DIR)/usr/include/gpgme.h \
|
||||
$(1)/usr/include/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/libgpgme.{la,a,so*} \
|
||||
$(1)/usr/lib/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/share/aclocal
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_INSTALL_DIR)/usr/share/aclocal/gpgme.m4 \
|
||||
$(1)/usr/share/aclocal/
|
||||
endef
|
||||
|
||||
define Package/gpgme/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/libgpgme.so.* \
|
||||
$(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,gpgme))
|
76
libassuan/Makefile
Normal file
76
libassuan/Makefile
Normal file
@ -0,0 +1,76 @@
|
||||
#
|
||||
# Copyright (C) 2005-2009 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libassuan
|
||||
PKG_VERSION:=2.0.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=ftp://ftp.gnupg.org/gcrypt/libassuan/
|
||||
PKG_MD5SUM:=59bc0ae7194c412d7a522029005684b2
|
||||
PKG_FIXUP:=libtool
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
PKG_INSTALL=1
|
||||
|
||||
define Package/libassuan
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=IPC library used by some GnuPG related software
|
||||
URL:=http://www.gnupg.org
|
||||
endef
|
||||
|
||||
define Package/libassuan/description
|
||||
Libassuan is the IPC library used by some GnuPG related software.
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default, \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
)
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(2)/bin $(1)/usr/bin
|
||||
$(INSTALL_BIN) \
|
||||
$(PKG_INSTALL_DIR)/usr/bin/libassuan-config \
|
||||
$(2)/bin/
|
||||
$(SED) \
|
||||
's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
|
||||
$(2)/bin/libassuan-config
|
||||
ln -sf $(STAGING_DIR)/host/bin/libassuan-config $(1)/usr/bin/libassuan-config
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_INSTALL_DIR)/usr/include/assuan.h \
|
||||
$(1)/usr/include/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/libassuan.{la,a,so*} \
|
||||
$(1)/usr/lib/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/share/aclocal
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_INSTALL_DIR)/usr/share/aclocal/libassuan.m4 \
|
||||
$(1)/usr/share/aclocal/
|
||||
endef
|
||||
|
||||
define Package/libassuan/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/libassuan.so.* \
|
||||
$(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libassuan))
|
71
libphysfs/Makefile
Normal file
71
libphysfs/Makefile
Normal file
@ -0,0 +1,71 @@
|
||||
|
||||
|
||||
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libphysfs
|
||||
PKG_VERSION:=2.0.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
#PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE:=physfs-2.0.0.tar.gz
|
||||
PKG_SOURCE_URL:=http://icculus.org/physfs/downloads/
|
||||
PKG_MD5SUM:=cfc53e0c193914c9c5ab522e58737373
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/physfs-$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libphysfs
|
||||
SECTION:=games
|
||||
CATEGORY:=Games
|
||||
TITLE:=PhysicsFS
|
||||
URL:=http://icculus.org/physfs/
|
||||
endef
|
||||
|
||||
define Package/libphysfs/description
|
||||
PhysicsFS is a library to provide abstract access to various archives.
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR);\
|
||||
IN_OPENWRT=1 \
|
||||
AR="$(TARGET_CROSS)ar" \
|
||||
AS="$(TARGET_CC) -c $(TARGET_CFLAGS)" \
|
||||
LD="$(TARGET_CROSS)ld" \
|
||||
NM="$(TARGET_CROSS)nm" \
|
||||
CC="$(TARGET_CC)" \
|
||||
GCC="$(TARGET_CC)" \
|
||||
CXX="$(TARGET_CROSS)g++" \
|
||||
RANLIB="$(TARGET_CROSS)ranlib" \
|
||||
STRIP="$(TARGET_CROSS)strip" \
|
||||
OBJCOPY="$(TARGET_CROSS)objcopy" \
|
||||
OBJDUMP="$(TARGET_CROSS)objdump" \
|
||||
TARGET_CPPFLAGS="$(TARGET_CPPFLAGS)" \
|
||||
TARGET_CFLAGS="$(TARGET_CFLAGS)" \
|
||||
TARGET_LDFLAGS="$(TARGET_LDFLAGS)" \
|
||||
cmake .);$
|
||||
$(call Build/Compile/Default)$
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
mkdir -p $(1)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/local/include/physfs.h $(1)/usr/include/
|
||||
mkdir -p $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/local/lib/libphysfs.so* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Package/libphysfs/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_BUILD_DIR)/libphysfs.so* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libphysfs))
|
20
libphysfs/patches/CMakeLists.patch
Normal file
20
libphysfs/patches/CMakeLists.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- physfs-2.0.0/CMakeLists.txt 2009-03-23 06:13:28.000000000 +0100
|
||||
+++ physfs-2.0.0m/CMakeLists.txt 2010-07-28 20:16:16.893088173 +0200
|
||||
@@ -44,7 +44,7 @@
|
||||
# Add some gcc-specific command lines.
|
||||
IF(CMAKE_COMPILER_IS_GNUCC)
|
||||
# Always build with debug symbols...you can strip it later.
|
||||
- ADD_DEFINITIONS(-g -pipe -Werror -fsigned-char)
|
||||
+ ADD_DEFINITIONS(-g -Werror -fsigned-char)
|
||||
|
||||
# Stupid BeOS generates warnings in the system headers.
|
||||
IF(NOT BEOS)
|
||||
@@ -315,7 +315,7 @@
|
||||
SET(PHYSFS_INSTALL_TARGETS ${PHYSFS_INSTALL_TARGETS} ";test_physfs")
|
||||
ENDIF(PHYSFS_BUILD_TEST)
|
||||
|
||||
-OPTION(PHYSFS_BUILD_WX_TEST "Build wxWidgets test program." TRUE)
|
||||
+OPTION(PHYSFS_BUILD_WX_TEST "Build wxWidgets test program." FALSE)
|
||||
MARK_AS_ADVANCED(PHYSFS_BUILD_WX_TEST)
|
||||
IF(PHYSFS_BUILD_WX_TEST)
|
||||
SET(wxWidgets_USE_LIBS base core adv)
|
Loading…
Reference in New Issue
Block a user