mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-04 23:03:10 +02:00
remove overriden gettext, iconv, glib2 due to fixed upstream
This commit is contained in:
parent
3f266040c0
commit
745e0f4673
@ -1,63 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2006-2010 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gettext
|
||||
PKG_VERSION:=0.18.1.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=gettext-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@GNU/gettext
|
||||
PKG_MD5SUM:=3dd55b952826d2b32f51308f2f91aa89
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/gettext-$(PKG_VERSION)
|
||||
|
||||
PKG_FIXUP:=libtool
|
||||
PKG_INSTALL:=1
|
||||
PKG_BUILD_PARALLEL:=0
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libintl
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=GNU Internationalization library
|
||||
URL:=http://www.gnu.org/software/gettext/
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--disable-rpath \
|
||||
--enable-nls \
|
||||
--disable-java \
|
||||
--disable-native-java \
|
||||
--disable-openmp \
|
||||
--with-included-gettext \
|
||||
--without-libintl-prefix \
|
||||
--without-libexpat-prefix \
|
||||
--without-emacs
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/libintl.h $(1)/usr/include/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libintl.{a,so*} $(1)/usr/lib/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/share/aclocal
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/aclocal/* $(1)/usr/share/aclocal/
|
||||
endef
|
||||
|
||||
define Package/libintl/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libintl.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libintl))
|
@ -1,35 +0,0 @@
|
||||
--- a/gettext-runtime/man/Makefile.am
|
||||
+++ b/gettext-runtime/man/Makefile.am
|
||||
@@ -159,8 +159,7 @@ bind_textdomain_codeset.3.html: bind_tex
|
||||
$(MAN2HTML) $(srcdir)/bind_textdomain_codeset.3.in | sed -e '/CreationDate:/d' > t-$@
|
||||
mv t-$@ $@
|
||||
|
||||
-install-html-local:
|
||||
- $(mkdir_p) $(DESTDIR)$(htmldir)
|
||||
+install-html: installdirs-html
|
||||
for file in $(man_HTML); do \
|
||||
if test -f $$file; then dir=.; else dir=$(srcdir); fi; \
|
||||
$(INSTALL_DATA) $$dir/$$file $(DESTDIR)$(htmldir)/$$file; \
|
||||
--- a/gettext-tools/man/Makefile.am
|
||||
+++ b/gettext-tools/man/Makefile.am
|
||||
@@ -186,8 +186,7 @@ autopoint.1.html: autopoint.1
|
||||
$(MAN2HTML) `if test -f autopoint.1; then echo .; else echo $(srcdir); fi`/autopoint.1 | sed -e '/CreationDate:/d' > t-$@
|
||||
mv t-$@ $@
|
||||
|
||||
-install-html-local:
|
||||
- $(mkdir_p) $(DESTDIR)$(htmldir)
|
||||
+install-html: installdirs-html
|
||||
for file in $(man_HTML); do \
|
||||
if test -f $$file; then dir=.; else dir=$(srcdir); fi; \
|
||||
$(INSTALL_DATA) $$dir/$$file $(DESTDIR)$(htmldir)/$$file; \
|
||||
--- a/gettext-runtime/intl/Makefile.in
|
||||
+++ b/gettext-runtime/intl/Makefile.in
|
||||
@@ -19,7 +19,7 @@
|
||||
PACKAGE = @PACKAGE@
|
||||
VERSION = @VERSION@
|
||||
|
||||
-SHELL = /bin/sh
|
||||
+SHELL = @SHELL@
|
||||
|
||||
srcdir = @srcdir@
|
||||
top_srcdir = @top_srcdir@
|
@ -1,22 +0,0 @@
|
||||
--- a/gettext-runtime/Makefile.in
|
||||
+++ b/gettext-runtime/Makefile.in
|
||||
@@ -208,7 +208,7 @@ AM_RECURSIVE_TARGETS = $(RECURSIVE_TARGE
|
||||
ETAGS = etags
|
||||
CTAGS = ctags
|
||||
DIST_SUBDIRS = doc intl intl-java intl-csharp gnulib-lib libasprintf \
|
||||
- src po man m4 tests
|
||||
+ src po man m4
|
||||
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
|
||||
distdir = $(PACKAGE)-$(VERSION)
|
||||
top_distdir = $(distdir)
|
||||
--- a/gettext-tools/Makefile.in
|
||||
+++ b/gettext-tools/Makefile.in
|
||||
@@ -1248,7 +1248,7 @@ top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
|
||||
ACLOCAL_AMFLAGS = -I m4 -I ../gettext-runtime/m4 -I ../m4 -I gnulib-m4 -I libgrep/gnulib-m4 -I libgettextpo/gnulib-m4
|
||||
-SUBDIRS = doc intl gnulib-lib libgrep src libgettextpo po projects styles misc man m4 tests gnulib-tests examples
|
||||
+SUBDIRS = doc intl gnulib-lib libgrep src libgettextpo po projects styles misc man m4
|
||||
|
||||
# Allow users to use "gnulib-tool --update".
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- a/gettext-tools/libgettextpo/error.h
|
||||
+++ b/gettext-tools/libgettextpo/error.h
|
||||
@@ -49,7 +49,7 @@ extern void error_at_line (int __status,
|
||||
/* If NULL, error will flush stdout, then print on stderr the program
|
||||
name, a colon and a space. Otherwise, error will call this
|
||||
function without parameters instead. */
|
||||
-extern DLL_VARIABLE void (*error_print_progname) (void);
|
||||
+void (*error_print_progname) (void);
|
||||
|
||||
/* This variable is incremented each time `error' is called. */
|
||||
extern DLL_VARIABLE unsigned int error_message_count;
|
@ -1,17 +0,0 @@
|
||||
uclibc defines __GLIBC__ but it does not expose struct shed_param as much as glibc
|
||||
and is not needed too per standard. gnulib attempts to use it but we have to account
|
||||
for it because in this case uclibc does not behave like glibc.
|
||||
|
||||
-Khem
|
||||
|
||||
--- a/gettext-tools/gnulib-lib/spawn.in.h
|
||||
+++ b/gettext-tools/gnulib-lib/spawn.in.h
|
||||
@@ -31,7 +31,7 @@
|
||||
|
||||
/* Get definitions of 'struct sched_param' and 'sigset_t'.
|
||||
But avoid namespace pollution on glibc systems. */
|
||||
-#ifndef __GLIBC__
|
||||
+#if !defined __GLIBC__ || defined __UCLIBC__
|
||||
# include <sched.h>
|
||||
# include <signal.h>
|
||||
#endif
|
@ -1,10 +0,0 @@
|
||||
--- a/gettext-runtime/intl/intl-compat.c
|
||||
+++ b/gettext-runtime/intl/intl-compat.c
|
||||
@@ -131,3 +131,7 @@ bind_textdomain_codeset (const char *dom
|
||||
{
|
||||
return libintl_bind_textdomain_codeset (domainname, codeset);
|
||||
}
|
||||
+
|
||||
+#ifdef __UCLIBC__
|
||||
+DLL_EXPORTED void (*error_print_progname)(void) = NULL;
|
||||
+#endif
|
@ -1,11 +0,0 @@
|
||||
--- a/gettext-runtime/intl/localename.c
|
||||
+++ b/gettext-runtime/intl/localename.c
|
||||
@@ -2780,7 +2780,7 @@ gl_locale_name_posix (int category, cons
|
||||
{
|
||||
/* Use the POSIX methods of looking to 'LC_ALL', 'LC_xxx', and 'LANG'.
|
||||
On some systems this can be done by the 'setlocale' function itself. */
|
||||
-#if defined HAVE_SETLOCALE && defined HAVE_LC_MESSAGES && defined HAVE_LOCALE_NULL
|
||||
+#if defined HAVE_SETLOCALE && defined HAVE_LC_MESSAGES && defined HAVE_LOCALE_NULL && (!defined __UCLIBC__ || defined __UCLIBC_HAS_LOCALE__)
|
||||
return setlocale (category, NULL);
|
||||
#else
|
||||
/* On other systems we ignore what setlocale reports and instead look at the
|
@ -1,22 +0,0 @@
|
||||
--- a/gettext-tools/gnulib-lib/libxml/xmlversion.in.h
|
||||
+++ b/gettext-tools/gnulib-lib/libxml/xmlversion.in.h
|
||||
@@ -263,7 +263,7 @@ XMLPUBFUN void XMLCALL xmlCheckVersion(i
|
||||
*
|
||||
* Whether iconv support is available
|
||||
*/
|
||||
-#if 1
|
||||
+#if 0
|
||||
#define LIBXML_ICONV_ENABLED
|
||||
#endif
|
||||
|
||||
--- a/gnulib-local/lib/libxml/xmlversion.in.h
|
||||
+++ b/gnulib-local/lib/libxml/xmlversion.in.h
|
||||
@@ -263,7 +263,7 @@ XMLPUBFUN void XMLCALL xmlCheckVersion(i
|
||||
*
|
||||
* Whether iconv support is available
|
||||
*/
|
||||
-#if 1
|
||||
+#if 0
|
||||
#define LIBXML_ICONV_ENABLED
|
||||
#endif
|
||||
|
@ -1,26 +0,0 @@
|
||||
diff --git a/gettext-runtime/intl/localename.c b/gettext-runtime/intl/localename.c
|
||||
index 89a9692..5e86bc4 100644
|
||||
--- a/gettext-runtime/intl/localename.c
|
||||
+++ b/gettext-runtime/intl/localename.c
|
||||
@@ -2607,7 +2607,7 @@ gl_locale_name_thread_unsafe (int category, const char *categoryname)
|
||||
locale_t thread_locale = uselocale (NULL);
|
||||
if (thread_locale != LC_GLOBAL_LOCALE)
|
||||
{
|
||||
-# if __GLIBC__ >= 2
|
||||
+# if __GLIBC__ >= 2 && !defined __UCLIBC__
|
||||
/* Work around an incorrect definition of the _NL_LOCALE_NAME macro in
|
||||
glibc < 2.12.
|
||||
See <http://sourceware.org/bugzilla/show_bug.cgi?id=10968>. */
|
||||
diff --git a/gettext-tools/gnulib-lib/localename.c b/gettext-tools/gnulib-lib/localename.c
|
||||
index dab5e5b..85149ac 100644
|
||||
--- a/gettext-tools/gnulib-lib/localename.c
|
||||
+++ b/gettext-tools/gnulib-lib/localename.c
|
||||
@@ -2607,7 +2607,7 @@ gl_locale_name_thread_unsafe (int category, const char *categoryname)
|
||||
locale_t thread_locale = uselocale (NULL);
|
||||
if (thread_locale != LC_GLOBAL_LOCALE)
|
||||
{
|
||||
-# if __GLIBC__ >= 2
|
||||
+# if __GLIBC__ >= 2 && !defined __UCLIBC__
|
||||
/* Work around an incorrect definition of the _NL_LOCALE_NAME macro in
|
||||
glibc < 2.12.
|
||||
See <http://sourceware.org/bugzilla/show_bug.cgi?id=10968>. */
|
105
glib2/Makefile
105
glib2/Makefile
@ -1,105 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2007 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=glib2
|
||||
PKG_VERSION:=2.22.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=glib-$(PKG_VERSION).tar.bz2
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/glib-$(PKG_VERSION)
|
||||
PKG_SOURCE_URL:=@GNOME/glib/2.22
|
||||
PKG_MD5SUM:=846a86c74b74d5b16826aa5508940f9b
|
||||
|
||||
PKG_FIXUP:=libtool
|
||||
PKG_BUILD_DEPENDS:=glib2/host
|
||||
PKG_INSTALL:=1
|
||||
|
||||
HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/glib-$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/host-build.mk
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/glib2
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
DEPENDS:=+libiconv +libintl
|
||||
TITLE:=glib 2.0
|
||||
URL:=http://www.gtk.org/
|
||||
endef
|
||||
|
||||
define Package/glib2/description
|
||||
The GLib library of C routines
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS+= \
|
||||
$(FPIC) \
|
||||
-I$(STAGING_DIR)/usr/lib/libiconv/include \
|
||||
-I$(STAGING_DIR)/usr/lib/libintl/include
|
||||
|
||||
TARGET_LDFLAGS+= \
|
||||
-L$(STAGING_DIR)/usr/lib/libiconv/lib \
|
||||
-L$(STAGING_DIR)/usr/lib/libintl/lib
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default, \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--enable-debug=no \
|
||||
--with-libiconv=gnu \
|
||||
--disable-selinux \
|
||||
--disable-fam \
|
||||
, \
|
||||
glib_cv_stack_grows=no \
|
||||
glib_cv_uscore=no \
|
||||
ac_cv_path_GLIB_GENMARSHAL=$(STAGING_DIR_HOST)/bin/glib-genmarshal \
|
||||
ac_cv_func_mmap_fixed_mapped=yes \
|
||||
);
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/include/glib-2.0 \
|
||||
$(1)/usr/include/
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/glib-2.0/include/*.h \
|
||||
$(1)/usr/include/glib-2.0/
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/include/gio-unix-2.0 \
|
||||
$(1)/usr/include/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/glib-2.0 \
|
||||
$(1)/usr/lib/
|
||||
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/*.{so*,a,la} \
|
||||
$(1)/usr/lib/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/*.pc \
|
||||
$(1)/usr/lib/pkgconfig
|
||||
|
||||
$(INSTALL_DIR) $(2)/share/aclocal/
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_INSTALL_DIR)/usr/share/aclocal/*.m4 \
|
||||
$(2)/share/aclocal/
|
||||
endef
|
||||
|
||||
define Package/glib2/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/*.so* \
|
||||
$(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call HostBuild))
|
||||
$(eval $(call BuildPackage,glib2))
|
@ -1,12 +0,0 @@
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -2682,7 +2682,8 @@ dnl **************************
|
||||
dnl *** Checks for gtk-doc ***
|
||||
dnl **************************
|
||||
|
||||
-GTK_DOC_CHECK([1.11])
|
||||
+AM_CONDITIONAL([ENABLE_GTK_DOC], [false])
|
||||
+AM_CONDITIONAL([GTK_DOC_USE_LIBTOOL], [false])
|
||||
|
||||
AC_ARG_ENABLE(man,
|
||||
[AC_HELP_STRING([--enable-man],
|
@ -1,10 +0,0 @@
|
||||
--- glib-2.18.1/glib-2.0.pc.in.orig 2008-10-03 22:32:17.000000000 +0200
|
||||
+++ glib-2.18.1/glib-2.0.pc.in 2008-10-03 22:32:42.000000000 +0200
|
||||
@@ -10,6 +10,5 @@
|
||||
Name: GLib
|
||||
Description: C Utility Library
|
||||
Version: @VERSION@
|
||||
-Libs: -L${libdir} -lglib-2.0 @INTLLIBS@
|
||||
-Libs.private: @ICONV_LIBS@
|
||||
+Libs: -L${libdir} -lglib-2.0 @INTLLIBS@ @ICONV_LIBS@
|
||||
Cflags: -I${includedir}/glib-2.0 -I${libdir}/glib-2.0/include @GLIB_EXTRA_CFLAGS@
|
@ -1,120 +0,0 @@
|
||||
--- a/gio/Makefile.in
|
||||
+++ b/gio/Makefile.in
|
||||
@@ -242,7 +242,7 @@ ETAGS = etags
|
||||
CTAGS = ctags
|
||||
am__tty_colors = \
|
||||
red=; grn=; lgn=; blu=; std=
|
||||
-DIST_SUBDIRS = libasyncns xdgmime inotify fen win32 . fam tests
|
||||
+DIST_SUBDIRS = libasyncns xdgmime inotify fen . fam
|
||||
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
|
||||
am__relativize = \
|
||||
dir0=`pwd`; \
|
||||
@@ -489,7 +489,7 @@ EXTRA_DIST = gio-marshal.list gio.symbol
|
||||
TEST_PROGS =
|
||||
NULL =
|
||||
SUBDIRS = $(am__append_1) $(am__append_2) $(am__append_6) \
|
||||
- $(am__append_9) . $(am__append_12) tests
|
||||
+ $(am__append_9) . $(am__append_12)
|
||||
@MS_LIB_AVAILABLE_TRUE@@OS_WIN32_AND_DLL_COMPILATION_TRUE@noinst_DATA = gio-2.0.lib
|
||||
@MS_LIB_AVAILABLE_TRUE@@OS_WIN32_AND_DLL_COMPILATION_TRUE@install_ms_lib_cmd = $(INSTALL) gio-2.0.lib $(DESTDIR)$(libdir)
|
||||
@MS_LIB_AVAILABLE_TRUE@@OS_WIN32_AND_DLL_COMPILATION_TRUE@uninstall_ms_lib_cmd = -rm $(DESTDIR)$(libdir)/gio-2.0.lib
|
||||
--- a/glib/Makefile.in
|
||||
+++ b/glib/Makefile.in
|
||||
@@ -483,8 +483,8 @@ TEST_PROGS =
|
||||
@ENABLE_REGEX_TRUE@gregex_c = gregex.c
|
||||
@ENABLE_REGEX_FALSE@gregex_h =
|
||||
@ENABLE_REGEX_TRUE@gregex_h = gregex.h
|
||||
-SUBDIRS = libcharset $(PRINTF_SUBDIR) $(MAYBE_PCRE) update-pcre . tests
|
||||
-DIST_SUBDIRS = libcharset gnulib pcre update-pcre tests
|
||||
+SUBDIRS = libcharset $(PRINTF_SUBDIR) $(MAYBE_PCRE) update-pcre .
|
||||
+DIST_SUBDIRS = libcharset gnulib pcre update-pcre
|
||||
AM_CPPFLAGS = \
|
||||
-I$(top_srcdir) \
|
||||
$(pcre_inc) \
|
||||
--- a/gobject/Makefile.in
|
||||
+++ b/gobject/Makefile.in
|
||||
@@ -413,7 +413,7 @@ TEST_PROGS =
|
||||
# GObject - GLib Type, Object, Parameter and Signal Library
|
||||
# Copyright (C) 1997,98,99,2000 Tim Janik and Red Hat, Inc.
|
||||
#
|
||||
-SUBDIRS = . tests
|
||||
+SUBDIRS = .
|
||||
AM_CPPFLAGS = \
|
||||
-DG_LOG_DOMAIN=\"GLib-GObject\" \
|
||||
-I$(top_srcdir) \
|
||||
--- a/Makefile.in
|
||||
+++ b/Makefile.in
|
||||
@@ -398,7 +398,7 @@ EXTRA_DIST = ChangeLog.pre-2-20 ChangeLo
|
||||
gio-2.0-uninstalled.pc.in gio-unix-2.0-uninstalled.pc.in
|
||||
TEST_PROGS =
|
||||
AUTOMAKE_OPTIONS = 1.7
|
||||
-SUBDIRS = . m4macros glib gmodule gthread gobject gio tests po docs
|
||||
+SUBDIRS = . m4macros glib gmodule gthread gobject gio
|
||||
DIST_SUBDIRS = $(SUBDIRS) build
|
||||
bin_SCRIPTS = glib-gettextize
|
||||
AM_CPPFLAGS = \
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -3470,18 +3470,6 @@ gio/fen/Makefile
|
||||
gio/fam/Makefile
|
||||
gio/win32/Makefile
|
||||
gio/tests/Makefile
|
||||
-po/Makefile.in
|
||||
-docs/Makefile
|
||||
-docs/reference/Makefile
|
||||
-docs/reference/glib/Makefile
|
||||
-docs/reference/glib/version.xml
|
||||
-docs/reference/gobject/Makefile
|
||||
-docs/reference/gobject/version.xml
|
||||
-docs/reference/gio/Makefile
|
||||
-docs/reference/gio/version.xml
|
||||
-tests/Makefile
|
||||
-tests/gobject/Makefile
|
||||
-tests/refcount/Makefile
|
||||
m4macros/Makefile
|
||||
])
|
||||
|
||||
--- a/gio/Makefile.am
|
||||
+++ b/gio/Makefile.am
|
||||
@@ -174,8 +174,6 @@ win32_sources = \
|
||||
|
||||
endif
|
||||
|
||||
-SUBDIRS += tests
|
||||
-
|
||||
libgio_2_0_la_SOURCES = \
|
||||
gappinfo.c \
|
||||
gasynchelper.c \
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -3,7 +3,7 @@ include $(top_srcdir)/Makefile.decl
|
||||
|
||||
AUTOMAKE_OPTIONS = 1.7
|
||||
|
||||
-SUBDIRS = . m4macros glib gmodule gthread gobject gio tests po docs
|
||||
+SUBDIRS = . m4macros glib gmodule gthread gobject gio
|
||||
DIST_SUBDIRS = $(SUBDIRS) build
|
||||
|
||||
bin_SCRIPTS = glib-gettextize
|
||||
--- a/glib/Makefile.am
|
||||
+++ b/glib/Makefile.am
|
||||
@@ -19,7 +19,7 @@ gregex_c =
|
||||
gregex_h =
|
||||
endif
|
||||
|
||||
-SUBDIRS = libcharset $(PRINTF_SUBDIR) $(MAYBE_PCRE) update-pcre . tests
|
||||
+SUBDIRS = libcharset $(PRINTF_SUBDIR) $(MAYBE_PCRE) update-pcre .
|
||||
|
||||
DIST_SUBDIRS = libcharset gnulib pcre update-pcre tests
|
||||
|
||||
--- a/gobject/Makefile.am
|
||||
+++ b/gobject/Makefile.am
|
||||
@@ -4,7 +4,7 @@
|
||||
## Process this file with automake to produce Makefile.in
|
||||
include $(top_srcdir)/Makefile.decl
|
||||
|
||||
-SUBDIRS = . tests
|
||||
+SUBDIRS = .
|
||||
|
||||
AM_CPPFLAGS = \
|
||||
-DG_LOG_DOMAIN=\"GLib-GObject\" \
|
@ -1,86 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2006-2009 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libiconv
|
||||
PKG_VERSION:=1.11.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=libiconv-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@GNU/libiconv
|
||||
PKG_MD5SUM:=d42b97f6ef5dd0ba4469d520ed732fed
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/libiconv-$(PKG_VERSION)
|
||||
|
||||
PKG_FIXUP = libtool no-autoreconf
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libiconv/Default
|
||||
URL:=http://www.gnu.org/software/libiconv/
|
||||
TITLE:=Character set conversion
|
||||
endef
|
||||
|
||||
define Package/libiconv
|
||||
$(call Package/libiconv/Default)
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE+= library
|
||||
endef
|
||||
|
||||
define Package/libcharset
|
||||
$(call Package/libiconv/Default)
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE+= library
|
||||
endef
|
||||
|
||||
define Package/iconv
|
||||
$(call Package/libiconv/Default)
|
||||
DEPENDS:=+libiconv +libcharset
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE+= utility
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += $(FPIC) -DUSE_DOS
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--disable-rpath \
|
||||
--enable-relocatable
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
CC="$(TARGET_CC)" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
install
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/iconv.h $(1)/usr/include/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libcharset.{a,so*} $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libiconv.{a,so*} $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Package/libcharset/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libcharset.so* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Package/libiconv/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libiconv.so* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libcharset))
|
||||
$(eval $(call BuildPackage,libiconv))
|
||||
$(eval $(call BuildPackage,iconv))
|
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
@ -1,31 +0,0 @@
|
||||
--- /dev/null
|
||||
+++ b/Makefile.am
|
||||
@@ -0,0 +1,2 @@
|
||||
+ACLOCAL_AMFLAGS = -I m4
|
||||
+SUBDIRS = .
|
||||
--- /dev/null
|
||||
+++ b/libcharset/Makefile.am
|
||||
@@ -0,0 +1 @@
|
||||
+ACLOCAL_AMFLAGS = -I m4
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -54,7 +54,7 @@ AC_ISC_POSIX
|
||||
|
||||
dnl checks for installer options
|
||||
|
||||
-AC_RELOCATABLE
|
||||
+gl_RELOCATABLE
|
||||
|
||||
AC_ARG_ENABLE([extra-encodings],
|
||||
[AC_HELP_STRING([--enable-extra-encodings],
|
||||
--- a/libcharset/configure.ac
|
||||
+++ b/libcharset/configure.ac
|
||||
@@ -41,7 +41,7 @@ AC_CANONICAL_HOST
|
||||
|
||||
dnl checks for installer options
|
||||
|
||||
-AC_RELOCATABLE_LIBRARY
|
||||
+gl_RELOCATABLE_LIBRARY
|
||||
|
||||
dnl checks for programs
|
||||
|
@ -1,17 +0,0 @@
|
||||
Make iconv 1.11.x link correctly with libtool2 - argument "-Xcompiler" ensures "-shared" is passed to $(CC) when used as linker. Otherwise $(CC) tries to create an executable and fails while looking for a main()-function
|
||||
|
||||
diff -ruN libiconv-1.11.1/lib/Makefile.in libiconv-1.11.1.mod/lib/Makefile.in
|
||||
--- libiconv-1.11.1/lib/Makefile.in 2006-07-14 15:18:42.000000000 +0200
|
||||
+++ libiconv-1.11.1.mod/lib/Makefile.in 2010-12-01 20:47:57.000000000 +0100
|
||||
@@ -70,9 +70,9 @@
|
||||
|
||||
preloadable_libiconv_linux.so : $(SOURCES)
|
||||
if test -n "@GCC@"; then \
|
||||
- $(LIBTOOL_LINK) $(CC) $(LDFLAGS) $(INCLUDES) $(CFLAGS) $(CPPFLAGS) $(DEFS) -fPIC -DPIC -DLIBICONV_PLUG $(SOURCES) -shared -o preloadable_libiconv_linux.so; \
|
||||
+ $(LIBTOOL_LINK) $(CC) $(LDFLAGS) $(INCLUDES) $(CFLAGS) $(CPPFLAGS) $(DEFS) -fPIC -DPIC -DLIBICONV_PLUG $(SOURCES) -Xcompiler -shared -o preloadable_libiconv_linux.so; \
|
||||
else \
|
||||
- $(LIBTOOL_LINK) $(CC) $(LDFLAGS) $(INCLUDES) $(CFLAGS) $(CPPFLAGS) $(DEFS) -KPIC -DPIC -DLIBICONV_PLUG $(SOURCES) -shared -o preloadable_libiconv_linux.so; \
|
||||
+ $(LIBTOOL_LINK) $(CC) $(LDFLAGS) $(INCLUDES) $(CFLAGS) $(CPPFLAGS) $(DEFS) -KPIC -DPIC -DLIBICONV_PLUG $(SOURCES) -Xcompiler -shared -o preloadable_libiconv_linux.so; \
|
||||
fi
|
||||
|
||||
preloadable_libiconv_solaris.so : $(SOURCES)
|
Loading…
Reference in New Issue
Block a user