mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-16 18:54:04 +02:00
commit support for sdl based music player "gmu"
This commit is contained in:
parent
9279c0e696
commit
7d9e2d5c38
80
gmu/Makefile
Normal file
80
gmu/Makefile
Normal file
@ -0,0 +1,80 @@
|
||||
#
|
||||
# Copyright (c) 2010 wejp
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gmu
|
||||
PKG_VERSION:=0.7.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://wejp.k.vu/wp-content/uploads/2010/03/
|
||||
PKG_MD5SUM:=88a4f12e6388dfd58fc0c8162c3a99c7
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/gmu
|
||||
SECTION:=multimedia
|
||||
CATEGORY:=Multimedia
|
||||
TITLE:=Gmu Music Player
|
||||
URL:=http://wejp.k.vu/projects/gmu/
|
||||
MENU:=1
|
||||
DEPENDS:=+libsdl +libsdl-image +libsdl-gfx +libmpcdec +libmikmod +libvorbisidec
|
||||
endef
|
||||
|
||||
define Package/gmu/description
|
||||
A popular music player for various handheld devices.
|
||||
It supports various file formats and comes with a
|
||||
file browser and a playlist editor/viewer.
|
||||
endef
|
||||
|
||||
MAKE_VARS += TARGET=nanonote
|
||||
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/SDL
|
||||
|
||||
define Package/gmu/install
|
||||
$(INSTALL_DIR) \
|
||||
$(1)/etc/gmu \
|
||||
$(1)/usr/bin \
|
||||
$(1)/usr/share/gmu \
|
||||
$(1)/usr/share/gmu/decoders \
|
||||
$(1)/usr/share/gmu/frontends \
|
||||
$(1)/usr/share/gmu/themes/default-modern
|
||||
|
||||
$(INSTALL_BIN) \
|
||||
$(PKG_BUILD_DIR)/gmu \
|
||||
$(1)/usr/bin/gmu.bin
|
||||
|
||||
$(INSTALL_BIN) \
|
||||
./files/gmu \
|
||||
$(1)/usr/bin/
|
||||
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_BUILD_DIR)/*.conf \
|
||||
$(1)/etc/gmu/
|
||||
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_BUILD_DIR)/*.keymap \
|
||||
$(1)/etc/gmu/
|
||||
|
||||
$(INSTALL_BIN) \
|
||||
$(PKG_BUILD_DIR)/decoders/* \
|
||||
$(1)/usr/share/gmu/decoders/
|
||||
|
||||
$(INSTALL_BIN) \
|
||||
$(PKG_BUILD_DIR)/frontends/* \
|
||||
$(1)/usr/share/gmu/frontends/
|
||||
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_BUILD_DIR)/themes/default-modern/* \
|
||||
$(1)/usr/share/gmu/themes/default-modern/
|
||||
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_BUILD_DIR)/README.txt \
|
||||
$(1)/usr/share/gmu/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,gmu))
|
2
gmu/files/gmu
Executable file
2
gmu/files/gmu
Executable file
@ -0,0 +1,2 @@
|
||||
#!/bin/sh
|
||||
( cd /usr/share/gmu && /usr/bin/gmu.bin -e -d /etc/gmu -c gmu.nanonote.conf )
|
18
gmu/patches/000-do-not-override.patch
Normal file
18
gmu/patches/000-do-not-override.patch
Normal file
@ -0,0 +1,18 @@
|
||||
--- gmu-0.7.0.orig/nanonote.mk 2010-03-25 19:32:41.000000000 +0100
|
||||
+++ gmu-0.7.0/nanonote.mk 2010-04-01 21:36:10.000000000 +0200
|
||||
@@ -19,13 +19,6 @@
|
||||
FRONTENDS_TO_BUILD=frontends/sdl.so frontends/log.so
|
||||
DEVICE=NANONOTE
|
||||
CONFIG=-D_$(DEVICE)
|
||||
-SDL_LIB=-lSDL -lpthread -ldirectfb -ldirect -lfusion -lz -lSDL_image -lSDL_gfx
|
||||
-SDL_CFLAGS=-D_GNU_SOURCE=1 -D_REENTRANT
|
||||
-CXX=mipsel-openwrt-linux-g++
|
||||
-CC=mipsel-openwrt-linux-gcc
|
||||
-STRIP=mipsel-openwrt-linux-strip
|
||||
-TOOLCHAIN_ROOT_PATH=$(shell which $(CC)|sed 's/toolchain-mipsel_gcc-4.3.3+cs_uClibc-0.9.30.1\/usr\/bin\/$(CC)//')
|
||||
-COPTS?=-O2 -s
|
||||
-CFLAGS=-msoft-float -I$(TOOLCHAIN_ROOT_PATH)/target-mipsel_uClibc-0.9.30.1/usr/include/SDL -I$(TOOLCHAIN_ROOT_PATH)/target-mipsel_uClibc-0.9.30.1/usr/include -ffast-math -fomit-frame-pointer $(SDL_CFLAGS) $(CONFIG)
|
||||
+CFLAGS+=$(CONFIG)
|
||||
-LFLAGS=-s $(SDL_LIB) -L$(TOOLCHAIN_ROOT_PATH)/target-mipsel_uClibc-0.9.30.1/usr/lib -L$(TOOLCHAIN_ROOT_PATH)/target-mipsel_uClibc-0.9.30.1/root-xburst/usr/lib -lpthread -lm -ldl -lgcc -Wl,-export-dynamic
|
||||
+LFLAGS=$(LDFLAGS) -lSDL -lpthread -ldirectfb -ldirect -lfusion -lz -lSDL_image -lSDL_gfx -lm -ldl -lgcc -Wl,-export-dynamic
|
||||
DISTFILES=$(BINARY) frontends decoders themes gmu.png README.txt libs.nanonote gmu.nn COPYING gmuinput.nanonote.conf
|
Loading…
Reference in New Issue
Block a user