mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 12:41:53 +02:00
Wordgrinder: Builds, marked broken until upstream accepts ncurses patch
This commit is contained in:
parent
53401034f6
commit
84793327bc
41
wordgrinder/Makefile
Normal file
41
wordgrinder/Makefile
Normal file
@ -0,0 +1,41 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=wordgrinder
|
||||
PKG_VERSION:=0.3.3
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
PKG_MD5SUM:=1ae3bcf2fc4ee027bdd9518a73733505
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/wordgrinder
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=A word processor for processing words
|
||||
URL:=http://wordgrinder.sourceforge.net/
|
||||
SUBMENU:=Editors
|
||||
DEPENDS:=+libncursesw lua luafilesystem BROKEN
|
||||
endef
|
||||
|
||||
define Package/wordgrinder/description
|
||||
WordGrinder is a word processor for processing words. It is not WYSIWYG. It is not point and click. It is not a desktop publisher. It is not a text editor. It is not do fonts and it barely does styles. What it does do is words. It's designed for writing text. It gets out of your way and lets you type.
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
(cd $(PKG_BUILD_DIR);\
|
||||
STAGING_DIR="$(STAGING_DIR)"\
|
||||
TARGET_CC="$(TARGET_CC)"\
|
||||
./pm);$
|
||||
endef
|
||||
|
||||
define Package/wordgrinder/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/bin/wordgrinder $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,wordgrinder))
|
80
wordgrinder/patches/001-pmfile.patch
Normal file
80
wordgrinder/patches/001-pmfile.patch
Normal file
@ -0,0 +1,80 @@
|
||||
--- wordgrinder-0.3.3/pmfile 2009-12-13 14:44:53.000000000 +0100
|
||||
+++ wordgrinder-0.3.3/pmfile-openwrt 2010-08-15 16:06:45.000000000 +0200
|
||||
@@ -12,6 +12,9 @@
|
||||
DATE = "13 December 2009"
|
||||
VERSION = "0.3.3"
|
||||
FILEFORMAT = 3
|
||||
+STAGING_DIR = os.getenv("STAGING_DIR")
|
||||
+CCOMPILER = os.getenv("TARGET_CC")
|
||||
+LUAC = "cat %in% > %out%"
|
||||
|
||||
-----------------------------------------------------------------------------
|
||||
-- User configurable settings start here!
|
||||
@@ -19,8 +22,8 @@
|
||||
-- Where do you want WordGrinder installed? By default, it goes into your
|
||||
-- home directory.
|
||||
|
||||
-PREFIX = HOME
|
||||
--- PREFIX = "/usr/local"
|
||||
+-- PREFIX = HOME
|
||||
+PREFIX = "/usr/"
|
||||
|
||||
-- What build flags do you want to use? (Not including -g or -Os, which are
|
||||
-- added later automatically.)
|
||||
@@ -32,10 +35,12 @@
|
||||
|
||||
-- Any other build options go in these three sections. Note the lack of -l, -D
|
||||
-- or -I. We need the XOPEN stuff to make the wide-character curses library
|
||||
-- work.
|
||||
|
||||
CLIBRARIES = {
|
||||
'm',
|
||||
+ 'crypt',
|
||||
+ 'dl',
|
||||
}
|
||||
|
||||
CDEFINES = {
|
||||
@@ -43,10 +48,10 @@
|
||||
'FILEFORMAT=%FILEFORMAT%',
|
||||
'PREFIX="%PREFIX%"'
|
||||
}
|
||||
|
||||
CINCLUDES = {
|
||||
- "/usr/include/ncursesw",
|
||||
- "/usr/include/lua5.1",
|
||||
+ "%STAGING_DIR%/usr/include/ncursesw",
|
||||
+ "%STAGING_DIR%/usr/include/",
|
||||
"src/c"
|
||||
}
|
||||
|
||||
@@ -211,11 +216,11 @@
|
||||
'_XOPEN_SOURCE_EXTENDED',
|
||||
'_XOPEN_SOURCE',
|
||||
},
|
||||
|
||||
CLIBRARIES = {
|
||||
PARENT,
|
||||
- 'ncursesw',
|
||||
- 'lua5.1'
|
||||
+ '%STAGING_DIR%/usr/lib/libncursesw.a',
|
||||
+ '%STAGING_DIR%/usr/lib/liblua.a'
|
||||
}
|
||||
}
|
||||
|
||||
@@ -238,15 +243,15 @@
|
||||
"EMULATED_WCWIDTH",
|
||||
"BUILTIN_LFS",
|
||||
},
|
||||
|
||||
CINCLUDES = {
|
||||
PARENT,
|
||||
"src/c/luacore"
|
||||
},
|
||||
|
||||
CLIBRARIES = {
|
||||
PARENT,
|
||||
- 'ncursesw',
|
||||
+ '%STAGING_DIR%/usr/lib/ncursesw.a',
|
||||
},
|
||||
|
||||
install = pm.install("bin/wordgrinder-static")
|
Loading…
Reference in New Issue
Block a user