1
0
mirror of git://projects.qi-hardware.com/openwrt-packages.git synced 2024-07-01 03:16:43 +03:00

[stardict] configure need the nls.m4

This commit is contained in:
Xiangfu Liu 2010-02-12 23:05:56 +08:00
parent b4a049968e
commit 875f6cdd73

View File

@ -6,13 +6,15 @@ From: Xiangfu Liu <xiangfu@sharism.cc>
---
configure.in | 26 ++-
m4/nls.m4 | 31 ++++
src/class_factory.cpp | 2
src/conf.cpp | 6 -
src/mainwin.cpp | 9 +
src/stardict.cpp | 35 +++-
src/x11_iskeyspressed.cpp | 351 ---------------------------------------------
src/x11_iskeyspressed.hpp | 65 --------
7 files changed, 44 insertions(+), 450 deletions(-)
8 files changed, 75 insertions(+), 450 deletions(-)
create mode 100644 m4/nls.m4
diff --git a/configure.in b/configure.in
@ -54,6 +56,43 @@ index 83d3d95..6be40db 100644
AC_SUBST(STARDICT_LIBS)
AC_SUBST(STARDICT_CFLAGS)
diff --git a/m4/nls.m4 b/m4/nls.m4
new file mode 100644
index 0000000..7967cc2
--- /dev/null
+++ b/m4/nls.m4
@@ -0,0 +1,31 @@
+# nls.m4 serial 3 (gettext-0.15)
+dnl Copyright (C) 1995-2003, 2005-2006 Free Software Foundation, Inc.
+dnl This file is free software; the Free Software Foundation
+dnl gives unlimited permission to copy and/or distribute it,
+dnl with or without modifications, as long as this notice is preserved.
+dnl
+dnl This file can can be used in projects which are not available under
+dnl the GNU General Public License or the GNU Library General Public
+dnl License but which still want to provide support for the GNU gettext
+dnl functionality.
+dnl Please note that the actual code of the GNU gettext library is covered
+dnl by the GNU Library General Public License, and the rest of the GNU
+dnl gettext package package is covered by the GNU General Public License.
+dnl They are *not* in the public domain.
+
+dnl Authors:
+dnl Ulrich Drepper <drepper@cygnus.com>, 1995-2000.
+dnl Bruno Haible <haible@clisp.cons.org>, 2000-2003.
+
+AC_PREREQ(2.50)
+
+AC_DEFUN([AM_NLS],
+[
+ AC_MSG_CHECKING([whether NLS is requested])
+ dnl Default is enabled NLS
+ AC_ARG_ENABLE(nls,
+ [ --disable-nls do not use Native Language Support],
+ USE_NLS=$enableval, USE_NLS=yes)
+ AC_MSG_RESULT($USE_NLS)
+ AC_SUBST(USE_NLS)
+])
diff --git a/src/class_factory.cpp b/src/class_factory.cpp
index 8bff538..d1dddc2 100644
--- a/src/class_factory.cpp