mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-04 23:03:10 +02:00
gnuplot-ggi: build without mouse support so we can leave plots via keypress
This commit is contained in:
parent
59ad4eac72
commit
8a1f0d44cd
@ -12,7 +12,7 @@ include $(TOPDIR)/rules.mk
|
||||
PKG_NAME:=gnuplot-ggi
|
||||
PKG_ORIG_NAME=gnuplot
|
||||
PKG_VERSION:=4.4.0
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_ORIG_NAME)-$(PKG_VERSION)
|
||||
HOST_BUILD_DIR = $(BUILD_DIR_HOST)/$(PKG_ORIG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(PKG_ORIG_NAME)-$(PKG_VERSION).tar.gz
|
||||
@ -94,7 +94,8 @@ CONFIGURE_ARGS += \
|
||||
--without-row-help \
|
||||
--without-lisp-files \
|
||||
--with-ggi \
|
||||
--with-gihdir=/usr/share/gnuplot
|
||||
--with-gihdir=/usr/share/gnuplot \
|
||||
--disable-mouse
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \
|
||||
|
30
gnuplot-ggi/patches/040-nomouse-fixes.patch
Normal file
30
gnuplot-ggi/patches/040-nomouse-fixes.patch
Normal file
@ -0,0 +1,30 @@
|
||||
Index: gnuplot-4.4.0/term/ggi.trm
|
||||
===================================================================
|
||||
--- gnuplot-4.4.0.orig/term/ggi.trm 2011-01-05 13:35:52.000000000 +0100
|
||||
+++ gnuplot-4.4.0/term/ggi.trm 2011-01-05 13:39:52.000000000 +0100
|
||||
@@ -499,6 +499,12 @@
|
||||
ggiSetGCForeground(GGIvisual,GGIcolors[linetype]);
|
||||
}
|
||||
|
||||
+TERM_PUBLIC int
|
||||
+GGI_y(int32_t y)
|
||||
+{
|
||||
+ return GGIymax - y;
|
||||
+}
|
||||
+
|
||||
TERM_PUBLIC void GGI_move(unsigned int x, unsigned int y)
|
||||
{
|
||||
GGIx=x;
|
||||
@@ -831,12 +837,6 @@
|
||||
}
|
||||
|
||||
TERM_PUBLIC int
|
||||
-GGI_y(int32_t y)
|
||||
-{
|
||||
- return GGIymax - y;
|
||||
-}
|
||||
-
|
||||
-TERM_PUBLIC int
|
||||
GGI_eventually_update_modifiers(const ggi_event* event, const int add)
|
||||
{
|
||||
int mod = 0;
|
Loading…
Reference in New Issue
Block a user