mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-04 23:21:53 +02:00
nupdf: initial port
This commit is contained in:
parent
05e38ea36c
commit
8bcbadf846
58
nupdf/Makefile
Normal file
58
nupdf/Makefile
Normal file
@ -0,0 +1,58 @@
|
|||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
#
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=nupdf
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
PKG_REV:=15
|
||||||
|
PKG_VERSION:=r$(PKG_REV)
|
||||||
|
PKG_SOURCE_URL:=http://nupdf.googlecode.com/svn/trunk/
|
||||||
|
PKG_SOURCE_PROTO:=svn
|
||||||
|
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||||
|
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/nupdf
|
||||||
|
SECTION:=utils
|
||||||
|
CATEGORY:=Utilities
|
||||||
|
TITLE:=relatively fast pdf reader in SDL
|
||||||
|
URL:=http://code.google.com/p/nupdf/
|
||||||
|
DEPENDS:=+libsdl
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/nupdf/description
|
||||||
|
nupdf is a relatively fast pdf reader; it uses the mupdf library to render pages/handle files, and SDL for the UI
|
||||||
|
endef
|
||||||
|
|
||||||
|
TARGET_CFLAGS += \
|
||||||
|
-I$(STAGING_DIR)/usr/include
|
||||||
|
|
||||||
|
TARGET_LDFLAGS += \
|
||||||
|
-Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
|
||||||
|
-ldl -lSDL -lmupdf -lfitz -lfitzdraw \
|
||||||
|
-lcmaps -lfonts -lfreetype -lpthread \
|
||||||
|
-lm -ljpeg -lz
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
$(TARGET_CC) $(PKG_BUILD_DIR)/*.c -o $(PKG_BUILD_DIR)/nupdf $(TARGET_CFLAGS) -L$(PKG_BUILD_DIR) $(TARGET_LDFLAGS)
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/nupdf/install
|
||||||
|
$(INSTALL_DIR) \
|
||||||
|
$(1)/usr/bin $(1)/usr/share/nupdf
|
||||||
|
|
||||||
|
$(INSTALL_BIN) \
|
||||||
|
$(PKG_BUILD_DIR)/nupdf $(1)/usr/bin/nupdf.bin
|
||||||
|
|
||||||
|
$(INSTALL_BIN) \
|
||||||
|
$(FILES_DIR)/nupdf.sh $(1)/usr/bin/nupdf
|
||||||
|
|
||||||
|
$(CP) \
|
||||||
|
$(PKG_BUILD_DIR)/{data,config} $(1)/usr/share/nupdf
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,nupdf))
|
3
nupdf/files/nupdf.sh
Normal file
3
nupdf/files/nupdf.sh
Normal file
@ -0,0 +1,3 @@
|
|||||||
|
#!/bin/sh
|
||||||
|
cd /usr/share/nupdf
|
||||||
|
/usr/bin/nupdf.bin $*
|
11
nupdf/patches/001-r15-bracket.patch
Normal file
11
nupdf/patches/001-r15-bracket.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- nupdf-15.orig/main.c 2010-10-22 16:44:51.033676255 +0400
|
||||||
|
+++ nupdf-r15/main.c 2010-10-22 17:13:33.777676124 +0400
|
||||||
|
@@ -457,7 +457,7 @@
|
||||||
|
strcpy(arrows[i], "");
|
||||||
|
}
|
||||||
|
|
||||||
|
-
|
||||||
|
+ }
|
||||||
|
sprintf(settingstext, "\t\t\tSettings\t%s\n\n"
|
||||||
|
"Jump to page %i\t%s\n\n"
|
||||||
|
"Return\t%s"
|
Loading…
Reference in New Issue
Block a user