mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 04:31:31 +02:00
gmu: build support for mp3 (if BUILD_PATENTED is set)
This commit is contained in:
parent
bdfc6c1134
commit
8f5504bff8
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gmu
|
||||
PKG_VERSION:=0.7.2
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://wejp.k.vu/files/
|
||||
@ -24,7 +24,7 @@ define Package/gmu
|
||||
URL:=http://wejp.k.vu/projects/gmu/
|
||||
MENU:=1
|
||||
DEPENDS:=+libsdl +libsdl-image +libsdl-gfx +libmpcdec +libmikmod \
|
||||
+libvorbisidec +libspeex +libflac +libogg
|
||||
+libvorbisidec +libspeex +libflac +libogg +BUILD_PATENTED:libmpg123
|
||||
endef
|
||||
|
||||
define Package/gmu/description
|
||||
@ -33,7 +33,7 @@ define Package/gmu/description
|
||||
file browser and a playlist editor/viewer.
|
||||
endef
|
||||
|
||||
MAKE_VARS += TARGET=nanonote
|
||||
MAKE_VARS += TARGET=nanonote $(if $(CONFIG_BUILD_PATENTED),MORE_DECODERS="decoders/mpg123.so")
|
||||
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/SDL
|
||||
TARGET_LDFLAGS+= \
|
||||
-Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
|
||||
|
13
gmu/patches/001-mpg123.patch
Normal file
13
gmu/patches/001-mpg123.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -ur gmu-0.7.2.orig/nanonote.mk gmu-0.7.2/nanonote.mk
|
||||
--- gmu-0.7.2.orig/nanonote.mk 2011-02-25 09:44:13.789059308 +0300
|
||||
+++ gmu-0.7.2/nanonote.mk 2011-02-25 16:12:39.573386748 +0300
|
||||
@@ -16,6 +16,9 @@
|
||||
|
||||
#DECODERS_TO_BUILD=decoders/vorbis.so decoders/musepack.so decoders/flac.so decoders/wavpack.so decoders/mpg123.so decoders/mikmod.so
|
||||
DECODERS_TO_BUILD=decoders/vorbis.so decoders/musepack.so decoders/wavpack.so decoders/mikmod.so decoders/flac.so decoders/speex.so
|
||||
+ifdef MORE_DECODERS
|
||||
+ DECODERS_TO_BUILD+=$(MORE_DECODERS)
|
||||
+endif
|
||||
FRONTENDS_TO_BUILD=frontends/sdl.so frontends/log.so
|
||||
SDL_LIB=-lSDL -lpthread -ldirectfb -ldirect -lfusion -lz -lSDL_image -lSDL_gfx
|
||||
SDL_CFLAGS=-D_GNU_SOURCE=1 -D_REENTRANT
|
Loading…
Reference in New Issue
Block a user