mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-24 04:12:51 +02:00
[nanoterm] [new package] a terminal for NanoNote
Signed-off-by: Xiangfu Liu <xiangfu@sharism.cc>
This commit is contained in:
parent
afd68224c8
commit
91241193cb
41
nanoterm/Makefile
Normal file
41
nanoterm/Makefile
Normal file
@ -0,0 +1,41 @@
|
||||
#
|
||||
# Copyright (C) 2009 Qi Hardware Inc.
|
||||
# Author: Xiangfu Liu <xiangfu@sharism.cc>
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=nanoterm
|
||||
PKG_VERSION:=0.2
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://downloads.sourceforge.net/project/nterm/nanoterm/0.2/
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/nanoterm
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
SUBMENU:=Terminal
|
||||
TITLE:=terminal emulator
|
||||
URL:=http://nterm.sourceforge.net/
|
||||
endef
|
||||
|
||||
define Package/nanoterm/description
|
||||
Nanoterm is a terminal emulator with i minimal font for the Linux framebuffer
|
||||
endef
|
||||
|
||||
define Package/nanoterm/install
|
||||
$(INSTALL_DIR) \
|
||||
$(1)/usr/bin \
|
||||
|
||||
$(INSTALL_BIN) \
|
||||
$(PKG_INSTALL_DIR)/usr/bin/nanoterm \
|
||||
$(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,nanoterm))
|
18
nanoterm/patches/001-change-DISTDIR-to-DESTDIR.patch
Normal file
18
nanoterm/patches/001-change-DISTDIR-to-DESTDIR.patch
Normal file
@ -0,0 +1,18 @@
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 08ac50e..8fb6d34 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -12,11 +12,11 @@ distclean: clean
|
||||
rm -f aclocal.m4 autoconf.h autoconf.mk config.log config.status
|
||||
|
||||
install: all
|
||||
- install -D -m 0755 -s --strip-program=$(STRIP) src/nanoterm $(DISTDIR)$(bindir)/nanoterm
|
||||
+ install -D -m 0755 -s --strip-program=$(STRIP) src/nanoterm $(DESTDIR)$(bindir)/nanoterm
|
||||
|
||||
ipkg:
|
||||
rm -Rf ipkg-tmp
|
||||
mkdir -p ipkg-tmp/CONTROL
|
||||
cp dist/ipkg.control ipkg-tmp/CONTROL/control
|
||||
- $(MAKE) DISTDIR=ipkg-tmp install
|
||||
+ $(MAKE) DESTDIR=ipkg-tmp install
|
||||
ipkg-build -o root -g root ipkg-tmp
|
Loading…
Reference in New Issue
Block a user