mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-24 05:18:27 +02:00
new package [sc], thanks to jirka
This commit is contained in:
parent
df66aa35e7
commit
933f0cd5df
48
sc/Makefile
Normal file
48
sc/Makefile
Normal file
@ -0,0 +1,48 @@
|
||||
# Author: Jirka
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=sc
|
||||
PKG_VERSION:=7.15
|
||||
PKG_RELEASE:=1
|
||||
#http://www.ibiblio.org/pub/linux/apps/financial/spreadsheet/sc-7.15.tar.gz
|
||||
|
||||
PKG_SOURCE:=sc-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.ibiblio.org/pub/linux/apps/financial/spreadsheet
|
||||
PKG_MD5SUM:=89c0d76f2c0aabe1cf1c80eae7a13e8f
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/sc-$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/sc
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
DEPENDS:=+libncurses
|
||||
TITLE:=SC Spreadsheet Calculator
|
||||
URL:=http://www.ibiblio.org/pub/linux/apps/financial/spreadsheet
|
||||
endef
|
||||
|
||||
define Package/sc/description
|
||||
SC is a classic unix speadsheet calculator.
|
||||
Works in a character terminal.
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Compile/Default, \
|
||||
CFLAGS="-I$(STAGING_DIR)/usr/include -DSYSV3 -O2 -pipe" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -lm -lncurses" \
|
||||
)
|
||||
endef
|
||||
|
||||
|
||||
|
||||
define Package/sc/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/sc $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/psc $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/scqref $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,sc))
|
11
sc/patches/makefile.patch
Normal file
11
sc/patches/makefile.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- sc-7.15/Makefile 2001-11-06 01:37:05.000000000 +0100
|
||||
+++ sc-7.15mod/Makefile 2010-05-26 13:42:54.000000000 +0200
|
||||
@@ -299,7 +299,7 @@
|
||||
|
||||
#########################################
|
||||
# Use this for Linux
|
||||
-CC=gcc
|
||||
+#CC=gcc
|
||||
# Only use -Wall for testing, since it produces warnings that are of no
|
||||
# real effect on the reliability of the program, but may concern some
|
||||
# people who don't understand them.
|
11
sc/patches/xmalloc.patch
Normal file
11
sc/patches/xmalloc.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- sc-7.15/xmalloc.c 2001-11-06 01:41:58.000000000 +0100
|
||||
+++ sc-7.15mod/xmalloc.c 2010-05-24 14:38:54.000000000 +0200
|
||||
@@ -6,7 +6,7 @@
|
||||
#include <curses.h>
|
||||
#include "sc.h"
|
||||
|
||||
-extern char *malloc();
|
||||
+/*extern char *malloc();*/
|
||||
extern char *realloc();
|
||||
extern void free();
|
||||
void fatal();
|
Loading…
Reference in New Issue
Block a user