mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 12:29:21 +02:00
Merge branch 'master' of projects.qi-hardware.com:openwrt-packages
This commit is contained in:
commit
9a15361e6f
@ -44,3 +44,9 @@ define Package/bard/install
|
|||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,bard))
|
$(eval $(call BuildPackage,bard))
|
||||||
|
|
||||||
|
|
||||||
|
# The following comments configure the Emacs editor. Just ignore them.
|
||||||
|
# Local Variables:
|
||||||
|
# compile-command: "cd ~/src/nanonote/bard-0.7-current && ~/bin/quilt-export target && make -C ~/h/src/qi/openwrt-xburst package/bard/compile -j2 V=99"
|
||||||
|
# End:
|
||||||
|
62
bard/patches/0010-configure.patch
Normal file
62
bard/patches/0010-configure.patch
Normal file
@ -0,0 +1,62 @@
|
|||||||
|
Index: bard-0.7-current/configure.in
|
||||||
|
===================================================================
|
||||||
|
--- bard-0.7-current.orig/configure.in 2012-03-22 03:13:47.186201055 +0100
|
||||||
|
+++ bard-0.7-current/configure.in 2012-03-22 03:25:50.896839172 +0100
|
||||||
|
@@ -456,28 +456,28 @@
|
||||||
|
SDLLIBS="-lSDL"
|
||||||
|
|
||||||
|
dnl Fix this ....
|
||||||
|
-if ! test -f /usr/include/SDL/SDL_ttf.h; then
|
||||||
|
- AC_MSG_ERROR("Cannot locate /usr/include/SDL/SDL_ttf.h.")
|
||||||
|
-fi
|
||||||
|
+AC_CHECK_HEADER(SDL/SDL_ttf.h,,[AC_MSG_ERROR([Cannot locate SDL/SDL_ttf.h])])
|
||||||
|
SDLLIBS="-lSDL_ttf $SDLLIBS"
|
||||||
|
|
||||||
|
dnl AC_CHECK_HEADER(SDL/SDL_ttf.h,,[AC_MSG_ERROR([Cannot locate SDL/SDL_ttf.h])])
|
||||||
|
-if ! test "x$EPUBDEFS" = x; then
|
||||||
|
- if test -f /usr/include/SDL/SDL_image.h -a -f /usr/include/SDL/SDL_rotozoom.h
|
||||||
|
- then
|
||||||
|
- echo "EPUB (with SDL images) support found"
|
||||||
|
+AS_IF([test "x$EPUBDEFS" = x],[
|
||||||
|
+ sdl_img=no
|
||||||
|
+ sdl_rotozoom=no
|
||||||
|
+ AC_CHECK_HEADER(SDL/SDL_image.h,sdl_img=yes)
|
||||||
|
+ AC_CHECK_HEADER(SDL/SDL_rotozoom.h,sdl_rotozoom=yes)
|
||||||
|
+ AS_IF([test x$sdl_img = xyes && test x$sdl_rotozoom = xyes], [
|
||||||
|
+ AC_MSG_NOTICE([EPUB (with SDL images) support found])
|
||||||
|
SDLLIBS="-lSDL_gfx -lSDL_image $SDLLIBS"
|
||||||
|
EPUBDEFS="-DBARD_EPUB_IMAGES $EPUBDEFS"
|
||||||
|
- else
|
||||||
|
- echo "EPUB (without SDL images) support found"
|
||||||
|
- fi
|
||||||
|
-else
|
||||||
|
- echo "No EPUB support found (missing libzip)"
|
||||||
|
-fi
|
||||||
|
+ ],[
|
||||||
|
+ AC_MSG_NOTICE([EPUB (without SDL images) support found])
|
||||||
|
+ ])],[
|
||||||
|
+ AC_MSG_NOTICE([No EPUB support found (missing libzip)])
|
||||||
|
+])
|
||||||
|
|
||||||
|
+CFLAGS="$CFLAGS $EPUBDEFS"
|
||||||
|
+LDFLAGS="$LDFLAGS $SDLLIBS"
|
||||||
|
AC_SUBST(SDLLIBS)
|
||||||
|
-AC_SUBST(EPUBLIBS)
|
||||||
|
-AC_SUBST(EPUBDEFS)
|
||||||
|
|
||||||
|
dnl
|
||||||
|
dnl Find a font.
|
||||||
|
Index: bard-0.7-current/config/config.in
|
||||||
|
===================================================================
|
||||||
|
--- bard-0.7-current.orig/config/config.in 2012-03-22 03:23:02.812217274 +0100
|
||||||
|
+++ bard-0.7-current/config/config.in 2012-03-22 03:23:15.784265078 +0100
|
||||||
|
@@ -29,8 +29,7 @@
|
||||||
|
|
||||||
|
EPUBLIBS = @EPUBLIBS@
|
||||||
|
EPUBDEFS = @EPUBDEFS@
|
||||||
|
-SDLINCLUDES = -I/usr/include/SDL ${EPUBDEFS}
|
||||||
|
-SDLLIBS = @SDLLIBS@ ${EPUBLIBS}
|
||||||
|
+SDLLIBS = @SDLLIBS@
|
||||||
|
|
||||||
|
DEFAULTFONT = @DEFAULTFONT@
|
||||||
|
|
@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
PKG_NAME:=kbd
|
PKG_NAME:=kbd
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_VERSION:=1.15.3
|
PKG_VERSION:=1.15.3
|
||||||
PKG_SOURCE_URL:=http://mirror.anl.gov/pub/linux/utils/kbd/
|
PKG_SOURCE_URL:=ftp://ftp.altlinux.org/pub/people/legion/kbd/
|
||||||
PKG_SOURCE:=kbd-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=kbd-$(PKG_VERSION).tar.gz
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
@ -13,7 +13,7 @@ export SDL_NOMOUSE=1
|
|||||||
export SDL_VIDEODRIVER=fbcon
|
export SDL_VIDEODRIVER=fbcon
|
||||||
## QT4
|
## QT4
|
||||||
### set keyboard device
|
### set keyboard device
|
||||||
export QWS_KEYBOARD=LinuxInput:/dev/input/event1:keymap=/usr/share/qmaps/ben.qmap
|
export QWS_KEYBOARD=LinuxInput:/dev/input/event0:keymap=/usr/share/qmaps/ben.qmap
|
||||||
### do use fb-device directly
|
### do use fb-device directly
|
||||||
export QWS_DISPLAY=linuxfb
|
export QWS_DISPLAY=linuxfb
|
||||||
|
|
||||||
|
@ -6,12 +6,20 @@
|
|||||||
# OpenWRT package for the GNU Octave
|
# OpenWRT package for the GNU Octave
|
||||||
#
|
#
|
||||||
# todo: how do we enable octave's internal help system?
|
# todo: how do we enable octave's internal help system?
|
||||||
|
#
|
||||||
|
# todo: we may have a (slight) linking problem: it prefers liboctinterp.so &
|
||||||
|
# friends from staging_dir/target-mipsel_uClibc-0.9.32/usr/lib/ over the one
|
||||||
|
# freshly compiled. As a workaround, try 'rm
|
||||||
|
# openwrt-xburst/staging_dir/target-mipsel_uClibc-0.9.32/usr/lib/*oct*' if
|
||||||
|
# compilation fails for you. Mostly that doesn't matter on clean rebuilds
|
||||||
|
# anyways.
|
||||||
|
#
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=octave
|
PKG_NAME:=octave
|
||||||
PKG_VERSION:=3.2.4
|
PKG_VERSION:=3.2.4
|
||||||
PKG_RELEASE:=3
|
PKG_RELEASE:=4
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=ftp://ftp.octave.org/pub/octave/
|
PKG_SOURCE_URL:=ftp://ftp.octave.org/pub/octave/
|
||||||
PKG_MD5SUM:=90c39fa9e241ad2e978bcee4682a2ba9
|
PKG_MD5SUM:=90c39fa9e241ad2e978bcee4682a2ba9
|
||||||
@ -75,6 +83,10 @@ endef
|
|||||||
# todo : need -enable-rpath?
|
# todo : need -enable-rpath?
|
||||||
|
|
||||||
OCTAVE_LIB_DIR := /usr/lib
|
OCTAVE_LIB_DIR := /usr/lib
|
||||||
|
|
||||||
|
# ugly workaround for octave 3.2.4 to compile with latest openwrt toolchain
|
||||||
|
TARGET_CXXFLAGS += -include stddef.h -fpermissive
|
||||||
|
|
||||||
CONFIGURE_ARGS += --without-x --without-fftw --disable-docs
|
CONFIGURE_ARGS += --without-x --without-fftw --disable-docs
|
||||||
CONFIGURE_VARS += octlibdir=$(OCTAVE_LIB_DIR) \
|
CONFIGURE_VARS += octlibdir=$(OCTAVE_LIB_DIR) \
|
||||||
FFLAGS="$(TARGET_CFLAGS)"
|
FFLAGS="$(TARGET_CFLAGS)"
|
||||||
|
@ -363,15 +363,16 @@ define Package/plplot/install
|
|||||||
endef
|
endef
|
||||||
|
|
||||||
# ugly, but necessary: compiling demo-programs on install, using the just
|
# ugly, but necessary: compiling demo-programs on install, using the just
|
||||||
# installed libs.
|
# installed libs. Note that the PKG_CONFIG_ENV= override used below sets
|
||||||
|
# environment variables that would usually be handled by openwrt's
|
||||||
|
# include/package.mk (Build/Exports/Default), but aren't available for the
|
||||||
|
# install targets.
|
||||||
define Package/plplot-demo/install
|
define Package/plplot-demo/install
|
||||||
$(SED) 's;/usr/lib/pkgconfig;$(STAGING_DIR)/usr/lib/pkgconfig;g' \
|
|
||||||
$(PKG_INSTALL_DIR)/usr/share/plplot$(PKG_VERSION)/examples/c/Makefile
|
|
||||||
$(MAKE) -C $(PKG_INSTALL_DIR)/usr/share/plplot$(PKG_VERSION)/examples/c/ \
|
$(MAKE) -C $(PKG_INSTALL_DIR)/usr/share/plplot$(PKG_VERSION)/examples/c/ \
|
||||||
C_INCLUDE_PATH=$(STAGING_DIR)/usr/include/plplot \
|
C_INCLUDE_PATH=$(STAGING_DIR)/usr/include/plplot \
|
||||||
CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(EXTRA_CFLAGS) $(TARGET_LDFLAGS)"\
|
CC="$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(EXTRA_CFLAGS) $(TARGET_LDFLAGS)"\
|
||||||
RPATHCMD=
|
RPATHCMD= \
|
||||||
|
PKG_CONFIG_ENV="STAGING_PREFIX=$(STAGING_DIR)/usr PKG_CONFIG_PATH=$(PKG_CONFIG_PATH) PKG_CONFIG_LIBDIR=$(PKG_CONFIG_PATH)"
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/share/plplot$(PKG_VERSION)/examples/c/x??c \
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/share/plplot$(PKG_VERSION)/examples/c/x??c \
|
||||||
$(1)/usr/bin/
|
$(1)/usr/bin/
|
||||||
|
Loading…
Reference in New Issue
Block a user