mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 19:13:44 +02:00
Physfs library - initial port.
This commit is contained in:
parent
d25f457bd7
commit
a20cbc71b2
55
physfs/Makefile
Normal file
55
physfs/Makefile
Normal file
@ -0,0 +1,55 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libphysfs
|
||||
PKG_VERSION:=2.0.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
#PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE:=physfs-2.0.0.tar.gz
|
||||
PKG_SOURCE_URL:=http://icculus.org/physfs/downloads/
|
||||
# PKG_MD5SUM:=cfc53e0c193914c9c5ab522e58737373
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/physfs-$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libphysfs
|
||||
SECTION:=games
|
||||
CATEGORY:=Games
|
||||
TITLE:=PhysicsFS
|
||||
URL:=http://icculus.org/physfs/
|
||||
endef
|
||||
|
||||
define Package/libphysfs/description
|
||||
PhysicsFS is a library to provide abstract access to various archives.
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR);\
|
||||
IN_OPENWRT=1 \
|
||||
AR="$(TARGET_CROSS)ar" \
|
||||
AS="$(TARGET_CC) -c $(TARGET_CFLAGS)" \
|
||||
LD="$(TARGET_CROSS)ld" \
|
||||
NM="$(TARGET_CROSS)nm" \
|
||||
CC="$(TARGET_CC)" \
|
||||
GCC="$(TARGET_CC)" \
|
||||
CXX="$(TARGET_CROSS)g++" \
|
||||
RANLIB="$(TARGET_CROSS)ranlib" \
|
||||
STRIP="$(TARGET_CROSS)strip" \
|
||||
OBJCOPY="$(TARGET_CROSS)objcopy" \
|
||||
OBJDUMP="$(TARGET_CROSS)objdump" \
|
||||
TARGET_CPPFLAGS="$(TARGET_CPPFLAGS)" \
|
||||
TARGET_CFLAGS="$(TARGET_CFLAGS)" \
|
||||
TARGET_LDFLAGS="$(TARGET_LDFLAGS)" \
|
||||
cmake $(PKG_BUILD_DIR));$
|
||||
$(call Build/Compile/Default)$
|
||||
endef
|
||||
|
||||
|
||||
define Package/libphysfs/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/libphysfs.so.2.0.0 $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libphysfs))
|
20
physfs/patches/CMakeLists.patch
Normal file
20
physfs/patches/CMakeLists.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- physfs-2.0.0/CMakeLists.txt 2009-03-23 06:13:28.000000000 +0100
|
||||
+++ physfs-2.0.0m/CMakeLists.txt 2010-07-28 20:16:16.893088173 +0200
|
||||
@@ -44,7 +44,7 @@
|
||||
# Add some gcc-specific command lines.
|
||||
IF(CMAKE_COMPILER_IS_GNUCC)
|
||||
# Always build with debug symbols...you can strip it later.
|
||||
- ADD_DEFINITIONS(-g -pipe -Werror -fsigned-char)
|
||||
+ ADD_DEFINITIONS(-g -Werror -fsigned-char)
|
||||
|
||||
# Stupid BeOS generates warnings in the system headers.
|
||||
IF(NOT BEOS)
|
||||
@@ -315,7 +315,7 @@
|
||||
SET(PHYSFS_INSTALL_TARGETS ${PHYSFS_INSTALL_TARGETS} ";test_physfs")
|
||||
ENDIF(PHYSFS_BUILD_TEST)
|
||||
|
||||
-OPTION(PHYSFS_BUILD_WX_TEST "Build wxWidgets test program." TRUE)
|
||||
+OPTION(PHYSFS_BUILD_WX_TEST "Build wxWidgets test program." FALSE)
|
||||
MARK_AS_ADVANCED(PHYSFS_BUILD_WX_TEST)
|
||||
IF(PHYSFS_BUILD_WX_TEST)
|
||||
SET(wxWidgets_USE_LIBS base core adv)
|
Loading…
Reference in New Issue
Block a user