mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-04 23:21:53 +02:00
[fbgrab] new package. fbgrab is a framebuffer screenshot program
Signed-off-by: Xiangfu Liu <xiangfu@sharism.cc>
This commit is contained in:
parent
9980185f2c
commit
a70cc1ac5c
42
fbgrab/Makefile
Normal file
42
fbgrab/Makefile
Normal file
@ -0,0 +1,42 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2010 Qi Hardware Inc.
|
||||||
|
# Author: Xiangfu Liu <xiangfu@sharism.com>
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=fbgrab
|
||||||
|
PKG_VERSION:=1.0
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=http://hem.bredband.net/gmogmo/fbgrab/
|
||||||
|
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/fbgrab
|
||||||
|
TITLE:=framebuffer screenshot program
|
||||||
|
SECTION:=utils
|
||||||
|
CATEGORY:=Utilities
|
||||||
|
DEPENDS:=+zlib +libpng
|
||||||
|
URL:=http://hem.bredband.net/gmogmo/fbgrab/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/fbgrab/description
|
||||||
|
FBGrab is a framebuffer screenshot program
|
||||||
|
endef
|
||||||
|
|
||||||
|
TARGET_LDFLAGS+= -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
|
||||||
|
|
||||||
|
define Package/fbgrab/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/fbgrab $(1)/usr/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,fbgrab))
|
32
fbgrab/patches/001-modify-makefile-for-openwrt.patch
Normal file
32
fbgrab/patches/001-modify-makefile-for-openwrt.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
diff --git a/Makefile b/Makefile
|
||||||
|
index 14c63cb..f4cb0b0 100644
|
||||||
|
--- a/Makefile
|
||||||
|
+++ b/Makefile
|
||||||
|
@@ -2,15 +2,20 @@
|
||||||
|
### I think it's not worth to make such a small project
|
||||||
|
### modular. So this is a simple gnu Makefile...
|
||||||
|
###
|
||||||
|
+STRIP ?= strip
|
||||||
|
+INSTALL ?= install
|
||||||
|
+
|
||||||
|
+CFLAGS := $(CFLAGS) -g -Wall
|
||||||
|
|
||||||
|
fbgrab: fbgrab.c
|
||||||
|
- splint +posixlib fbgrab.c
|
||||||
|
- gcc -g -Wall fbgrab.c -lpng -lz -o fbgrab
|
||||||
|
+ $(CC) $(CFLAGS) $(LDFLAGS) fbgrab.c -lpng -lz -o fbgrab
|
||||||
|
+ $(STRIP) fbgrab
|
||||||
|
|
||||||
|
install:
|
||||||
|
- strip fbgrab
|
||||||
|
- install fbgrab /usr/bin/fbgrab
|
||||||
|
- install fbgrab.1.man /usr/man/man1/fbgrab.1
|
||||||
|
+ mkdir -p $(DESTDIR)/usr/bin/
|
||||||
|
+ mkdir -p $(DESTDIR)/usr/man/man1/
|
||||||
|
+ $(INSTALL) fbgrab $(DESTDIR)/usr/bin/fbgrab
|
||||||
|
+ $(INSTALL) fbgrab.1.man $(DESTDIR)/usr/man/man1/fbgrab.1
|
||||||
|
|
||||||
|
clean:
|
||||||
|
- rm -f fbgrab *~ \#*\#
|
||||||
|
\ No newline at end of file
|
||||||
|
+ rm -f fbgrab *~ \#*\#
|
Loading…
Reference in New Issue
Block a user