mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-04 22:57:30 +02:00
libggi port
This commit is contained in:
parent
0c9d588c6f
commit
a7636d86f6
86
libggi/Makefile
Normal file
86
libggi/Makefile
Normal file
@ -0,0 +1,86 @@
|
||||
#
|
||||
# Copyright (C) 2011 David Kuehling <dvdkhlng TA gmx TOD de>
|
||||
#
|
||||
# License GPLv2 or later. NO WARRANTY.
|
||||
#
|
||||
# OpenWRT package for the libGGI
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libggi
|
||||
PKG_VERSION:=2.2.2
|
||||
PKG_RELEASE:=1
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).src.tar.gz
|
||||
PKG_SOURCE_URL:=@SF/ggi
|
||||
PKG_MD5SUM:=4fa672b1403c9f06e8cb35e699a693f1
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/libggi-$(PKG_VERSION)
|
||||
PKG_INSTALL:=1
|
||||
PKG_FIXUP:=libtool
|
||||
|
||||
PKG_BUILD_DEPENDS:= libtool/host
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libggi
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=General Graphics Interface
|
||||
URL:=http://www.ggi-project.org/packages/libggi.html
|
||||
DEPENDS:=+libgii
|
||||
#+directfb
|
||||
endef
|
||||
|
||||
define Package/libggi/description
|
||||
LibGGI is the central library in the GGI project, hence the name.
|
||||
|
||||
It provides an opaque interface to the display\'s acceleration functions. It
|
||||
was originally intended to allow user programs to interface with KGI, the GGI
|
||||
Kernel Graphics Interface, but other display types can be easily used by
|
||||
loading the appropriate \"display target\" (e.g. X, memory).
|
||||
endef
|
||||
|
||||
TARGET_LDFLAGS += -Wl,-rpath-link -Wl,$(STAGING_DIR)/usr/lib
|
||||
CONFIGURE_VARS += ac_cv_func_mmap_fixed_mapped=yes
|
||||
|
||||
TARGET_CPPFLAGS += \
|
||||
-I$(STAGING_DIR)/usr/include/directfb \
|
||||
|
||||
# searches for fusion* headers that are not present. different version?
|
||||
CONFIGURE_ARGS += \
|
||||
--disable-x \
|
||||
--with-gii=$(STAGING_DIR)/usr/lib \
|
||||
--disable-directfb
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/Default,-j2)
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/include/* \
|
||||
$(1)/usr/include/
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/*.{a,la,so*} \
|
||||
$(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Package/libgii/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/ggi $(1)/usr/lib/
|
||||
$(INSTALL_DIR) $(1)/etc/ggi
|
||||
$(CP) $(PKG_INSTALL_DIR)/etc/ggi/* $(1)/etc/ggi/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libggi))
|
||||
|
||||
|
||||
# The following comments configure the Emacs editor. Just ignore them.
|
||||
# Local Variables:
|
||||
# compile-command: "make -C ~/h/src/qi/openwrt-xburst package/libggi/compile -j2 V=99"
|
||||
# End:
|
107
libggi/patches/010-directfb-headers.patch
Normal file
107
libggi/patches/010-directfb-headers.patch
Normal file
@ -0,0 +1,107 @@
|
||||
Index: libggi-2.2.2/configure
|
||||
===================================================================
|
||||
--- libggi-2.2.2.orig/configure 2011-01-04 19:40:37.000000000 +0100
|
||||
+++ libggi-2.2.2/configure 2011-01-04 19:40:43.000000000 +0100
|
||||
@@ -18746,8 +18746,8 @@
|
||||
|
||||
|
||||
if test "${ac_cv_header_directfb_internal_directfb_version_h+set}" = set; then
|
||||
- echo "$as_me:$LINENO: checking for directfb-internal/directfb_version.h" >&5
|
||||
-echo $ECHO_N "checking for directfb-internal/directfb_version.h... $ECHO_C" >&6
|
||||
+ echo "$as_me:$LINENO: checking for directfb/directfb_version.h" >&5
|
||||
+echo $ECHO_N "checking for directfb/directfb_version.h... $ECHO_C" >&6
|
||||
if test "${ac_cv_header_directfb_internal_directfb_version_h+set}" = set; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
fi
|
||||
@@ -18755,8 +18755,8 @@
|
||||
echo "${ECHO_T}$ac_cv_header_directfb_internal_directfb_version_h" >&6
|
||||
else
|
||||
# Is the header compilable?
|
||||
-echo "$as_me:$LINENO: checking directfb-internal/directfb_version.h usability" >&5
|
||||
-echo $ECHO_N "checking directfb-internal/directfb_version.h usability... $ECHO_C" >&6
|
||||
+echo "$as_me:$LINENO: checking directfb/directfb_version.h usability" >&5
|
||||
+echo $ECHO_N "checking directfb/directfb_version.h usability... $ECHO_C" >&6
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
/* confdefs.h. */
|
||||
_ACEOF
|
||||
@@ -18764,7 +18764,7 @@
|
||||
cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
$ac_includes_default
|
||||
-#include <directfb-internal/directfb_version.h>
|
||||
+#include <directfb/directfb_version.h>
|
||||
_ACEOF
|
||||
rm -f conftest.$ac_objext
|
||||
if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
|
||||
@@ -18800,15 +18800,15 @@
|
||||
echo "${ECHO_T}$ac_header_compiler" >&6
|
||||
|
||||
# Is the header present?
|
||||
-echo "$as_me:$LINENO: checking directfb-internal/directfb_version.h presence" >&5
|
||||
-echo $ECHO_N "checking directfb-internal/directfb_version.h presence... $ECHO_C" >&6
|
||||
+echo "$as_me:$LINENO: checking directfb/directfb_version.h presence" >&5
|
||||
+echo $ECHO_N "checking directfb/directfb_version.h presence... $ECHO_C" >&6
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
/* confdefs.h. */
|
||||
_ACEOF
|
||||
cat confdefs.h >>conftest.$ac_ext
|
||||
cat >>conftest.$ac_ext <<_ACEOF
|
||||
/* end confdefs.h. */
|
||||
-#include <directfb-internal/directfb_version.h>
|
||||
+#include <directfb/directfb_version.h>
|
||||
_ACEOF
|
||||
if { (eval echo "$as_me:$LINENO: \"$ac_cpp conftest.$ac_ext\"") >&5
|
||||
(eval $ac_cpp conftest.$ac_ext) 2>conftest.er1
|
||||
@@ -18842,25 +18842,25 @@
|
||||
# So? What about this header?
|
||||
case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
|
||||
yes:no: )
|
||||
- { echo "$as_me:$LINENO: WARNING: directfb-internal/directfb_version.h: accepted by the compiler, rejected by the preprocessor!" >&5
|
||||
-echo "$as_me: WARNING: directfb-internal/directfb_version.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
|
||||
- { echo "$as_me:$LINENO: WARNING: directfb-internal/directfb_version.h: proceeding with the compiler's result" >&5
|
||||
-echo "$as_me: WARNING: directfb-internal/directfb_version.h: proceeding with the compiler's result" >&2;}
|
||||
+ { echo "$as_me:$LINENO: WARNING: directfb/directfb_version.h: accepted by the compiler, rejected by the preprocessor!" >&5
|
||||
+echo "$as_me: WARNING: directfb/directfb_version.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
|
||||
+ { echo "$as_me:$LINENO: WARNING: directfb/directfb_version.h: proceeding with the compiler's result" >&5
|
||||
+echo "$as_me: WARNING: directfb/directfb_version.h: proceeding with the compiler's result" >&2;}
|
||||
ac_header_preproc=yes
|
||||
;;
|
||||
no:yes:* )
|
||||
- { echo "$as_me:$LINENO: WARNING: directfb-internal/directfb_version.h: present but cannot be compiled" >&5
|
||||
-echo "$as_me: WARNING: directfb-internal/directfb_version.h: present but cannot be compiled" >&2;}
|
||||
- { echo "$as_me:$LINENO: WARNING: directfb-internal/directfb_version.h: check for missing prerequisite headers?" >&5
|
||||
-echo "$as_me: WARNING: directfb-internal/directfb_version.h: check for missing prerequisite headers?" >&2;}
|
||||
- { echo "$as_me:$LINENO: WARNING: directfb-internal/directfb_version.h: see the Autoconf documentation" >&5
|
||||
-echo "$as_me: WARNING: directfb-internal/directfb_version.h: see the Autoconf documentation" >&2;}
|
||||
- { echo "$as_me:$LINENO: WARNING: directfb-internal/directfb_version.h: section \"Present But Cannot Be Compiled\"" >&5
|
||||
-echo "$as_me: WARNING: directfb-internal/directfb_version.h: section \"Present But Cannot Be Compiled\"" >&2;}
|
||||
- { echo "$as_me:$LINENO: WARNING: directfb-internal/directfb_version.h: proceeding with the preprocessor's result" >&5
|
||||
-echo "$as_me: WARNING: directfb-internal/directfb_version.h: proceeding with the preprocessor's result" >&2;}
|
||||
- { echo "$as_me:$LINENO: WARNING: directfb-internal/directfb_version.h: in the future, the compiler will take precedence" >&5
|
||||
-echo "$as_me: WARNING: directfb-internal/directfb_version.h: in the future, the compiler will take precedence" >&2;}
|
||||
+ { echo "$as_me:$LINENO: WARNING: directfb/directfb_version.h: present but cannot be compiled" >&5
|
||||
+echo "$as_me: WARNING: directfb/directfb_version.h: present but cannot be compiled" >&2;}
|
||||
+ { echo "$as_me:$LINENO: WARNING: directfb/directfb_version.h: check for missing prerequisite headers?" >&5
|
||||
+echo "$as_me: WARNING: directfb/directfb_version.h: check for missing prerequisite headers?" >&2;}
|
||||
+ { echo "$as_me:$LINENO: WARNING: directfb/directfb_version.h: see the Autoconf documentation" >&5
|
||||
+echo "$as_me: WARNING: directfb/directfb_version.h: see the Autoconf documentation" >&2;}
|
||||
+ { echo "$as_me:$LINENO: WARNING: directfb/directfb_version.h: section \"Present But Cannot Be Compiled\"" >&5
|
||||
+echo "$as_me: WARNING: directfb/directfb_version.h: section \"Present But Cannot Be Compiled\"" >&2;}
|
||||
+ { echo "$as_me:$LINENO: WARNING: directfb/directfb_version.h: proceeding with the preprocessor's result" >&5
|
||||
+echo "$as_me: WARNING: directfb/directfb_version.h: proceeding with the preprocessor's result" >&2;}
|
||||
+ { echo "$as_me:$LINENO: WARNING: directfb/directfb_version.h: in the future, the compiler will take precedence" >&5
|
||||
+echo "$as_me: WARNING: directfb/directfb_version.h: in the future, the compiler will take precedence" >&2;}
|
||||
(
|
||||
cat <<\_ASBOX
|
||||
## ------------------------------------------------------ ##
|
||||
@@ -18871,8 +18871,8 @@
|
||||
sed "s/^/$as_me: WARNING: /" >&2
|
||||
;;
|
||||
esac
|
||||
-echo "$as_me:$LINENO: checking for directfb-internal/directfb_version.h" >&5
|
||||
-echo $ECHO_N "checking for directfb-internal/directfb_version.h... $ECHO_C" >&6
|
||||
+echo "$as_me:$LINENO: checking for directfb/directfb_version.h" >&5
|
||||
+echo $ECHO_N "checking for directfb/directfb_version.h... $ECHO_C" >&6
|
||||
if test "${ac_cv_header_directfb_internal_directfb_version_h+set}" = set; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
Loading…
Reference in New Issue
Block a user