mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-21 19:54:03 +02:00
[new package] some unfinished package. mark as BROKEN
This commit is contained in:
parent
e0a7e26b44
commit
a9090d686e
45
mlterm/Makefile
Normal file
45
mlterm/Makefile
Normal file
@ -0,0 +1,45 @@
|
||||
#
|
||||
# Copyright (C) 2009 Qi Hardware Inc.
|
||||
# Author: Xiangfu Liu <xiangfu@qi-hardware.com>
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mlterm
|
||||
PKG_VERSION:=2.9.4
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://cdnetworks-kr-2.dl.sourceforge.net/project/mlterm/01%20release/mlterm-2.9.4/
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/mlterm
|
||||
TITLE:=mlterm
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
DEPENDS:=@BROKEN
|
||||
URL:=http://mlterm.sourceforge.net/
|
||||
endef
|
||||
|
||||
define Package/mlterm/description
|
||||
Mlterm is a multilingual terminal emulator on X11
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS+=
|
||||
TARGET_LDFLAGS+=
|
||||
|
||||
CONFIGURE_ARGS +=
|
||||
|
||||
define Package/mlterm/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mlterm $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,mlterm))
|
49
myserver/Makefile
Normal file
49
myserver/Makefile
Normal file
@ -0,0 +1,49 @@
|
||||
#
|
||||
# Author : Ernest Kugel <erik.kugel@gmail.com>
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=myserver
|
||||
PKG_VERSION:=0.9.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=myserver-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=ftp://ftp.gnu.org/gnu/myserver/0.9.2
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
TARGET_LDFLAGS+= \
|
||||
-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
|
||||
|
||||
define Package/myserver
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=MyServer is a powerful and easy to configure web server
|
||||
URL:=http://www.myserverproject.net/index.php/Main_Page
|
||||
DEPENDS:=@BROKEN +libgnutls-openssl
|
||||
endef
|
||||
|
||||
define Package/myserver/description
|
||||
MyServer is a powerful and easy to configure web server.
|
||||
Its multi-threaded architecture makes it extremely scalable and
|
||||
usable in large scale sites as well as in small networks, it has
|
||||
a lot of built-in features. Share your files in minutes!
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default)
|
||||
endef
|
||||
|
||||
define Package/myserver/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/myserver/myserver $(1)/usr/sbin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,myserver))
|
43
sarien/Makefile
Normal file
43
sarien/Makefile
Normal file
@ -0,0 +1,43 @@
|
||||
# Copyright (C) 2010 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
PKG_NAME:=sarien
|
||||
PKG_VERSION:=0.7.0
|
||||
PKG_RELEASE:=1
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
PKG_CAT:=zcat
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/sarien-$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/sarien
|
||||
TITLE:=Sarien
|
||||
SECTION:=games
|
||||
CATEGORY:=Games
|
||||
DEPENDS:=@BROKEN +libsdl
|
||||
URL:=http://sourceforge.net/projects/sarien/
|
||||
endef
|
||||
|
||||
define Package/sarien/description
|
||||
Sarien is a portable implementation of the Sierra On-Line Adventure Game Interpreter (AGI)
|
||||
endef
|
||||
|
||||
MAKE_ARGS += ipkg
|
||||
CONFIGURE_ARGS += --with-sdl --with-alsa
|
||||
|
||||
define Package/sarien/Build/Compile
|
||||
$(call Build/Compile/Default)
|
||||
endef
|
||||
|
||||
define Package/sarien/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_DIR) $(1)/usr/share/sarien
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/bin/sarien $(1)/sarien
|
||||
$(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/sarien.cfg $(1)/usr/share/sarien/sarien.cfg
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,sarien))
|
89
sarien/patches/sarien-0.7.0-nanonote1.patch
Normal file
89
sarien/patches/sarien-0.7.0-nanonote1.patch
Normal file
@ -0,0 +1,89 @@
|
||||
diff -urN sarien-0.7.0/etc/sarien.cfg sarien-0.7.0-nanonote/etc/sarien.cfg
|
||||
--- sarien-0.7.0/etc/sarien.cfg 2001-11-06 10:49:58.000000000 +0100
|
||||
+++ sarien-0.7.0-nanonote/etc/sarien.cfg 2010-06-21 00:21:42.000000000 +0200
|
||||
@@ -6,8 +6,7 @@
|
||||
# to the operating system being used.
|
||||
#
|
||||
# In UNIX:
|
||||
-# $HOME/.sarienrc
|
||||
-# /etc/sarien.conf
|
||||
+# /usr/share/sarien/sarien.cfg
|
||||
#
|
||||
# In Cygwin:
|
||||
# /etc/sarien.conf
|
||||
diff -urN sarien-0.7.0/Makefile sarien-0.7.0-nanonote/Makefile
|
||||
--- sarien-0.7.0/Makefile 2001-09-04 04:17:00.000000000 +0200
|
||||
+++ sarien-0.7.0-nanonote/Makefile 2010-06-21 01:29:46.000000000 +0200
|
||||
@@ -72,6 +72,17 @@
|
||||
rm -Rf $(DIST)
|
||||
sync
|
||||
|
||||
+ipkg:
|
||||
+ rm -Rf ipkg-tmp $(DIST).ipk
|
||||
+ mkdir -p ipkg-tmp/CONTROL
|
||||
+ cp openwrt/control ipkg-tmp/CONTROL
|
||||
+ $(MAKE) DISTDIR=ipkg-tmp install
|
||||
+ ipkg-build -o root -g root ipkg-tmp
|
||||
+
|
||||
+install: all
|
||||
+ install -D -m 0755 -s --strip-program=$(STRIP) bin/sarien $(DISTDIR)$(BIN_DIR)/sarien
|
||||
+ install -D -m 0644 etc/sarien.cfg $(DISTDIR)$(DATADIR)/sarien.cfg
|
||||
+
|
||||
chkoldver:
|
||||
@if [ "$(OLDVER)" = "" ]; then \
|
||||
echo "parameter missing: OLDVER=<old_version>"; \
|
||||
diff -urN sarien-0.7.0/openwrt/control sarien-0.7.0-nanonote/openwrt/control
|
||||
--- sarien-0.7.0/openwrt/control 1970-01-01 01:00:00.000000000 +0100
|
||||
+++ sarien-0.7.0-nanonote/openwrt/control 2010-06-21 00:54:37.000000000 +0200
|
||||
@@ -0,0 +1,18 @@
|
||||
+Package: sarien
|
||||
+Version: 0.7.0-1
|
||||
+Source: http://sourceforge.net/projects/sarien/
|
||||
+Architecture: xburst
|
||||
+Maintainer: Magnus Bergman <magnusbe@algonet.se>
|
||||
+Priority: optional
|
||||
+Section: extras
|
||||
+Depends: libsdl
|
||||
+Description: An interpreter for AGI resources
|
||||
+ The old Sierra games are made with the AGI engine. Sarien
|
||||
+ is a free interpreter for AGI resources.
|
||||
+ .
|
||||
+ Games written in AGI includes:
|
||||
+ * Kings Quest I - IV
|
||||
+ * Police Quest
|
||||
+ * Leisure Suit Larry
|
||||
+ .
|
||||
+ You need the files from the original games.
|
||||
diff -urN sarien-0.7.0/Rules.in sarien-0.7.0-nanonote/Rules.in
|
||||
--- sarien-0.7.0/Rules.in 2001-09-06 14:41:36.000000000 +0200
|
||||
+++ sarien-0.7.0-nanonote/Rules.in 2010-06-21 00:14:38.000000000 +0200
|
||||
@@ -3,6 +3,7 @@
|
||||
prefix = @prefix@
|
||||
exec_prefix = @prefix@
|
||||
BIN_DIR = @bindir@
|
||||
+DATA_DIR = @datadir@/sarien
|
||||
LIB_DIR = @libdir@
|
||||
MAN_DIR = @mandir@/man1
|
||||
|
||||
diff -urN sarien-0.7.0/src/filesys/unix/path.c sarien-0.7.0-nanonote/src/filesys/unix/path.c
|
||||
--- sarien-0.7.0/src/filesys/unix/path.c 2001-08-05 01:59:48.000000000 +0200
|
||||
+++ sarien-0.7.0-nanonote/src/filesys/unix/path.c 2010-06-21 00:57:09.000000000 +0200
|
||||
@@ -46,6 +46,6 @@
|
||||
#endif
|
||||
#endif
|
||||
|
||||
- return "/etc/sarien.conf";
|
||||
+ return DATADIR "/sarien.cfg";
|
||||
}
|
||||
|
||||
diff -urN sarien-0.7.0/src/graphics/sdl/sdl.c sarien-0.7.0-nanonote/src/graphics/sdl/sdl.c
|
||||
--- sarien-0.7.0/src/graphics/sdl/sdl.c 2010-06-19 17:41:56.000000000 +0200
|
||||
+++ sarien-0.7.0-nanonote/src/graphics/sdl/sdl.c 2010-06-20 23:02:18.000000000 +0200
|
||||
@@ -460,6 +460,7 @@
|
||||
SDL_GetError ());
|
||||
return err_Unk;
|
||||
}
|
||||
+ SDL_ShowCursor (SDL_DISABLE);
|
||||
|
||||
mode = SDL_SWSURFACE | SDL_ANYFORMAT;
|
||||
|
46
scummvm/Makefile
Normal file
46
scummvm/Makefile
Normal file
@ -0,0 +1,46 @@
|
||||
# Copyright (C) 2010 tuxbrain.com
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=scummvm
|
||||
PKG_VERSION:=1.1.1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
PKG_CAT:=bzcat
|
||||
PKG_BUILD_DEPENDS:=+libiconv +libsdl +libsdl_sound +libsdl_mixer
|
||||
DEPENDS:=libiconv libsdl libsdl_sound libsdl_mixer
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/scummvm
|
||||
TITLE:=free implementation of LucasArts SCUMM interpreter
|
||||
SECTION:=games
|
||||
CATEGORY:=Games
|
||||
DEPENDS:=@BROKEN
|
||||
URL:=http://www.scummvm.org/
|
||||
endef
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/scummvm-$(PKG_VERSION)
|
||||
|
||||
define Package/scummvm/description
|
||||
ScummVM is a program which allows you to run certain classic graphical point-and-click adventure games, provided you already have their data files. The clever part about this: ScummVM just replaces the executables shipped with the games, allowing you to play them on systems for which they were never designed!
|
||||
endef
|
||||
|
||||
MAKE_FLAGS += AR="mipsel-openwrt-linux-uclibc-ar cru"
|
||||
|
||||
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/SDL
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default, --enable-all-engines --disable-nasm --disable-mad --disable-vorbis --disable-scalers --disable-mt32emu --disable-hq-scalers --disable-indeo3)
|
||||
|
||||
endef
|
||||
define Package/scummvm/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/scummvm $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,scummvm))
|
24
scummvm/patches/001_del_wrong_param_check_configure.patch
Normal file
24
scummvm/patches/001_del_wrong_param_check_configure.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -cB scummvm-1.1.1/configure scummvm-1.1.1.mod/configure
|
||||
*** scummvm-1.1.1/configure 2010-04-01 00:51:54.000000000 +0200
|
||||
--- scummvm-1.1.1.mod/configure 2010-06-15 22:34:20.735635566 +0200
|
||||
***************
|
||||
*** 696,701 ****
|
||||
--- 696,703 ----
|
||||
--disable-keymapper) _keymapper=no ;;
|
||||
--enable-text-console) _text_console=yes ;;
|
||||
--disable-text-console) _text_console=no ;;
|
||||
+ --disable-nls) ;;
|
||||
+ --disable-ipv6) ;;
|
||||
--with-fluidsynth-prefix=*)
|
||||
arg=`echo $ac_option | cut -d '=' -f 2`
|
||||
FLUIDSYNTH_CFLAGS="-I$arg/include"
|
||||
***************
|
||||
*** 810,816 ****
|
||||
engine_disable `echo $ac_option | cut -d '-' -f 4-`
|
||||
;;
|
||||
*)
|
||||
- option_error
|
||||
;;
|
||||
esac;
|
||||
done;
|
||||
--- 812,817 ----
|
Loading…
Reference in New Issue
Block a user