mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-04 23:21:53 +02:00
make the stardict can resize to 320x240
This commit is contained in:
parent
4e63e5be4c
commit
b4a049968e
@ -8,10 +8,11 @@ From: Xiangfu Liu <xiangfu@sharism.cc>
|
||||
configure.in | 26 ++-
|
||||
src/class_factory.cpp | 2
|
||||
src/conf.cpp | 6 -
|
||||
src/mainwin.cpp | 9 +
|
||||
src/stardict.cpp | 35 +++-
|
||||
src/x11_iskeyspressed.cpp | 351 ---------------------------------------------
|
||||
src/x11_iskeyspressed.hpp | 65 --------
|
||||
6 files changed, 39 insertions(+), 446 deletions(-)
|
||||
7 files changed, 44 insertions(+), 450 deletions(-)
|
||||
|
||||
|
||||
diff --git a/configure.in b/configure.in
|
||||
@ -83,6 +84,33 @@ index 2d0f89d..a35bc5c 100644
|
||||
#endif
|
||||
|
||||
std::auto_ptr<AppConf> conf;
|
||||
diff --git a/src/mainwin.cpp b/src/mainwin.cpp
|
||||
index 7005f7b..5bda8be 100644
|
||||
--- a/src/mainwin.cpp
|
||||
+++ b/src/mainwin.cpp
|
||||
@@ -129,10 +129,10 @@ void TopWin::Create(GtkWidget *vbox)
|
||||
gtk_box_pack_start(GTK_BOX(hbox),button,false,false,0);
|
||||
gtk_widget_set_tooltip_text(button,_("Go Back - Right button: history (Alt+Left)"));
|
||||
|
||||
- GtkWidget *label;
|
||||
- label = gtk_label_new("\t");
|
||||
- gtk_widget_show(label);
|
||||
- gtk_box_pack_start(GTK_BOX(hbox),label,false,false,0);
|
||||
+ // GtkWidget *label;
|
||||
+ // label = gtk_label_new("\t");
|
||||
+ // gtk_widget_show(label);
|
||||
+ // gtk_box_pack_start(GTK_BOX(hbox),label,false,false,0);
|
||||
|
||||
button=gtk_button_new();
|
||||
gtk_container_add(GTK_CONTAINER(button),gtk_image_new_from_stock(GTK_STOCK_HOME,GTK_ICON_SIZE_BUTTON));
|
||||
@@ -2665,6 +2665,7 @@ void MidWin::Create(GtkWidget *vbox)
|
||||
|
||||
notebook = gtk_notebook_new();
|
||||
gtk_widget_show(notebook);
|
||||
+ gtk_widget_set_size_request(GTK_WIDGET(notebook), 50, 20);
|
||||
gtk_notebook_set_show_tabs(GTK_NOTEBOOK(notebook), false);
|
||||
gtk_notebook_set_show_border(GTK_NOTEBOOK(notebook),false);
|
||||
|
||||
diff --git a/src/stardict.cpp b/src/stardict.cpp
|
||||
index 326ca4a..0e820ed 100644
|
||||
--- a/src/stardict.cpp
|
||||
|
Loading…
Reference in New Issue
Block a user