mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 00:44:03 +02:00
gmu: update to 0.9.1
This commit is contained in:
parent
6b68c45b33
commit
b731d34ce1
13
gmu/Makefile
13
gmu/Makefile
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gmu
|
||||
PKG_VERSION:=0.8.0BETA1
|
||||
PKG_VERSION:=0.9.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://wejp.k.vu/files/
|
||||
PKG_MD5SUM:=a1a3d346802f3877b4c739b3c65225d6
|
||||
PKG_MD5SUM:=b9beb8ae21828c637821fcc98b989603
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -24,7 +24,8 @@ define Package/gmu
|
||||
URL:=http://wejp.k.vu/projects/gmu/
|
||||
MENU:=1
|
||||
DEPENDS:=+libsdl +libsdl-image +libsdl-gfx +libmpcdec +libmikmod \
|
||||
+libvorbisidec +libspeex +libflac +libogg +BUILD_PATENTED:libmpg123
|
||||
+libvorbisidec +libspeex +libflac +libogg +BUILD_PATENTED:libmpg123 \
|
||||
+libncursesw
|
||||
endef
|
||||
|
||||
define Package/gmu/description
|
||||
@ -34,7 +35,7 @@ define Package/gmu/description
|
||||
endef
|
||||
|
||||
MAKE_VARS += TARGET=nanonote $(if $(CONFIG_BUILD_PATENTED),MORE_DECODERS="decoders/mpg123.so")
|
||||
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/SDL
|
||||
TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include/SDL -I$(STAGING_DIR)/usr/include/ncursesw
|
||||
TARGET_LDFLAGS+= \
|
||||
-Wl,-rpath-link=$(STAGING_DIR)/usr/lib \
|
||||
-L$(STAGING_DIR)/usr/lib/SDL \
|
||||
@ -49,8 +50,8 @@ define Package/gmu/install
|
||||
$(1)/usr/share/gmu/themes/default-modern
|
||||
|
||||
$(INSTALL_BIN) \
|
||||
$(PKG_BUILD_DIR)/gmu \
|
||||
$(1)/usr/bin/gmu.bin
|
||||
$(PKG_BUILD_DIR)/{gmu.bin,gmuc} \
|
||||
$(1)/usr/bin/
|
||||
|
||||
$(INSTALL_BIN) \
|
||||
./files/gmu \
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/nanonote.mk
|
||||
+++ b/nanonote.mk
|
||||
@@ -19,11 +19,7 @@ DECODERS_TO_BUILD=decoders/vorbis.so dec
|
||||
@@ -18,11 +18,7 @@ DECODERS_TO_BUILD=decoders/vorbis.so dec
|
||||
FRONTENDS_TO_BUILD=frontends/sdl.so frontends/log.so
|
||||
SDL_LIB=-lSDL -lpthread -ldirectfb -ldirect -lfusion -lz
|
||||
SDL_CFLAGS=-D_GNU_SOURCE=1 -D_REENTRANT
|
||||
@ -13,4 +13,4 @@
|
||||
-LFLAGS=-s -L$(TOOLCHAIN_ROOT_PATH)/target-mipsel_uClibc-0.9.30.1/usr/lib -L$(TOOLCHAIN_ROOT_PATH)/target-mipsel_uClibc-0.9.30.1/root-xburst/usr/lib -lpthread -lm -ldl -lgcc -Wl,-export-dynamic
|
||||
+CFLAGS+=-msoft-float -ffast-math -fomit-frame-pointer $(SDL_CFLAGS) -DFILE_HW_H="\"hw_$(TARGET).h\""
|
||||
+LFLAGS=$(LDFLAGS) -s $(SDL_LIB) -lpthread -lm -ldl -lgcc -Wl,-export-dynamic
|
||||
DISTFILES=$(BINARY) frontends decoders themes gmu.png README.txt libs.nanonote gmu.nn COPYING gmuinput.nanonote.conf gmu.bmp
|
||||
DISTFILES=$(COMMON_DISTBIN_FILES) gmu-nanonote.sh gmuinput.nanonote.conf
|
||||
|
@ -1,8 +1,8 @@
|
||||
--- a/nanonote.mk
|
||||
+++ b/nanonote.mk
|
||||
@@ -16,6 +16,9 @@
|
||||
@@ -15,6 +15,9 @@
|
||||
#
|
||||
|
||||
#DECODERS_TO_BUILD=decoders/vorbis.so decoders/musepack.so decoders/flac.so decoders/wavpack.so decoders/mpg123.so decoders/mikmod.so
|
||||
DECODERS_TO_BUILD=decoders/vorbis.so decoders/musepack.so decoders/wavpack.so decoders/mikmod.so decoders/flac.so decoders/speex.so
|
||||
+ifdef MORE_DECODERS
|
||||
+ DECODERS_TO_BUILD+=$(MORE_DECODERS)
|
||||
|
Loading…
Reference in New Issue
Block a user