mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-10 22:28:25 +02:00
cgminer: increase the MAX_DEVICE to 64
This commit is contained in:
parent
f5c5a97a5c
commit
b96e10c474
@ -11,7 +11,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
PKG_NAME:=cgminer
|
PKG_NAME:=cgminer
|
||||||
PKG_VERSION:=20120315
|
PKG_VERSION:=20120315
|
||||||
PKG_REV:=22ff7a406951f97af57cbca75d282c4bbf41a3e7
|
PKG_REV:=22ff7a406951f97af57cbca75d282c4bbf41a3e7
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=3
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_REV).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_REV).tar.gz
|
||||||
|
@ -1,17 +1,17 @@
|
|||||||
From 5d3d883703d8098537c248c797009247f51b116b Mon Sep 17 00:00:00 2001
|
From 01cd959ba71d577c8a13efbdc868b46515c88334 Mon Sep 17 00:00:00 2001
|
||||||
From: Xiangfu <xiangfu@openmobilefree.net>
|
From: Xiangfu <xiangfu@openmobilefree.net>
|
||||||
Date: Sun, 19 Feb 2012 22:20:22 +0800
|
Date: Sun, 19 Feb 2012 22:20:22 +0800
|
||||||
Subject: [PATCH] add-MIPSED-to-icarus-for-BIG_ENDIAN.patch
|
Subject: [PATCH 1/2] add-MIPSED-to-icarus-for-BIG_ENDIAN.patch
|
||||||
|
|
||||||
---
|
---
|
||||||
icarus.c | 2 +-
|
icarus.c | 2 +-
|
||||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||||
|
|
||||||
diff --git a/icarus.c b/icarus.c
|
diff --git a/icarus.c b/icarus.c
|
||||||
index 1d59657..26f4927 100644
|
index 48dabe5..c4c3736 100644
|
||||||
--- a/icarus.c
|
--- a/icarus.c
|
||||||
+++ b/icarus.c
|
+++ b/icarus.c
|
||||||
@@ -287,7 +287,7 @@ static uint64_t icarus_scanhash(struct thr_info *thr, struct work *work,
|
@@ -290,7 +290,7 @@ static uint64_t icarus_scanhash(struct thr_info *thr, struct work *work,
|
||||||
if (nonce == 0 && ret)
|
if (nonce == 0 && ret)
|
||||||
return 0xffffffff;
|
return 0xffffffff;
|
||||||
|
|
||||||
|
25
cgminer/patches/0002-Increase-the-MAX_DEVICES-to-64.patch
Normal file
25
cgminer/patches/0002-Increase-the-MAX_DEVICES-to-64.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From 6334588efe26a774f4ebaac345073f8ad5f9172c Mon Sep 17 00:00:00 2001
|
||||||
|
From: Xiangfu <xiangfu@openmobilefree.net>
|
||||||
|
Date: Wed, 21 Mar 2012 13:54:53 +0800
|
||||||
|
Subject: [PATCH 2/2] Increase the MAX_DEVICES to 64
|
||||||
|
|
||||||
|
---
|
||||||
|
miner.h | 2 +-
|
||||||
|
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/miner.h b/miner.h
|
||||||
|
index 5f5fd68..e1cc07f 100644
|
||||||
|
--- a/miner.h
|
||||||
|
+++ b/miner.h
|
||||||
|
@@ -473,7 +473,7 @@ extern int add_pool_details(bool live, char *url, char *user, char *pass);
|
||||||
|
#define ADD_POOL_OK 0
|
||||||
|
|
||||||
|
#define MAX_GPUDEVICES 16
|
||||||
|
-#define MAX_DEVICES 32
|
||||||
|
+#define MAX_DEVICES 64
|
||||||
|
#define MAX_POOLS (32)
|
||||||
|
|
||||||
|
#define MIN_INTENSITY -10
|
||||||
|
--
|
||||||
|
1.7.5.4
|
||||||
|
|
Loading…
Reference in New Issue
Block a user