mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-10 22:39:43 +02:00
Add libunistring
This commit is contained in:
parent
a3e9bea8a8
commit
bb2a84ca0e
64
libunistring/Makefile
Normal file
64
libunistring/Makefile
Normal file
@ -0,0 +1,64 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2009 Qi Hardware Inc.
|
||||||
|
# Author: Bart van Strien <bart.bes@gmail.com>
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=libunistring
|
||||||
|
PKG_VERSION:=0.9.2.1
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/$(PKG_NAME)/
|
||||||
|
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/libunistring
|
||||||
|
MAINTAINER:="Bart van Strien" <bart.bes@gmail.com>
|
||||||
|
TITLE:=libunistring
|
||||||
|
SECTION:=libs
|
||||||
|
CATEGORY:=Libraries
|
||||||
|
DEPENDS:=+libiconv
|
||||||
|
URL:=http://savannah.gnu.org/projects/libunistring/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/libunistring/description
|
||||||
|
This library implements Unicode strings, together with functions for Unicode characters and functions for string processing.
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
$(MAKE) -C "$(PKG_BUILD_DIR)"\
|
||||||
|
DESTDIR="$(PKG_INSTALL_DIR)"\
|
||||||
|
all install
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/InstallDev
|
||||||
|
$(INSTALL_DIR) \
|
||||||
|
$(1)/usr/include \
|
||||||
|
$(1)/usr/lib \
|
||||||
|
$(1)/usr/share
|
||||||
|
$(CP) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/lib/* \
|
||||||
|
$(1)/usr/lib/
|
||||||
|
$(CP) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/include/* \
|
||||||
|
$(1)/usr/include/
|
||||||
|
$(CP) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/share/* \
|
||||||
|
$(1)/usr/share
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/libunistring/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
|
|
||||||
|
$(CP) \
|
||||||
|
$(PKG_INSTALL_DIR)/usr/lib/* \
|
||||||
|
$(1)/usr/lib/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,libunistring))
|
12
libunistring/patches/0001-locale.patch
Normal file
12
libunistring/patches/0001-locale.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -ruN libunistring-0.9.2.1/lib/localename.c libunistring-0.9.2.1m/lib/localename.c
|
||||||
|
--- libunistring-0.9.2.1/lib/localename.c 2010-01-01 11:02:02.000000000 +0100
|
||||||
|
+++ libunistring-0.9.2.1m/lib/localename.c 2011-08-12 01:25:13.037171961 +0200
|
||||||
|
@@ -2607,7 +2607,7 @@
|
||||||
|
locale_t thread_locale = uselocale (NULL);
|
||||||
|
if (thread_locale != LC_GLOBAL_LOCALE)
|
||||||
|
{
|
||||||
|
-# if __GLIBC__ >= 2
|
||||||
|
+# if __GLIBC__ >= 2 && 0
|
||||||
|
/* Work around an incorrect definition of the _NL_LOCALE_NAME macro in
|
||||||
|
glibc < 2.12.
|
||||||
|
See <http://sourceware.org/bugzilla/show_bug.cgi?id=10968>. */
|
Loading…
Reference in New Issue
Block a user