mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 01:02:49 +02:00
mupdf, jbig2dec and openjpeg as prerequisites of nupdf.
This commit is contained in:
parent
a863278092
commit
bbe02374cb
59
jbig2dec/Makefile
Normal file
59
jbig2dec/Makefile
Normal file
@ -0,0 +1,59 @@
|
||||
#
|
||||
# Copyright (C) 2005-2009 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=jbig2dec
|
||||
PKG_VERSION:=0.11
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://ghostscript.com/~giles/jbig2/jbig2dec/
|
||||
PKG_MD5SUM:=1f61e144852c86563fee6e5ddced63f1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
PKG_INSTALL=1
|
||||
|
||||
define Package/jbig2dec
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=decoder implementation of the JBIG2 image compression format
|
||||
URL:=http://jbig2dec.sourceforge.net/
|
||||
endef
|
||||
|
||||
define Package/jbig2dec/description
|
||||
jbig2dec is a decoder implementation of the JBIG2 image compression format.
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default, \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
)
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_INSTALL_DIR)/usr/include/jbig2.h \
|
||||
$(1)/usr/include/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/libjbig2dec.{la,a,so*} \
|
||||
$(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Package/jbig2dec/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/libjbig2dec.so.* \
|
||||
$(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,jbig2dec))
|
88
mupdf/Makefile
Normal file
88
mupdf/Makefile
Normal file
@ -0,0 +1,88 @@
|
||||
#
|
||||
# Copyright (C) 2005-2009 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mupdf
|
||||
PKG_VERSION:=0.7
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://mupdf.com/download/
|
||||
PKG_MD5SUM:=83adc4d14eb17835df791a9a0d1e8fa9
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/mupdf/Default
|
||||
URL:=http://mupdf.com
|
||||
DEPENDS:=+jbig2dec +openjpeg +zlib +libfreetype
|
||||
endef
|
||||
|
||||
define Package/mupdf
|
||||
$(call Package/mupdf/Default)
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=lightweight PDF viewer and toolkit written in portable C
|
||||
endef
|
||||
|
||||
define Package/mupdf-tools
|
||||
$(call Package/mupdf/Default)
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=Command-line PDF tools
|
||||
endef
|
||||
|
||||
define Package/mupdf/description
|
||||
MuPDF is a lightweight PDF viewer and toolkit written in portable C.
|
||||
endef
|
||||
|
||||
define Package/mupdf-tools/description
|
||||
This package installs command-line tools: pdfclean, pdfinfo, pdfdraw, pdfextract, pdfshow
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS+= \
|
||||
-I$(STAGING_DIR)/usr/include/freetype2 \
|
||||
-I$(PKG_BUILD_DIR)/mupdf \
|
||||
-I$(PKG_BUILD_DIR)/fitz
|
||||
|
||||
TARGET_LDFLAGS+= \
|
||||
-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
|
||||
|
||||
MAKE_FLAGS+=build=release prefix=/usr verbose=true pregen=build/generated
|
||||
|
||||
define Build/Configure
|
||||
$(INSTALL_DIR) $(PKG_BUILD_DIR)/build
|
||||
$(CP) $(FILES_DIR)/generated $(PKG_BUILD_DIR)/build
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_BUILD_DIR)/mupdf/mupdf.h \
|
||||
$(PKG_BUILD_DIR)/fitz/fitz.h \
|
||||
$(PKG_BUILD_DIR)/apps/pdfapp.h \
|
||||
$(1)/usr/include/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_BUILD_DIR)/build/release/libmupdf.a \
|
||||
$(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Package/mupdf-tools/install
|
||||
$(INSTALL_DIR) \
|
||||
$(1)/usr/bin
|
||||
|
||||
$(INSTALL_BIN) \
|
||||
$(PKG_BUILD_DIR)/build/release/{pdfclean,pdfinfo,pdfdraw,pdfextract,pdfshow} \
|
||||
$(1)/usr/bin
|
||||
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,mupdf))
|
||||
$(eval $(call BuildPackage,mupdf-tools))
|
48295
mupdf/files/generated/cmap_cns.c
Normal file
48295
mupdf/files/generated/cmap_cns.c
Normal file
File diff suppressed because it is too large
Load Diff
52738
mupdf/files/generated/cmap_gb.c
Normal file
52738
mupdf/files/generated/cmap_gb.c
Normal file
File diff suppressed because it is too large
Load Diff
44028
mupdf/files/generated/cmap_japan.c
Normal file
44028
mupdf/files/generated/cmap_japan.c
Normal file
File diff suppressed because it is too large
Load Diff
25614
mupdf/files/generated/cmap_korea.c
Normal file
25614
mupdf/files/generated/cmap_korea.c
Normal file
File diff suppressed because it is too large
Load Diff
66303
mupdf/files/generated/cmap_unicode.c
Normal file
66303
mupdf/files/generated/cmap_unicode.c
Normal file
File diff suppressed because it is too large
Load Diff
45747
mupdf/files/generated/font_base14.c
Normal file
45747
mupdf/files/generated/font_base14.c
Normal file
File diff suppressed because it is too large
Load Diff
192635
mupdf/files/generated/font_cjk.c
Normal file
192635
mupdf/files/generated/font_cjk.c
Normal file
File diff suppressed because it is too large
Load Diff
13
mupdf/patches/001-Makefile.patch
Normal file
13
mupdf/patches/001-Makefile.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- mupdf-0.7_orig/Makefile 2010-09-10 17:38:20.986315574 +0400
|
||||
+++ mupdf-0.7/Makefile 2010-09-11 16:26:24.552535117 +0400
|
||||
@@ -32,8 +32,8 @@
|
||||
|
||||
LIBS := -lfreetype -ljbig2dec -lopenjpeg -ljpeg -lz -lm
|
||||
|
||||
-include Makerules
|
||||
-include Makethird
|
||||
+#include Makerules
|
||||
+#include Makethird
|
||||
|
||||
CFLAGS += $(THIRD_INCS) $(SYS_FREETYPE_INC)
|
||||
|
53
openjpeg/Makefile
Normal file
53
openjpeg/Makefile
Normal file
@ -0,0 +1,53 @@
|
||||
#
|
||||
# Copyright (C) 2005-2009 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=openjpeg
|
||||
PKG_VERSION:=1.3
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)_v1_3.tar.gz
|
||||
PKG_SOURCE_URL:=http://openjpeg.googlecode.com/files/
|
||||
PKG_MD5SUM:=f9a3ccfa91ac34b589e9bf7577ce8ff9
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
PKG_INSTALL=1
|
||||
PKG_UNPACK:=gzip -dc $(DL_DIR)/$(PKG_SOURCE) | $(TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xf -
|
||||
|
||||
define Package/openjpeg
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=open-source JPEG 2000 codec written in C language.
|
||||
URL:=http://www.openjpeg.org
|
||||
endef
|
||||
|
||||
define Package/openjpeg/description
|
||||
The OpenJPEG library is an open-source JPEG 2000 codec written in C language.
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_INSTALL_DIR)/usr/include/openjpeg.h \
|
||||
$(1)/usr/include/
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/libopenjpeg.{a,so*} \
|
||||
$(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Package/openjpeg/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/libopenjpeg.so.* \
|
||||
$(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,openjpeg))
|
17
openjpeg/patches/001-install.patch
Normal file
17
openjpeg/patches/001-install.patch
Normal file
@ -0,0 +1,17 @@
|
||||
--- a/Makefile 2010-09-10 12:28:16.497302519 +0400
|
||||
+++ b/Makefile 2010-09-10 12:27:40.307427782 +0400
|
||||
@@ -58,11 +58,11 @@
|
||||
|
||||
install: OpenJPEG
|
||||
install -d '$(DESTDIR)$(INSTALL_LIBDIR)' '$(DESTDIR)$(INSTALL_INCLUDE)'
|
||||
- install -m 644 -o root -g root $(STATICLIB) '$(DESTDIR)$(INSTALL_LIBDIR)'
|
||||
+ install -m 644 $(STATICLIB) '$(DESTDIR)$(INSTALL_LIBDIR)'
|
||||
ranlib '$(DESTDIR)$(INSTALL_LIBDIR)/$(STATICLIB)'
|
||||
- install -m 755 -o root -g root $(SHAREDLIB) '$(DESTDIR)$(INSTALL_LIBDIR)'
|
||||
+ install -m 755 $(SHAREDLIB) '$(DESTDIR)$(INSTALL_LIBDIR)'
|
||||
ln -sf $(SHAREDLIB) '$(DESTDIR)$(INSTALL_LIBDIR)/$(LIBNAME)'
|
||||
- install -m 644 -o root -g root libopenjpeg/openjpeg.h '$(DESTDIR)$(INSTALL_INCLUDE)'
|
||||
+ install -m 644 libopenjpeg/openjpeg.h '$(DESTDIR)$(INSTALL_INCLUDE)'
|
||||
-ldconfig
|
||||
|
||||
clean:
|
Loading…
Reference in New Issue
Block a user