mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 14:09:42 +02:00
add sdcv(StarDict command line version) to packages
This commit is contained in:
parent
c2726ce3f9
commit
bc972214cb
44
sdcv/Makefile
Normal file
44
sdcv/Makefile
Normal file
@ -0,0 +1,44 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2009 Qi Hardware Inc.
|
||||||
|
# Author: Xiangfu Liu <xiangfu@qi-hardware.com>
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=sdcv
|
||||||
|
PKG_VERSION:=0.4.2
|
||||||
|
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
|
PKG_SOURCE_URL:=http://cdnetworks-kr-1.dl.sourceforge.net/project/sdcv/sdcv/0.4.2/
|
||||||
|
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
|
||||||
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/sdcv
|
||||||
|
TITLE:=sdcv
|
||||||
|
SECTION:=utils
|
||||||
|
CATEGORY:=Utilities
|
||||||
|
URL:=http://sdcv.sourceforge.net/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/sdcv/description
|
||||||
|
StarDict Command line version
|
||||||
|
endef
|
||||||
|
|
||||||
|
TARGET_CFLAGS+=-I$(STAGING_DIR)/usr/lib/libintl/include
|
||||||
|
TARGET_LDFLAGS+= -L$(STAGING_DIR)/usr/lib/libintl/lib
|
||||||
|
|
||||||
|
CONFIGURE_ARGS +=
|
||||||
|
|
||||||
|
define Package/sdcv/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/sdcv $(1)/usr/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,sdcv))
|
29
sdcv/patches/001-fix-compile-error.patch
Normal file
29
sdcv/patches/001-fix-compile-error.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
diff --git a/src/lib/mapfile.hpp b/src/lib/mapfile.hpp
|
||||||
|
index eedb1bc..300849a 100644
|
||||||
|
--- a/src/lib/mapfile.hpp
|
||||||
|
+++ b/src/lib/mapfile.hpp
|
||||||
|
@@ -18,9 +18,9 @@
|
||||||
|
class MapFile {
|
||||||
|
public:
|
||||||
|
MapFile(void) :
|
||||||
|
- data(NULL),
|
||||||
|
+ data(NULL)
|
||||||
|
#ifdef HAVE_MMAP
|
||||||
|
- mmap_fd(-1)
|
||||||
|
+ , mmap_fd(-1)
|
||||||
|
#elif defined(_WIN32)
|
||||||
|
hFile(0),
|
||||||
|
hFileMap(0)
|
||||||
|
diff --git a/src/utils.cpp b/src/utils.cpp
|
||||||
|
index 5e8d562..2e3e55e 100644
|
||||||
|
--- a/src/utils.cpp
|
||||||
|
+++ b/src/utils.cpp
|
||||||
|
@@ -24,6 +24,8 @@
|
||||||
|
|
||||||
|
#include <glib.h>
|
||||||
|
#include <glib/gi18n.h>
|
||||||
|
+#include <stdio.h>
|
||||||
|
+#include <stdlib.h>
|
||||||
|
|
||||||
|
#include "utils.hpp"
|
||||||
|
|
Loading…
Reference in New Issue
Block a user