1
0
mirror of git://projects.qi-hardware.com/openwrt-packages.git synced 2024-07-01 03:22:21 +03:00

[stardict] maybe we need those buttons

This commit is contained in:
Xiangfu Liu 2010-03-03 22:54:26 +08:00
parent f7c7751fd7
commit be4290d743

View File

@ -10,9 +10,9 @@ From: Xiangfu Liu <xiangfu@sharism.cc>
src/class_factory.cpp | 6 ++++
src/conf.cpp | 4 +++
src/desktop.cpp | 2 +
src/mainwin.cpp | 10 +++++++
src/mainwin.cpp | 8 +++++-
src/stardict.cpp | 67 ++++++++++++++++++++++++++++++++++++-------------
7 files changed, 96 insertions(+), 35 deletions(-)
7 files changed, 94 insertions(+), 35 deletions(-)
diff --git a/configure.in b/configure.in
@ -172,7 +172,7 @@ index 9d08caf..4f95bcb 100644
{
gchar *qarg = g_shell_quote(arg);
diff --git a/src/mainwin.cpp b/src/mainwin.cpp
index 7005f7b..0b77b0c 100644
index 7005f7b..f7dac0b 100644
--- a/src/mainwin.cpp
+++ b/src/mainwin.cpp
@@ -129,10 +129,12 @@ void TopWin::Create(GtkWidget *vbox)
@ -188,23 +188,7 @@ index 7005f7b..0b77b0c 100644
button=gtk_button_new();
gtk_container_add(GTK_CONTAINER(button),gtk_image_new_from_stock(GTK_STOCK_HOME,GTK_ICON_SIZE_BUTTON));
@@ -1249,6 +1251,7 @@ void LeftWin::Create(GtkWidget *hbox, bool has_treedict)
gtk_widget_show(vbox);
gtk_box_pack_start(GTK_BOX(hbox),vbox, false, false, 0);
+#ifndef CONFIG_NANONOTE
GtkWidget *wazard_button = gtk_radio_button_new(NULL);
GTK_WIDGET_UNSET_FLAGS (wazard_button, GTK_CAN_FOCUS);
gtk_toggle_button_set_mode(GTK_TOGGLE_BUTTON(wazard_button), false);
@@ -1323,6 +1326,7 @@ void LeftWin::Create(GtkWidget *hbox, bool has_treedict)
g_signal_connect(G_OBJECT(button),"enter_notify_event", G_CALLBACK(stardict_on_enter_notify), NULL);
gtk_box_pack_end(GTK_BOX(vbox),button,false,false,0);
gtk_widget_set_tooltip_text(button,_("Previous word (Alt+Up)"));
+#endif
}
void LeftWin::on_wazard_button_toggled(GtkToggleButton *button, LeftWin *oLeftWin)
@@ -1807,7 +1811,10 @@ void TextWin::ShowTips()
@@ -1807,7 +1809,10 @@ void TextWin::ShowTips()
query_result = TEXT_WIN_TIPS;
view->set_text(
_(" Welcome to StarDict!\n\n"
@ -216,7 +200,7 @@ index 7005f7b..0b77b0c 100644
" Press Alt+C or ESC to clear the input entry's text.\n"
" Press Space key to move focus to the input entry.\n"
" If the query word was not found, you can press Tab key to select the first word in the word list.\n"
@@ -2665,6 +2672,7 @@ void MidWin::Create(GtkWidget *vbox)
@@ -2665,6 +2670,7 @@ void MidWin::Create(GtkWidget *vbox)
notebook = gtk_notebook_new();
gtk_widget_show(notebook);