mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-10 22:39:43 +02:00
octave: fix fortran compile flags, enable parallel compilation
This commit is contained in:
parent
7d8785d261
commit
c33acf0a30
@ -4,6 +4,8 @@
|
|||||||
# License GPLv2 or later. NO WARRANTY.
|
# License GPLv2 or later. NO WARRANTY.
|
||||||
#
|
#
|
||||||
# OpenWRT package for the GNU Octave
|
# OpenWRT package for the GNU Octave
|
||||||
|
#
|
||||||
|
# todo: how do we enable octave's internal help system?
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
@ -14,6 +16,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|||||||
PKG_SOURCE_URL:=ftp://ftp.octave.org/pub/octave/
|
PKG_SOURCE_URL:=ftp://ftp.octave.org/pub/octave/
|
||||||
PKG_MD5SUM:=90c39fa9e241ad2e978bcee4682a2ba9
|
PKG_MD5SUM:=90c39fa9e241ad2e978bcee4682a2ba9
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
|
||||||
PKG_FIXUP:=libtool
|
PKG_FIXUP:=libtool
|
||||||
PKG_REMOVE_FILES:=
|
PKG_REMOVE_FILES:=
|
||||||
@ -72,8 +75,9 @@ endef
|
|||||||
# todo : need -enable-rpath?
|
# todo : need -enable-rpath?
|
||||||
|
|
||||||
OCTAVE_LIB_DIR := /usr/lib
|
OCTAVE_LIB_DIR := /usr/lib
|
||||||
CONFIGURE_ARGS += --without-x --without-fftw
|
CONFIGURE_ARGS += --without-x --without-fftw --disable-docs
|
||||||
CONFIGURE_VARS += octlibdir=$(OCTAVE_LIB_DIR)
|
CONFIGURE_VARS += octlibdir=$(OCTAVE_LIB_DIR) \
|
||||||
|
FFLAGS="$(TARGET_CFLAGS)"
|
||||||
#MAKE_FLAGS += "LD=$(TARGET_CROSS)gcc -nostdlib"
|
#MAKE_FLAGS += "LD=$(TARGET_CROSS)gcc -nostdlib"
|
||||||
|
|
||||||
define Build/Configure
|
define Build/Configure
|
||||||
|
26
octave/patches/015-no-docs.patch
Normal file
26
octave/patches/015-no-docs.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
Index: octave-3.2.4/octMakefile.in
|
||||||
|
===================================================================
|
||||||
|
--- octave-3.2.4.orig/octMakefile.in 2011-06-09 15:22:14.000000000 +0200
|
||||||
|
+++ octave-3.2.4/octMakefile.in 2011-06-09 15:55:36.000000000 +0200
|
||||||
|
@@ -51,10 +51,10 @@
|
||||||
|
mkoctfile.in mkoctfile.cc.in run-octave.in ChangeLog ChangeLog.[0-9]
|
||||||
|
|
||||||
|
# Subdirectories in which to run `make all'.
|
||||||
|
-SUBDIRS = libcruft liboctave src scripts doc examples
|
||||||
|
+SUBDIRS = libcruft liboctave src scripts # doc examples
|
||||||
|
|
||||||
|
# Subdirectories in which to run `make all'.
|
||||||
|
-INSTALL_SUBDIRS = libcruft liboctave src scripts doc examples
|
||||||
|
+INSTALL_SUBDIRS = libcruft liboctave src scripts # doc examples
|
||||||
|
|
||||||
|
# Subdirectories in which to run `make conf-dist'.
|
||||||
|
CONF_DISTSUBDIRS = src
|
||||||
|
@@ -78,7 +78,7 @@
|
||||||
|
|
||||||
|
M4_FILES = $(wildcard *.m4)
|
||||||
|
|
||||||
|
-all: $(SHELL_SCRIPTS) $(filter-out libcruft liboctave, $(SUBDIRS)) dist-info-files
|
||||||
|
+all: $(SHELL_SCRIPTS) $(filter-out libcruft liboctave, $(SUBDIRS)) # dist-info-files
|
||||||
|
@echo ""
|
||||||
|
@echo "Octave successfully built. Now choose from the following:"
|
||||||
|
@echo ""
|
Loading…
Reference in New Issue
Block a user