1
0
mirror of git://projects.qi-hardware.com/openwrt-packages.git synced 2024-06-06 21:55:28 +03:00

vitetris: terminal-based Tetris clone

This commit is contained in:
kyak 2011-06-19 17:26:00 +04:00
parent cd0c7cebcc
commit c8ada0df0d
2 changed files with 57 additions and 0 deletions

47
vitetris/Makefile Normal file
View File

@ -0,0 +1,47 @@
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
include $(TOPDIR)/rules.mk
PKG_NAME:=vitetris
PKG_VERSION:=0.57
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://victornils.net/tetris
PKG_MD5SUM:=07d02ee03e2edd66a8741729e237f21f
include $(INCLUDE_DIR)/package.mk
define Package/vitetris
TITLE:=terminal-based Tetris clone
SECTION:=games
CATEGORY:=Games
URL:=http://victornils.net/tetris
endef
define Package/vitetris/description
vitetris is a terminal-based Tetris clone by Victor Nilsson. It can also run in graphics mode using the Allegro library
endef
CONFIGURE_ARGS= \
--without-xlib \
--without-joystick \
--with-2player \
--with-network \
--with-curses \
--without-allegro \
--with-term_resizing \
--with-menu \
--with-blockstyles \
--with-pctimer
CONFIGURE_VARS+=HOSTCC="$(HOSTCC)" HOST_CFLAGS="$(HOST_CFLAGS)" HOST_CPPFLAGS="$(HOST_CPPFLAGS)"
define Package/vitetris/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/tetris $(1)/usr/bin/vitetris
endef
$(eval $(call BuildPackage,vitetris))

View File

@ -0,0 +1,10 @@
diff --git a/systest.mk b/systest.mk
index 43df066..4affb36 100644
--- a/systest.mk
+++ b/systest.mk
@@ -1,4 +1,4 @@
systest: systest.c
- $(CC) -o systest $(CFLAGS) $(CPPFLAGS) systest.c
+ $(HOSTCC) -o systest $(HOST_CFLAGS) $(HOST_CPPFLAGS) systest.c
clean:
rm -f systest systest.exe