mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-22 00:29:41 +02:00
Small command line time tracker - openwrt port, patched for better help message.
This commit is contained in:
parent
c97f2493eb
commit
d02893d336
43
wtime/Makefile
Normal file
43
wtime/Makefile
Normal file
@ -0,0 +1,43 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=wtime
|
||||
PKG_VERSION:=0.2
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=wtime_0_2.tar.gz
|
||||
PKG_SOURCE_URL:=@SF/wtime
|
||||
PKG_MD5SUM:=59c2d41048706993ca260afcdab337c3
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/wtime
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/wtime
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
DEPENDS:=
|
||||
TITLE:=WTime time tracker
|
||||
URL:=http://wtime.sourceforge.net
|
||||
endef
|
||||
|
||||
define Package/wtime/description
|
||||
Time tracking command-line utility.
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Compile/Default, \
|
||||
)
|
||||
endef
|
||||
|
||||
|
||||
define Package/wtime/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/wtime $(1)/usr/bin/
|
||||
$(INSTALL_DIR) $(1)/root/.wtimed/
|
||||
$(INSTALL_DIR) $(1)/usr/share/
|
||||
$(INSTALL_DIR) $(1)/usr/share/wtime/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/LICENCE $(1)/usr/share/wtime/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,wtime))
|
24
wtime/patches/config.patch
Normal file
24
wtime/patches/config.patch
Normal file
@ -0,0 +1,24 @@
|
||||
--- wtime/config.mk 2006-06-17 14:30:50.000000000 +0200
|
||||
+++ wtimem/config.mk 2010-12-08 20:11:42.933802915 +0100
|
||||
@@ -1,17 +1,11 @@
|
||||
# Customize to fit your system
|
||||
|
||||
-PREFIX = /usr/local
|
||||
+INCLUDES = -I.
|
||||
+LIBS =
|
||||
|
||||
-INCDIR = ${PREFIX}/include
|
||||
-LIBDIR = ${PREFIX}/lib
|
||||
+CFLAGS = -std=c99 -O2
|
||||
+LDFLAGS =
|
||||
|
||||
-INCLUDES = -I. -I${INCDIR} -I/usr/include
|
||||
-LIBS = -L${LIBDIR} -L/usr/lib -lc
|
||||
-
|
||||
-CFLAGS = -std=c99 -O2 ${INCLUDES}
|
||||
-LDFLAGS = ${LIBS}
|
||||
-
|
||||
-CC = gcc
|
||||
CP = cp -f
|
||||
RM = rm -f
|
||||
MKDIR = mkdir
|
12
wtime/patches/wtime.patch
Normal file
12
wtime/patches/wtime.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- wtime/wtime.c 2006-06-17 14:29:37.000000000 +0200
|
||||
+++ wtimem/wtime.c 2010-12-08 20:20:18.692552915 +0100
|
||||
@@ -10,7 +10,8 @@
|
||||
|
||||
typedef enum { EMPTY, STARTED, STOPPED, UNKNOWN } Tstate;
|
||||
|
||||
-char usage[] = "wt [-t task] [-h|-a|-s|-c|-r [<start>[<end>]]]\nFor more info see the man page.\n";
|
||||
+//char usage[] = "wt [-t task] [-h|-a|-s|-c|-r [<start>[<end>]]]\nFor more info see the man page.\n";
|
||||
+char usage[] = "wt [-t task] [-h|-a|-s|-c|-r [<start>[<end>]]]\nExamples:\n wt -a ... start counting\n wt -s ... stop counting\n wt -c ... show running time in seconds\n wt -r ... show spent time in seconds\n";
|
||||
|
||||
static int fgetlastl(FILE * fd, char *lbuf, int size)
|
||||
{
|
Loading…
Reference in New Issue
Block a user