mirror of
git://projects.qi-hardware.com/openwrt-packages.git
synced 2024-11-16 21:17:32 +02:00
offrss: update to 1.0
This commit is contained in:
parent
3065078724
commit
d0b6d45411
@ -1,13 +1,11 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=offrss
|
PKG_NAME:=offrss
|
||||||
PKG_VERSION:=trunk
|
PKG_VERSION:=1.0
|
||||||
PKG_RELEASE:=1
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=http://vicerveza.homeunix.net/~viric/soft/offrss/
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
|
|
||||||
PKG_SOURCE_URL:=http://downloads.qi-hardware.com/software/mirror-openwrt-sources/
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
UNPACK_CMD=unzip $(DL_DIR)/$(PKG_SOURCE) -d $(1)/../
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
include $(INCLUDE_DIR)/nls.mk
|
include $(INCLUDE_DIR)/nls.mk
|
||||||
@ -28,10 +26,6 @@ define Package/offrss/description
|
|||||||
offrss - Offline RSS reader
|
offrss - Offline RSS reader
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Compile
|
|
||||||
$(call Build/Compile/Default)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/offrss/install
|
define Package/offrss/install
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
$(INSTALL_BIN) ./files/offrss $(1)/usr/bin
|
$(INSTALL_BIN) ./files/offrss $(1)/usr/bin
|
||||||
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/Makefile b/Makefile
|
|
||||||
index ff2e231..8414bae 100644
|
|
||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -1,7 +1,7 @@
|
|
||||||
VERSION=$(shell if test -f manifest.uuid; then cat manifest.uuid | cut -c -10 ; else echo undefined; fi)
|
|
||||||
|
|
||||||
offrss: offrss.c server.c encoding.c util.c
|
|
||||||
- gcc -DVERSION="$(VERSION)" -g -o $@ $^ -lmrss -lcurl
|
|
||||||
+ $(CC) $(CFLAGS) $(LDFLAGS) -DVERSION="$(VERSION)" -g -o $@ $^ -lmrss -lcurl
|
|
||||||
|
|
||||||
offrss.c: offrss.h
|
|
||||||
server.c: offrss.h
|
|
Loading…
Reference in New Issue
Block a user